Bug 1207735 - Disperse volume: Huge memory leak of glusterfsd process [NEEDINFO]
Summary: Disperse volume: Huge memory leak of glusterfsd process
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: GlusterFS
Classification: Community
Component: disperse
Version: mainline
Hardware: All
OS: All
high
urgent
Target Milestone: ---
Assignee: Pranith Kumar K
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks: qe_tracker_everglades 1224177 1229282 1247964 1259697
TreeView+ depends on / blocked
 
Reported: 2015-03-31 15:11 UTC by Bhaskarakiran
Modified: 2016-11-23 23:13 UTC (History)
11 users (show)

Fixed In Version: glusterfs-3.8rc2
Doc Type: Bug Fix
Doc Text:
Clone Of:
: 1224177 1229282 1247964 1259697 (view as bug list)
Environment:
Last Closed: 2016-06-16 12:46:47 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
atalur: needinfo? (byarlaga)


Attachments (Terms of Use)
statedump of node1 (3.95 MB, application/zip)
2015-03-31 15:11 UTC, Bhaskarakiran
no flags Details
statedump of node2 (3.94 MB, application/zip)
2015-03-31 15:18 UTC, Bhaskarakiran
no flags Details

Description Bhaskarakiran 2015-03-31 15:11:28 UTC
Created attachment 1009107 [details]
statedump of node1

Description of problem:
=======================
There's a huge memory leak in glusterfsd process with disperse volume. Created a plain disperse volume and converted to distributed-disperse. There's no IO from the clients but seeing the resident memory reaching upto 20GB as seen from top command for the glusterfsd process and the system becomes unresponsive as the whole memory gets consumed.

Version-Release number of selected component (if applicable):
=============================================================
[root@vertigo geo-master]# gluster --version
glusterfs 3.7dev built on Mar 31 2015 01:05:54
Repository revision: git://git.gluster.com/glusterfs.git
Copyright (c) 2006-2011 Gluster Inc. <http://www.gluster.com>
GlusterFS comes with ABSOLUTELY NO WARRANTY.
You may redistribute copies of GlusterFS under the terms of the GNU General Public License.

Additional info:
================
Top output of node1:

  PID USER      PR  NI  VIRT  RES  SHR S %CPU %MEM    TIME+  COMMAND               
 9902 root      20   0 4321m 1.4g 2920 D 20.0  4.5   1:28.68 glusterfsd            
10758 root      20   0 4321m 1.4g 2920 D 18.4  4.5   1:26.33 glusterfsd            
10053 root      20   0 4961m 1.6g 2920 D 18.1  5.2   1:28.64 glusterfsd            
10729 root      20   0 3681m 1.0g 2920 D 17.1  3.3   1:26.60 glusterfsd            
10759 root      20   0 4321m 1.4g 2920 S 17.1  4.5   1:25.68 glusterfsd            
10756 root      20   0 3745m 1.4g 2920 S 16.4  4.6   1:30.05 glusterfsd            
 9939 root      20   0 4321m 1.4g 2920 S 16.4  4.5   1:27.61 glusterfsd            
10775 root      20   0 4961m 1.6g 2920 D 15.8  5.2   1:26.52 glusterfsd            
10723 root      20   0 3745m 1.4g 2920 S 15.8  4.6   1:32.41 glusterfsd            
10728 root      20   0 34.0g  19g 2920 S 15.8 63.3   1:31.89 glusterfsd            
10054 root      20   0 3681m 1.0g 2920 D 15.8  3.3   1:28.10 glusterfsd            
10090 root      20   0 3681m 1.0g 2920 S 15.8  3.3   1:33.02 glusterfsd            
10789 root      20   0 3681m 1.0g 2920 D 15.8  3.3   1:26.16 glusterfsd            
10739 root      20   0 4961m 1.6g 2920 D 15.4  5.2   1:31.29 glusterfsd            
10763 root      20   0 4961m 1.6g 2920 S 15.4  5.2   1:27.03 glusterfsd            
10727 root      20   0 34.0g  19g 2920 S 15.4 63.3   1:31.35 glusterfsd            
10782 root      20   0 34.0g  19g 2920 S 15.4 63.3   1:31.86 glusterfsd            
10062 root      20   0 3425m 1.1g 2920 S 15.4  3.5   1:44.85 glusterfsd            
10783 root      20   0 3681m 1.0g 2920 D 15.4  3.3   1:26.73 glusterfsd            
 9940 root      20   0 4321m 1.4g 2920 S 15.4  4.5   1:28.84 glusterfsd            
10724 root      20   0 4321m 1.4g 2920 D 15.4  4.5   1:25.27 glusterfsd            
10753 root      20   0 4321m 1.4g 2920 S 15.4  4.5   1:26.44 glusterfsd            
10733 root      20   0 3745m 1.4g 2920 R 15.1  4.6   1:28.42 glusterfsd            
10755 root      20   0 3745m 1.4g 2920 S 15.1  4.6   1:31.19 glusterfsd            
10091 root      20   0 34.0g  19g 2920 S 15.1 63.3   1:33.56 glusterfsd            
10778 root      20   0 34.0g  19g 2920 S 15.1 63.3   1:31.88 glusterfsd            
 9894 root      20   0 3681m 1.0g 2920 D 15.1  3.3   1:32.51 glusterfsd            
10736 root      20   0 3681m 1.0g 2920 S 15.1  3.3   1:27.33 glusterfsd            
10746 root      20   0 4321m 1.4g 2920 D 15.1  4.5   1:25.14 glusterfsd            
10744 root      20   0 4961m 1.6g 2920 S 14.8  5.2   1:29.22 glusterfsd            
10743 root      20   0 3745m 1.4g 2920 S 14.8  4.6   1:29.96 glusterfsd            
10784 root      20   0 34.0g  19g 2920 S 14.8 63.3   1:31.92 glusterfsd            
 9735 root      20   0 4961m 1.6g 2920 S 14.4  5.2   1:28.84 glusterfsd            
 9903 root      20   0 4961m 1.6g 2920 S 14.4  5.2   1:28.63 glusterfsd    

Attaching the statedumps of the volumes.

Comment 1 Bhaskarakiran 2015-03-31 15:18:11 UTC
Created attachment 1009111 [details]
statedump of node2

Comment 2 Bhaskarakiran 2015-05-05 05:17:36 UTC
On recent builds, seeing bricks and nfs servers getting crashed with OOM messages. sequence of events that happen are :

1. client mount hangs
2. brick crashes
3. export of volume is not shown with rpcinfo
4. nfs server crashes with OOM.

Comment 3 Xavi Hernandez 2015-05-06 16:03:14 UTC
I've tried to reproduce this issue with current master and I've been unable.

Do you do anything else besides the add-brick and rebalance ?

Comment 4 Bhaskarakiran 2015-05-13 10:14:49 UTC
Even with the plain disperse volume and nfs mount the issue persists on 3.7 beta2 build. NFS mounted the volume and ran iozone -a couple of times and seeing the leak. The process is taking almost 40g.

14314 root      20   0 17.1g 8.0g 2528 S 20.0 12.7  41:15.49 glusterfsd                            
14396 root      20   0 17.1g 8.0g 2528 S 19.4 12.7  42:16.27 glusterfsd                            
14397 root      20   0 17.1g 8.0g 2528 S 19.4 12.7  43:34.59 glusterfsd                            
14721 root      20   0 17.1g 8.0g 2528 S 19.4 12.7  43:08.11 glusterfsd                            
14697 root      20   0 17.1g 8.0g 2528 S 19.0 12.7  41:04.22 glusterfsd                            
14702 root      20   0 17.1g 8.0g 2528 S 19.0 12.7  41:13.08 glusterfsd                            
14722 root      20   0 17.1g 8.0g 2528 S 19.0 12.7  40:32.11 glusterfsd                            
14713 root      20   0 65.3g  40g 2528 S 18.7 64.5  40:38.43 glusterfsd  >>>>>>>>>>>>>>>>>>>>>>>                          
14735 root      20   0 65.3g  40g 2528 S 18.7 64.5  41:52.18 glusterfsd  >>>>>>>>>>>>>>>>>>>>>>>                          
14392 root      20   0 17.1g 8.0g 2528 S 18.7 12.7  43:33.64 glusterfsd                            
14704 root      20   0 17.1g 8.0g 2528 S 18.7 12.7  41:59.24 glusterfsd                            
14714 root      20   0 65.3g  40g 2528 S 18.4 64.5  39:08.16 glusterfsd  >>>>>>>>>>>>>>>>>>>>>>>                            
14737 root      20   0 65.3g  40g 2528 S 18.4 64.5  41:03.79 glusterfsd                            
14701 root      20   0 17.1g 8.0g 2528 S 18.4 12.7  41:18.25 glusterfsd                            
14684 root      20   0 10.3g 4.4g 2532 S 18.4  7.0  38:15.19 glusterfsd                            
14388 root      20   0 65.3g  40g 2528 S 18.1 64.5  40:20.30 glusterfsd  >>>>>>>>>>>>>>>>>>>>>>>                            
14716 root      20   0 65.3g  40g 2528 R 18.1 64.5  40:24.51 glusterfsd  >>>>>>>>>>>>>>>>>>>>>>>                            
14736 root      20   0 65.3g  40g 2528 R 18.1 64.5  38:40.43 glusterfsd  >>>>>>>>>>>>>>>>>>>>>>>                            
14703 root      20   0 17.1g 8.0g 2528 S 18.1 12.7  41:06.25 glusterfsd                            
14331 root      20   0 10.3g 4.4g 2532 S 18.1  7.0  38:29.85 glusterfsd                            
14294 root      20   0 65.3g  40g 2528 R 17.7 64.5  38:03.70 glusterfsd  >>>>>>>>>>>>>>>>>>>>>>>                            
14395 root      20   0 65.3g  40g 2528 R 17.7 64.5  38:51.38 glusterfsd  >>>>>>>>>>>>>>>>>>>>>>>                            
14705 root      20   0 17.1g 8.0g 2528 S 17.7 12.7  43:05.49 glusterfsd                            
14723 root      20   0 17.1g 8.0g 2528 R 17.7 12.7  42:20.05 glusterfsd                            
14740 root      20   0 17.1g 8.0g 2528 S 17.7 12.7  39:55.02 glusterfsd                            
14389 root      20   0 10.3g 4.4g 2532 S 17.7  7.0  39:52.06 glusterfsd                            
14675 root      20   0 10.3g 4.4g 2532 S 17.7  7.0  38:26.46 glusterfsd                            
14678 root      20   0 65.3g  40g 2528 S 17.4 64.5  40:18.39 glusterfsd  >>>>>>>>>>>>>>>>>>>>>>>                            
14734 root      20   0 65.3g  40g 2528 S 17.4 64.5  39:07.99 glusterfsd  >>>>>>>>>>>>>>>>>>>>>>>                            
14328 root      20   0 10.3g 4.4g 2532 S 17.4  7.0  38:01.29 glusterfsd                            
14393 root      20   0 10.3g 4.4g 2532 S 17.4  7.0  39:14.94 glusterfsd                            
14683 root      20   0 10.3g 4.4g 2532 S 17.4  7.0  38:10.70 glusterfsd                            
14696 root      20   0 65.3g  40g 2528 S 17.1 64.5  39:26.60 glusterfsd  >>>>>>>>>>>>>>>>>>>>>>>                            
14390 root      20   0 17.1g 8.0g 2528 S 17.1 12.7  41:03.34 glusterfsd                            
14724 root      20   0 17.1g 8.0g 2528 S 17.1 12.7  41:06.26 glusterfsd                            
14329 root      20   0 10.3g 4.4g 2532 S 17.1  7.0  38:46.04 glusterfsd                            
14712 root      20   0 10.3g 4.4g 2532 S 17.1  7.0  38:18.10 glusterfsd                            
14297 root      20   0 65.3g  40g 2528 S 16.7 64.5  40:29.80 glusterfsd  >>>>>>>>>>>>>>>>>>>>>>>                           
14670 root      20   0 65.3g  40g 2528 S 16.7 64.5  39:24.16 glusterfsd  >>>>>>>>>>>>>>>>>>>>>>>                            
14700 root      20   0 65.3g  40g 2528 R 16.7 64.5  40:00.28 glusterfsd  >>>>>>>>>>>>>>>>>>>>>>>                            
14715 root      20   0 65.3g  40g 2528 S 16.7 64.5  40:53.39 glusterfsd  >>>>>>>>>>>>>>>>>>>>>>>                            
14311 root      20   0 17.1g 8.0g 2528 S 16.7 12.7  39:05.23 glusterfsd                            
14706 root      20   0 10.3g 4.4g 2532 S 16.7  7.0  37:28.30 glusterfsd                            
14707 root      20   0 10.3g 4.4g 2532 S 16.7  7.0  37:52.83 glusterfsd

Comment 5 Xavi Hernandez 2015-05-14 07:18:35 UTC
Thanks, I'll try again with NFS and iozone.

Comment 6 Anuradha 2015-05-22 11:37:03 UTC
Bhaskarakiran,

Do you have sos-reports corresponding to the statedump attached? I need to go through logs to understand the state of the system.

Comment 7 Anand Avati 2015-06-02 11:24:57 UTC
REVIEW: http://review.gluster.org/11044 (fd: Do fd_bind on successful open) posted (#1) for review on master by Pranith Kumar Karampuri (pkarampu@redhat.com)

Comment 8 Pranith Kumar K 2015-06-02 11:25:46 UTC
This patch only fixes wrong fd_count being shown in statedump because fd_binds were not happening. Still looking into more fd leaks.

Comment 9 Anand Avati 2015-06-02 11:50:04 UTC
REVIEW: http://review.gluster.org/11044 (fd: Do fd_bind on successful open) posted (#2) for review on master by Pranith Kumar Karampuri (pkarampu@redhat.com)

Comment 10 Anand Avati 2015-06-02 12:29:01 UTC
REVIEW: http://review.gluster.org/11045 (features/quota: Fix ref-leak) posted (#1) for review on master by Pranith Kumar Karampuri (pkarampu@redhat.com)

Comment 11 Anand Avati 2015-06-04 04:42:30 UTC
COMMIT: http://review.gluster.org/11045 committed in master by Raghavendra G (rgowdapp@redhat.com) 
------
commit 2b7ae84a5feb636f0e41d0ab36c04b7f3fbce520
Author: Pranith Kumar K <pkarampu@redhat.com>
Date:   Tue Jun 2 17:58:00 2015 +0530

    features/quota: Fix ref-leak
    
    Change-Id: I0b44b70f07be441e044d9dfc5c2b64bd5b4cac18
    BUG: 1207735
    Signed-off-by: Pranith Kumar K <pkarampu@redhat.com>
    Reviewed-on: http://review.gluster.org/11045
    Tested-by: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Raghavendra G <rgowdapp@redhat.com>
    Tested-by: Raghavendra G <rgowdapp@redhat.com>

Comment 12 Anand Avati 2015-06-19 10:48:03 UTC
COMMIT: http://review.gluster.org/11311 committed in master by Raghavendra G (rgowdapp@redhat.com) 
------
commit 8ab6608accb62d6320d1fc1fbe651fcafd376270
Author: vmallika <vmallika@redhat.com>
Date:   Thu Jun 18 14:30:16 2015 +0530

    quota/marker: fix mem-leak, free contribution node
    
    When removing contribution xattr, we also need to free
    contribution node in memory
    
    Change-Id: I5fe97813a8f39e2f00401976046bd280f2eea54d
    BUG: 1207735
    Signed-off-by: vmallika <vmallika@redhat.com>
    Reviewed-on: http://review.gluster.org/11311
    Reviewed-by: Raghavendra G <rgowdapp@redhat.com>
    Tested-by: Raghavendra G <rgowdapp@redhat.com>

Comment 13 Vijaikumar Mallikarjuna 2015-06-23 06:55:21 UTC
Patch #11311 can cause memory corruption or crash because of accessing already freed contribution node.
We need to fix this with ref/unref mechanism of cleaning contribution node

Comment 14 Anand Avati 2015-06-23 06:59:49 UTC
REVIEW: http://review.gluster.org/11361 (quota/marker: fix mem-leak in marker) posted (#1) for review on master by Vijaikumar Mallikarjuna (vmallika@redhat.com)

Comment 15 Anand Avati 2015-06-23 07:04:01 UTC
REVIEW: http://review.gluster.org/11362 (Revert "quota/marker: fix mem-leak, free contribution node") posted (#1) for review on master by Raghavendra Bhat (raghavendra@redhat.com)

Comment 16 Raghavendra G 2015-06-23 07:06:12 UTC
Patch #11361, resulted in a memory corruption:

http://build.gluster.org/job/rackspace-regression-2GB-triggered/11193/consoleFull

 #0  0x00007f6d5f53c420 in uuid_unpack (in=0xffffffffffffff28 <Address 0xffffffffffffff28 out of bounds>, 
     uu=0x7f6d4040da70) at /home/jenkins/root/workspace/rackspace-regression-2GB-triggered/contrib/uuid/unpack.c:43
 #1  0x00007f6d5f53be0a in gf_uuid_unparse_x (uu=0xffffffffffffff28 <Address 0xffffffffffffff28 out of bounds>, 
     out=0x7f6d4040daf0 "bcaa777a-939a-49de-b41c-0eaa27cb8e02", 
     fmt=0x7f6d5f54eb38 "%08x-%04x-%04x-%02x%02x-%02x%02x%02x%02x%02x%02x")
     at /home/jenkins/root/workspace/rackspace-regression-2GB-triggered/contrib/uuid/unparse.c:55
 #2  0x00007f6d5f53bf2e in gf_uuid_unparse (uu=0xffffffffffffff28 <Address 0xffffffffffffff28 out of bounds>, 
     out=0x7f6d4040daf0 "bcaa777a-939a-49de-b41c-0eaa27cb8e02")
     at /home/jenkins/root/workspace/rackspace-regression-2GB-triggered/contrib/uuid/unparse.c:75
10:27 <nbalacha> #3  0x00007f6d5067a200 in mq_inspect_file_xattr_task (opaque=0x7f6d4020db30)

we are accessing contribution->gfid here. Seems like contribution is corrupted. This can happen if contribution object is being used by someone else when we free it.

Comment 17 Raghavendra G 2015-06-23 07:07:45 UTC
s/patch #11361/patch #11311/

Comment 18 Anand Avati 2015-06-23 07:12:32 UTC
REVIEW: http://review.gluster.org/11361 (quota/marker: fix mem-leak in marker) posted (#2) for review on master by Vijaikumar Mallikarjuna (vmallika@redhat.com)

Comment 19 Anand Avati 2015-06-23 08:27:11 UTC
REVIEW: http://review.gluster.org/11361 (quota/marker: fix mem-leak in marker) posted (#3) for review on master by Vijaikumar Mallikarjuna (vmallika@redhat.com)

Comment 20 Anand Avati 2015-06-23 09:24:41 UTC
REVIEW: http://review.gluster.org/11361 (quota/marker: fix mem-leak in marker) posted (#4) for review on master by Vijaikumar Mallikarjuna (vmallika@redhat.com)

Comment 21 Anand Avati 2015-06-23 09:36:38 UTC
REVIEW: http://review.gluster.org/11361 (quota/marker: fix mem-leak in marker) posted (#5) for review on master by Vijaikumar Mallikarjuna (vmallika@redhat.com)

Comment 22 Anand Avati 2015-06-24 06:11:04 UTC
REVIEW: http://review.gluster.org/11362 (Revert "quota/marker: fix mem-leak, free contribution node") posted (#2) for review on master by Raghavendra G (rgowdapp@redhat.com)

Comment 23 Anand Avati 2015-06-24 06:11:16 UTC
REVIEW: http://review.gluster.org/11362 (Revert "quota/marker: fix mem-leak, free contribution node") posted (#3) for review on master by Raghavendra G (rgowdapp@redhat.com)

Comment 24 Anand Avati 2015-06-24 06:11:53 UTC
COMMIT: http://review.gluster.org/11362 committed in master by Raghavendra G (rgowdapp@redhat.com) 
------
commit 01e42f25ebdc44847e8b1dce02f7fd486b40dbc2
Author: Raghavendra Bhat <raghavendra@redhat.com>
Date:   Tue Jun 23 00:25:38 2015 +0530

    Revert "quota/marker: fix mem-leak, free contribution node"
    
    This reverts commit 8ab6608accb62d6320d1fc1fbe651fcafd376270.
    
    This patch is resulting in memory corruption:
    http://build.gluster.org/job/rackspace-regression-2GB-triggered/11193/consoleFull
    
    contribution object might be being used by some other transaction when
    we free it. The correct way to handle this is to have a reference based
    scheme to manage the contribution object.
    
    Change-Id: Idf9993ed8268029073a3e2d699865587f20d9aea
    BUG: 1207735
    Signed-off-by: Raghavendra Bhat <raghavendra@redhat.com>
    Reviewed-on: http://review.gluster.org/11362
    Reviewed-by: Raghavendra G <rgowdapp@redhat.com>
    Tested-by: Raghavendra G <rgowdapp@redhat.com>

Comment 25 Anand Avati 2015-06-24 06:36:23 UTC
REVIEW: http://review.gluster.org/11361 (quota/marker: fix mem-leak in marker) posted (#7) for review on master by Vijaikumar Mallikarjuna (vmallika@redhat.com)

Comment 26 Vijaikumar Mallikarjuna 2015-06-25 09:07:15 UTC
Patch merged: http://review.gluster.org/#/c/11361/

Comment 28 Anand Avati 2015-06-29 13:49:28 UTC
REVIEW: http://review.gluster.org/11457 (quota/marker: improve locking in create_xattr_txn) posted (#1) for review on master by Vijaikumar Mallikarjuna (vmallika@redhat.com)

Comment 29 Anand Avati 2015-06-29 16:46:50 UTC
REVIEW: http://review.gluster.org/11457 (quota/marker: improve locking in create_xattr_txn) posted (#2) for review on master by Vijaikumar Mallikarjuna (vmallika@redhat.com)

Comment 30 Anand Avati 2015-06-29 16:53:38 UTC
REVIEW: http://review.gluster.org/11457 (quota/marker: improve locking in create_xattr_txn) posted (#3) for review on master by Vijaikumar Mallikarjuna (vmallika@redhat.com)

Comment 31 Anand Avati 2015-06-30 01:42:34 UTC
REVIEW: http://review.gluster.org/11457 (quota/marker: fix mem leak in marker) posted (#4) for review on master by Vijaikumar Mallikarjuna (vmallika@redhat.com)

Comment 32 Anand Avati 2015-06-30 16:45:56 UTC
REVIEW: http://review.gluster.org/11457 (quota/marker: fix mem leak in marker) posted (#5) for review on master by Vijaikumar Mallikarjuna (vmallika@redhat.com)

Comment 33 Anand Avati 2015-07-02 06:55:55 UTC
REVIEW: http://review.gluster.org/11499 (quota/marker: use smaller stacksize in synctask for marker updation) posted (#1) for review on master by Vijaikumar Mallikarjuna (vmallika@redhat.com)

Comment 34 Anand Avati 2015-07-02 13:38:53 UTC
REVIEW: http://review.gluster.org/11499 (quota/marker: use smaller stacksize in synctask for marker updation) posted (#2) for review on master by Vijaikumar Mallikarjuna (vmallika@redhat.com)

Comment 35 Anand Avati 2015-07-02 16:04:26 UTC
REVIEW: http://review.gluster.org/11457 (quota/marker: fix mem leak in marker) posted (#6) for review on master by Vijaikumar Mallikarjuna (vmallika@redhat.com)

Comment 36 Anand Avati 2015-07-02 18:07:22 UTC
REVIEW: http://review.gluster.org/11457 (quota/marker: fix mem leak in marker) posted (#7) for review on master by Vijaikumar Mallikarjuna (vmallika@redhat.com)

Comment 37 Anand Avati 2015-07-03 09:49:14 UTC
REVIEW: http://review.gluster.org/11522 (posix: fix mem-leak in posix_get_ancestry error path) posted (#1) for review on master by Vijaikumar Mallikarjuna (vmallika@redhat.com)

Comment 38 Anand Avati 2015-07-03 10:07:26 UTC
REVIEW: http://review.gluster.org/11457 (quota/marker: fix mem leak in marker) posted (#8) for review on master by Vijaikumar Mallikarjuna (vmallika@redhat.com)

Comment 39 Anand Avati 2015-07-03 12:04:41 UTC
REVIEW: http://review.gluster.org/11526 (quota: fix mem leak in quota enforcer) posted (#1) for review on master by Vijaikumar Mallikarjuna (vmallika@redhat.com)

Comment 40 Anand Avati 2015-07-06 05:30:44 UTC
REVIEW: http://review.gluster.org/11499 (quota/marker: use smaller stacksize in synctask for marker updation) posted (#3) for review on master by Vijaikumar Mallikarjuna (vmallika@redhat.com)

Comment 41 Anand Avati 2015-07-06 16:18:54 UTC
COMMIT: http://review.gluster.org/11522 committed in master by Raghavendra G (rgowdapp@redhat.com) 
------
commit a95f5651b8e2159eedb2ab87e2253a233d3ecfe7
Author: vmallika <vmallika@redhat.com>
Date:   Fri Jul 3 15:16:57 2015 +0530

    posix: fix mem-leak in posix_get_ancestry error path
    
    Change-Id: I47c8a8f170151f6374fc0420278aedf3ff5443ee
    BUG: 1207735
    Signed-off-by: vmallika <vmallika@redhat.com>
    Reviewed-on: http://review.gluster.org/11522
    Reviewed-by: Krishnan Parthasarathi <kparthas@redhat.com>
    Reviewed-by: Sachin Pandit <spandit@redhat.com>
    Reviewed-by: Raghavendra G <rgowdapp@redhat.com>
    Tested-by: Raghavendra G <rgowdapp@redhat.com>

Comment 42 Anand Avati 2015-07-07 14:24:46 UTC
REVIEW: http://review.gluster.org/11499 (quota/marker: use smaller stacksize in synctask for marker updation) posted (#4) for review on master by Vijaikumar Mallikarjuna (vmallika@redhat.com)

Comment 43 Anand Avati 2015-07-08 00:35:29 UTC
REVIEW: http://review.gluster.org/11457 (quota/marker: fix mem leak in marker) posted (#9) for review on master by Vijaikumar Mallikarjuna (vmallika@redhat.com)

Comment 44 Anand Avati 2015-07-08 06:35:21 UTC
REVIEW: http://review.gluster.org/11499 (quota/marker: use smaller stacksize in synctask for marker updation) posted (#5) for review on master by Vijaikumar Mallikarjuna (vmallika@redhat.com)

Comment 45 Anand Avati 2015-07-09 01:32:12 UTC
REVIEW: http://review.gluster.org/11457 (quota/marker: fix mem leak in marker) posted (#10) for review on master by Vijaikumar Mallikarjuna (vmallika@redhat.com)

Comment 46 Anand Avati 2015-07-09 04:57:45 UTC
REVIEW: http://review.gluster.org/11588 (posix: check for NULL inode in posix do_xattrop) posted (#1) for review on master by Vijaikumar Mallikarjuna (vmallika@redhat.com)

Comment 47 Anand Avati 2015-07-09 07:18:43 UTC
REVIEW: http://review.gluster.org/11457 (quota/marker: fix mem leak in marker) posted (#12) for review on master by Vijaikumar Mallikarjuna (vmallika@redhat.com)

Comment 48 Anand Avati 2015-07-09 08:13:14 UTC
REVIEW: http://review.gluster.org/11457 (quota/marker: fix mem leak in marker) posted (#13) for review on master by Vijaikumar Mallikarjuna (vmallika@redhat.com)

Comment 49 Anand Avati 2015-07-09 08:21:52 UTC
REVIEW: http://review.gluster.org/11457 (quota/marker: fix mem leak in marker) posted (#14) for review on master by Vijaikumar Mallikarjuna (vmallika@redhat.com)

Comment 50 Anand Avati 2015-07-09 08:40:04 UTC
REVIEW: http://review.gluster.org/11457 (quota/marker: fix mem leak in marker) posted (#15) for review on master by Vijaikumar Mallikarjuna (vmallika@redhat.com)

Comment 51 Anand Avati 2015-07-09 09:33:36 UTC
REVIEW: http://review.gluster.org/11457 (quota/marker: fix mem leak in marker) posted (#16) for review on master by Vijaikumar Mallikarjuna (vmallika@redhat.com)

Comment 52 Anand Avati 2015-07-10 11:08:10 UTC
REVIEW: http://review.gluster.org/11617 (quota/marker: fix mem-leak in marker) posted (#1) for review on master by Vijaikumar Mallikarjuna (vmallika@redhat.com)

Comment 53 Anand Avati 2015-07-10 13:06:27 UTC
REVIEW: http://review.gluster.org/11616 (quota/marker: inspect file/dir invoked without having quota xattrs requested) posted (#2) for review on master by Vijaikumar Mallikarjuna (vmallika@redhat.com)

Comment 54 Anand Avati 2015-07-12 15:34:50 UTC
REVIEW: http://review.gluster.org/11617 (quota/marker: fix mem-leak in marker) posted (#2) for review on master by Vijaikumar Mallikarjuna (vmallika@redhat.com)

Comment 55 Anand Avati 2015-07-13 11:46:30 UTC
REVIEW: http://review.gluster.org/11617 (quota/marker: fix mem-leak in marker) posted (#3) for review on master by Vijaikumar Mallikarjuna (vmallika@redhat.com)

Comment 56 Anand Avati 2015-07-13 11:53:48 UTC
REVIEW: http://review.gluster.org/11617 (quota/marker: fix mem-leak in marker) posted (#4) for review on master by Vijaikumar Mallikarjuna (vmallika@redhat.com)

Comment 57 Anand Avati 2015-07-14 09:59:56 UTC
COMMIT: http://review.gluster.org/11617 committed in master by Raghavendra G (rgowdapp@redhat.com) 
------
commit e73db5e7fe1dba5a071725ef3480a4a1d5c7bef7
Author: vmallika <vmallika@redhat.com>
Date:   Sun Jul 12 21:03:54 2015 +0530

    quota/marker: fix mem-leak in marker
    
    Free local in error paths
    
    Change-Id: I76f69e7d746af8eedea34354ff5a6bf50234e50e
    BUG: 1207735
    Signed-off-by: vmallika <vmallika@redhat.com>
    Reviewed-on: http://review.gluster.org/11617
    Tested-by: NetBSD Build System <jenkins@build.gluster.org>
    Tested-by: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Raghavendra G <rgowdapp@redhat.com>

Comment 58 Anand Avati 2015-07-16 02:20:01 UTC
REVIEW: http://review.gluster.org/11044 (fd: Do fd_bind on successful open) posted (#3) for review on master by Pranith Kumar Karampuri (pkarampu@redhat.com)

Comment 59 Anand Avati 2015-08-26 05:13:11 UTC
REVIEW: http://review.gluster.org/11044 (fd: Do fd_bind on successful open) posted (#4) for review on master by Pranith Kumar Karampuri (pkarampu@redhat.com)

Comment 60 Anand Avati 2015-08-28 17:26:23 UTC
COMMIT: http://review.gluster.org/11044 committed in master by Raghavendra G (rgowdapp@redhat.com) 
------
commit e55579bdb1d04cca29f3e87427de5f2a5ab5e9b4
Author: Pranith Kumar K <pkarampu@redhat.com>
Date:   Tue Jun 2 16:39:35 2015 +0530

    fd: Do fd_bind on successful open
    
    - fd_unref should decrement fd->inode->fd_count only if it is present in the
    inode's fd list.
    - successful open/opendir should perform fd_bind.
    
    Change-Id: I81dd04f330e2fee86369a6dc7147af44f3d49169
    BUG: 1207735
    Signed-off-by: Pranith Kumar K <pkarampu@redhat.com>
    Reviewed-on: http://review.gluster.org/11044
    Reviewed-by: Anoop C S <anoopcs@redhat.com>
    Tested-by: NetBSD Build System <jenkins@build.gluster.org>
    Tested-by: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Raghavendra G <rgowdapp@redhat.com>

Comment 61 Nagaprasad Sathyanarayana 2015-10-25 15:00:47 UTC
Fix for this BZ is already present in a GlusterFS release. You can find clone of this BZ, fixed in a GlusterFS release and closed. Hence closing this mainline BZ as well.

Comment 62 Niels de Vos 2016-06-16 12:46:47 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.8.0, please open a new bug report.

glusterfs-3.8.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://blog.gluster.org/2016/06/glusterfs-3-8-released/
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user


Note You need to log in before you can comment on or make changes to this bug.