Bug 1247964 - Disperse volume: Huge memory leak of glusterfsd process
Disperse volume: Huge memory leak of glusterfsd process
Status: CLOSED CURRENTRELEASE
Product: GlusterFS
Classification: Community
Component: quota (Show other bugs)
3.6.5
All All
high Severity urgent
: ---
: ---
Assigned To: Vijaikumar Mallikarjuna
: Triaged
Depends On: 1207735 1259697
Blocks: glusterfs-3.6.5
  Show dependency treegraph
 
Reported: 2015-07-29 06:58 EDT by Vijaikumar Mallikarjuna
Modified: 2016-05-11 18:48 EDT (History)
11 users (show)

See Also:
Fixed In Version: glusterfs-3.6.5
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 1207735
Environment:
Last Closed: 2015-08-27 09:06:39 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Comment 1 Anand Avati 2015-08-17 08:38:21 EDT
REVIEW: http://review.gluster.org/11793 (quota: fix mem leak in quota enforcer) posted (#2) for review on release-3.6 by Raghavendra Bhat (raghavendra@redhat.com)
Comment 2 Anand Avati 2015-08-18 06:39:14 EDT
COMMIT: http://review.gluster.org/11793 committed in release-3.6 by Raghavendra Bhat (raghavendra@redhat.com) 
------
commit df3f1d9926bf3e7a481391182aa967f0154634a3
Author: vmallika <vmallika@redhat.com>
Date:   Wed Jul 29 16:26:12 2015 +0530

    quota: fix mem leak in quota enforcer
    
    This is a backport of http://review.gluster.org/#/c/11526/
    
    Do inode_unref on parent
    
    > Change-Id: I21d82eb8716dd73aa2dc291b3ae8506e4fb4ea8b
    > BUG: 1207735
    > Signed-off-by: vmallika <vmallika@redhat.com>
    > Reviewed-on: http://review.gluster.org/11526
    > Reviewed-by: Krishnan Parthasarathi <kparthas@redhat.com>
    > Tested-by: Gluster Build System <jenkins@build.gluster.com>
    > Tested-by: NetBSD Build System <jenkins@build.gluster.org>
    > Reviewed-by: Raghavendra G <rgowdapp@redhat.com>
    > Tested-by: Raghavendra G <rgowdapp@redhat.com>
    
    Change-Id: I8f103ea96e6853d48c934b791ff4d95b226e4453
    BUG: 1247964
    Signed-off-by: vmallika <vmallika@redhat.com>
    Reviewed-on: http://review.gluster.org/11793
    Tested-by: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Raghavendra Bhat <raghavendra@redhat.com>
Comment 3 Raghavendra Bhat 2015-08-27 09:06:39 EDT
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.6.5, please open a new bug report.

glusterfs-3.6.5 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://www.gluster.org/pipermail/gluster-devel/2015-August/046570.html
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user

Note You need to log in before you can comment on or make changes to this bug.