Bug 1259697 - Disperse volume: Huge memory leak of glusterfsd process
Disperse volume: Huge memory leak of glusterfsd process
Status: CLOSED CURRENTRELEASE
Product: GlusterFS
Classification: Community
Component: disperse (Show other bugs)
3.7.5
All All
high Severity urgent
: ---
: ---
Assigned To: Pranith Kumar K
: Triaged
Depends On: 1207735
Blocks: qe_tracker_everglades 1224177 1229282 1247964
  Show dependency treegraph
 
Reported: 2015-09-03 07:50 EDT by Pranith Kumar K
Modified: 2015-10-14 06:37 EDT (History)
9 users (show)

See Also:
Fixed In Version: glusterfs-3.7.5
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 1207735
Environment:
Last Closed: 2015-10-14 06:27:30 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Comment 1 Pranith Kumar K 2015-09-03 07:51:25 EDT
This bug is raised only to fix the part of fd_bind code we found in code review.
    - fd_unref should decrement fd->inode->fd_count only if it is present in the
    inode's fd list.
    - successful open/opendir should perform fd_bind.
Comment 2 Vijay Bellur 2015-09-03 07:58:56 EDT
REVIEW: http://review.gluster.org/12100 (fd: Do fd_bind on successful open) posted (#1) for review on release-3.7 by Pranith Kumar Karampuri (pkarampu@redhat.com)
Comment 3 Pranith Kumar K 2015-10-14 06:27:30 EDT
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-glusterfs-3.7.5, please open a new bug report.

glusterfs-glusterfs-3.7.5 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://www.gluster.org/pipermail/gluster-users/2015-October/023968.html
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user
Comment 4 Pranith Kumar K 2015-10-14 06:37:24 EDT
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.7.5, please open a new bug report.

glusterfs-3.7.5 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://www.gluster.org/pipermail/gluster-users/2015-October/023968.html
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user

Note You need to log in before you can comment on or make changes to this bug.