Bug 120898 - Cannot get Xwindows with kernel-2.6.3-2.1.253.2.1 and Xorg libraries.
Summary: Cannot get Xwindows with kernel-2.6.3-2.1.253.2.1 and Xorg libraries.
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel
Version: rawhide
Hardware: i386
OS: Linux
medium
high
Target Milestone: ---
Assignee: Arjan van de Ven
QA Contact:
URL:
Whiteboard:
Keywords:
: 120899 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-04-15 01:28 UTC by Bill Brown
Modified: 2007-11-30 22:10 UTC (History)
0 users

(edit)
Clone Of:
(edit)
Last Closed: 2004-04-16 08:52:11 UTC


Attachments (Terms of Use)

Description Bill Brown 2004-04-15 01:28:08 UTC
Description of problem:
the Xwindows will not load. 

Version-Release number of selected component (if applicable):
any version of 
kernel-2.6.3-2.1.253.2.1
Xorg 0.0.6.6-0.0.2004_03_11.9


How reproducible:


Steps to Reproduce:
1. select the above kernel in GRUB
2. The Xserver / Xdisplay does not start and you get bumped to 
anaconda to configure the mouse settings.
3. The configuration of the mouse does not work and you get dropped 
to a shell.  
  
Actual results:


Expected results:


Additional info:

Comment 1 Dave Jones 2004-04-15 12:15:02 UTC
*** Bug 120899 has been marked as a duplicate of this bug. ***

Comment 2 Dave Jones 2004-04-15 12:16:15 UTC
sounds like bug 116118.
Can you check your X log for failures trying to open psaux ?
If you find any, you need to update your config file.



Comment 3 Bill Brown 2004-04-16 01:36:59 UTC
I updated the config file to the following:

Section "InputDevice"
	Identifier  "Mouse0"
	Driver      "mouse"
	Option	    "Protocol" "MouseManPlusPS/2"
	Option	    "Device" "/dev/input/mice" #"/dev/psaux"
	Option	    "ZAxisMapping" "4 5"
	Option	    "Emulate3Buttons" "no"
EndSection

I do not use a USB mouse but this seemed to fix the problem. Is this
setting going to be changed for a future release of XConfig? 

Comment 4 Arjan van de Ven 2004-04-16 08:52:11 UTC
this is supposed to be automatic for all our config tools now.



Note You need to log in before you can comment on or make changes to this bug.