Bug 121218 - cdparanoia with SCSI fails on recent kernels (no sg)
cdparanoia with SCSI fails on recent kernels (no sg)
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: cdparanoia (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Peter Jones
:
: 122551 123280 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-04-19 07:43 EDT by Ralf Ertzinger
Modified: 2007-11-30 17:10 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-10-08 09:28:15 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
strace cdparanoia on plextor drive (6.79 KB, text/plain)
2004-04-20 16:07 EDT, Ralf Ertzinger
no flags Details
strace on plextor drive (working) (166.38 KB, text/plain)
2004-04-21 05:58 EDT, Ralf Ertzinger
no flags Details
cdparanoia on plextor drive (working, long form) (52.99 KB, application/octet-stream)
2004-04-22 12:30 EDT, Ralf Ertzinger
no flags Details

  None (edit)
Description Ralf Ertzinger 2004-04-19 07:43:21 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6) Gecko/20040312

Description of problem:
On recent kernel releases, the scsi generic device is no longer
available for CDROM devices (see bug
https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=120490)

Due to this, cdparanoia fails to work:

[sun@nausicaa ~ :( (1) 6]$ cdparanoia -vsQ
cdparanoia III release 9.8 (March 23, 2001)
(C) 2001 Monty <monty@xiph.org> and Xiphophorus

Report bugs to paranoia@xiph.org
http://www.xiph.org/paranoia/

Checking /dev/cdrom for cdrom...
        Testing /dev/cdrom for cooked ioctl() interface
                /dev/scd0 is not a cooked ioctl CDROM.
        Testing /dev/cdrom for SCSI interface
Error trying to open /dev/sg0 exclusively (No such device or address).
retrying in 1 second.
Error trying to open /dev/sg0 exclusively (No such device or address).
retrying in 1 second.
Error trying to open /dev/sg0 exclusively (No such device or address).
retrying in 1 second.
Error trying to open /dev/sg0 exclusively (No such device or address).
retrying in 1 second.
.....

It might have to be rewritten to use SG_IO on the cdrom device.

Version-Release number of selected component (if applicable):
cdparanoia-alpha9.8-20.1

How reproducible:
Always

Steps to Reproduce:
1. Use cdparanoia on a SCSI cdrom with current kernels
2.
3.
    

Actual Results:  Error messages about scsi generic

Expected Results:  Successful ripping

Additional info:
Comment 1 Peter Jones 2004-04-20 11:39:13 EDT
There are packages that use SG_IO at
http://people.redhat.com/pjones/cdparanoia/ .

The patch is experimental, and I'd like more feedback before making
such an invasive change to the tree.
Comment 2 Ralf Ertzinger 2004-04-20 16:05:59 EDT
Works in 2 cases out of 3.

The failing drive is a Plextor PX-40TS (1.05 firmware). strace from
cdparanoia is attached.
Comment 3 Ralf Ertzinger 2004-04-20 16:07:01 EDT
Created attachment 99574 [details]
strace cdparanoia on plextor drive
Comment 4 Ralf Ertzinger 2004-04-21 05:56:26 EDT
The same drive works with kernel-2.6.4-1.300 and
cdparanoia-alpha9.8-20.1. strace attached.
Comment 5 Ralf Ertzinger 2004-04-21 05:58:57 EDT
Created attachment 99589 [details]
strace on plextor drive (working)
Comment 6 Peter Jones 2004-04-21 14:45:29 EDT
Any chance I can get you to rerun that last one with "strace -s3000"?
Comment 7 Ralf Ertzinger 2004-04-22 12:29:29 EDT
Attached. I reduced cdparanoia to read the first ten sectors of the track.
Comment 8 Ralf Ertzinger 2004-04-22 12:30:24 EDT
Created attachment 99635 [details]
cdparanoia on plextor drive (working, long form)
Comment 9 Ralf Ertzinger 2004-04-29 13:51:31 EDT
cdparanoia sometimes kicks the current CDROM from the bus (resetting
the whole bus in the process). See
https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=122007
Comment 10 Peter Jones 2004-05-17 11:27:11 EDT
*** Bug 123280 has been marked as a duplicate of this bug. ***
Comment 11 Dams 2004-05-19 14:04:24 EDT
Peter, please, take a look at bug #123618 .. related ? unrelated ?
Comment 12 Peter Jones 2004-05-21 15:23:51 EDT
*** Bug 122551 has been marked as a duplicate of this bug. ***
Comment 13 Jürgen Botz 2004-05-21 15:47:46 EDT
You can spare yourself the straces... we KNOW what the problem is. 
It's that arjanv@redhat.com deliberately broke the sg interface.  He
decided that sg should be deprecated because the other scsi devices
can now fill the same function so sg now no longer attaches to drives
that are already claimed by another driver (sd, sr).

arjanv did this despite my and others pointing out that there are
still applications that rely on sg and can't be forced to use i.e.
/dev/scd0 the way cdrecord can.  See fedora-devel and fedora-test for
this history on this.

The solution is to fix cdrecord and grip to do SG_IO on the regular
cdrom device.  (Right even if you give "-g /dev/scd0" it doesn't do
the right thing, but I haven't looked at the code to see why.)

Although the above is the correct solution that doesn't absolve arjan
from knowingly breaking these apps late in the Fedora 2 release cycle,
which has me really down on the whole RedHat / Fedora thing.

Comment 14 Peter Jones 2004-05-21 15:59:28 EDT
Jurgen, I'd really rather get cdparanoia up to snuff with SG_IO than
have to read political posts in my bugzillas.

So if you wouldn't mind, testing the packages linked to above is fair
game, let me know any problems whatsoever.  Complaining about removal
of sg is an argument for some other venue.  As far as I'm concerned,
sg is depricated, and the bug is that cdparanoia in fc2 is still using it.
Comment 15 Peter Jones 2004-05-21 16:18:50 EDT
Dams, I think 123618 is related, but I'm going to leave it seperate
until I get a chance to push another package with a fix in it, and
then see if _this_ problem still occurs.
Comment 16 Jürgen Botz 2004-05-23 18:37:51 EDT
Peter, your SG_IO cdparanoia packages work for me.
Comment 17 Ralf Ertzinger 2004-10-08 09:28:15 EDT
cdparanoia and the kernel seem to have settled down, I have no more
obvious problems.

Note You need to log in before you can comment on or make changes to this bug.