Bug 1212616 - virt-manager does not warn if it cannot find the network
Summary: virt-manager does not warn if it cannot find the network
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: virt-manager
Version: 23
Hardware: x86_64
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Cole Robinson
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-04-16 19:24 UTC by John Snow
Modified: 2015-12-31 00:54 UTC (History)
4 users (show)

Fixed In Version: virt-manager-1.3.2-1.fc23
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-12-31 00:54:58 UTC
Type: Bug


Attachments (Terms of Use)

Description John Snow 2015-04-16 19:24:50 UTC
Description of problem:

Virt-manager will happily chug along creating a new VM for you with no network with no indication, warning, error or otherwise that it was not able to set up or configure a network for you.

Relevant bug is BZ #867546 -- this bug is reproducible generally before the first libvirtd restart.

Version-Release number of selected component (if applicable):

Fedora 22 RC2
virt-manager.noarch 1.1.0-7.git6dbe19bd8.fc22

How reproducible:

100%

Steps to Reproduce:
1. Install virt-manager & friends via "sudo dnf groupinstall virtualization"
2. sudo virt-manager &
3. Install a new VM using the new VM wizard
4. Choose all the defaults and accept. A windows 7 ultimate N ISO was used in this case.
5. virsh dumpxml mynewvm > mynewvm.xml

Actual results:

<network> configuration session is missing, with no indication in the wizard during installation time.

Expected results:

A warning or error informing the user that (for whatever reason), the Network subsystem could not be configured.

Comment 1 Cole Robinson 2015-11-02 19:55:31 UTC
Fixed upstream now:

commit 50b1b18ec4de0260354379e006d2b43a3f2d4c98
Author: Cole Robinson <crobinso@redhat.com>
Date:   Mon Nov 2 14:42:42 2015 -0500

    create: Show a warning if no network is selected (bz 1267377)

Comment 2 Cole Robinson 2015-11-25 19:18:39 UTC
Backporting this is a bit of a pain because it was preceded by a bunch of code re-org in that area, so just moving to f23 where we will get this with the rebase

Comment 3 Fedora Update System 2015-11-25 20:09:32 UTC
virt-manager-1.3.0-1.fc23 has been submitted as an update to Fedora 23. https://bodhi.fedoraproject.org/updates/FEDORA-2015-7dfc5692ef

Comment 4 Fedora Update System 2015-11-26 23:50:29 UTC
virt-manager-1.3.0-1.fc23 has been pushed to the Fedora 23 testing repository. If problems still persist, please make note of it in this bug report.
If you want to test the update, you can install it with
$ su -c 'dnf --enablerepo=updates-testing update virt-manager'
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2015-7dfc5692ef

Comment 5 Fedora Update System 2015-12-07 01:07:37 UTC
virt-manager-1.3.1-1.fc23 has been submitted as an update to Fedora 23. https://bodhi.fedoraproject.org/updates/FEDORA-2015-6cf48609ca

Comment 6 Fedora Update System 2015-12-08 04:32:18 UTC
virt-manager-1.3.1-1.fc23 has been pushed to the Fedora 23 testing repository. If problems still persist, please make note of it in this bug report.
If you want to test the update, you can install it with
$ su -c 'dnf --enablerepo=updates-testing update virt-manager'
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2015-6cf48609ca

Comment 7 Fedora Update System 2015-12-24 19:02:50 UTC
virt-manager-1.3.2-1.fc23 has been submitted as an update to Fedora 23. https://bodhi.fedoraproject.org/updates/FEDORA-2015-237e1d49a8

Comment 8 Fedora Update System 2015-12-29 00:57:02 UTC
virt-manager-1.3.2-1.fc23 has been pushed to the Fedora 23 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2015-237e1d49a8

Comment 9 Fedora Update System 2015-12-31 00:54:31 UTC
virt-manager-1.3.2-1.fc23 has been pushed to the Fedora 23 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.