Bug 121487 - /etc/sysconfig/mouse not created => gpm doesn't work
/etc/sysconfig/mouse not created => gpm doesn't work
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: kudzu (Show other bugs)
rawhide
i386 Linux
medium Severity low
: ---
: ---
Assigned To: Bill Nottingham
David Lawrence
:
: 120775 121139 (view as bug list)
Depends On:
Blocks: FC2Blocker
  Show dependency treegraph
 
Reported: 2004-04-21 23:01 EDT by Alexandre Oliva
Modified: 2014-03-16 22:44 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-05-04 16:08:11 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Alexandre Oliva 2004-04-21 23:01:52 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6) Gecko/20040312

Description of problem:
Anaconda fails to create /etc/sysconfig/mouse, but the gpm init.d file
requires it to enable gpm.  Maybe it shouldn't?  Anyhow, running
system-config-mouse after installation is complete doesn't remember
the mouse selection in the kickstart file (or chosen at install time?
I haven't tried interactive installs, but I suppose the selection is
still there), so you have to select the right mouse type again in
order for text console mouse to work.

Version-Release number of selected component (if applicable):
anaconda-9.92-8

How reproducible:
Always

Steps to Reproduce:
1.Kickstart install, with several different PS/2 mouse types specificed

Actual Results:  Notice in the first boot that console mouse fails to
start because it's not configured.

Expected Results:  It should have been configured.

Additional info:
Comment 1 Alexandre Oliva 2004-04-22 10:27:12 EDT
Err...  Why was this reassigned to system-config-mouse? 
system-config-mouse *does* create the file.  It's the install
(kickstart, if it matters) that doesn't.
Comment 2 Brent Fox 2004-04-22 17:10:35 EDT
*** Bug 120775 has been marked as a duplicate of this bug. ***
Comment 3 Brent Fox 2004-04-22 17:12:39 EDT
The problem is that system-config-mouse is not getting called during
the installation.  It used to get called but something has changed in
either anaconda or kudzu due to the switch to the 2.6 kernel and
/dev/input/mice.

I'm changing the component to kudzu at notting's request.
Comment 4 Bill Nottingham 2004-05-04 16:08:11 EDT
Fixed in 1.1.59-1.
Comment 5 Bill Nottingham 2004-05-04 16:10:54 EDT
*** Bug 121139 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.