Bug 1215158 - [Blocked][HC] Show hosted engine storage domain in the Web UI
Summary: [Blocked][HC] Show hosted engine storage domain in the Web UI
Keywords:
Status: CLOSED DUPLICATE of bug 1269768
Alias: None
Product: ovirt-engine
Classification: oVirt
Component: BLL.HostedEngine
Version: ---
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: ovirt-4.0.0-alpha
: ---
Assignee: Roy Golan
QA Contact: Ilanit Stein
URL:
Whiteboard: integration
Depends On:
Blocks: Hosted_Engine_HC 1222010
TreeView+ depends on / blocked
 
Reported: 2015-04-24 12:56 UTC by Sandro Bonazzola
Modified: 2016-01-05 11:31 UTC (History)
18 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-01-05 11:31:06 UTC
oVirt Team: Integration
ylavi: ovirt-4.0.0?
ylavi: planning_ack?
ylavi: devel_ack?
ylavi: testing_ack?


Attachments (Terms of Use)

Description Sandro Bonazzola 2015-04-24 12:56:15 UTC
Currently the storage domain used by Hosted Engine can't be viewed in the Web UI.

Trying to add it using "import domain" from Web UI shows a popup:

This operation might be unrecoverable and destructive!
Storage Domain(s) are already attached to a Data Center. Approving this operation might cause data corruption if both Data Centers are active.
- hosted_storage

Once approved explicitly the operation a second popup shows:
Error while executing action: Cannot add Storage. The storage selected contains the self hosted engine.

In order to allow in the future to have other VMs using the same storage in HC setup, it should be possible to see add the storage domain to the cluster.

Comment 1 Allon Mureinik 2015-04-26 16:01:38 UTC
This is the wrong way to go about it.
the HE's installer should register the domain to the engine, not manually import it.

Comment 2 Tal Nisan 2015-05-11 15:38:33 UTC
Sandro, are you taking it?

Comment 3 Sandro Bonazzola 2015-05-12 15:20:01 UTC
Taking. Allon, how do I register the domain?

Comment 4 Sandro Bonazzola 2015-05-21 08:28:33 UTC
Raising severity since now the engine requires a storage domain for adding a direct lun, breaking hosted-engine on block devices.

Comment 5 Sandro Bonazzola 2015-05-21 08:36:52 UTC
Blocked on: how to add an SD with no DC to the engine?

Comment 6 Red Hat Bugzilla Rules Engine 2015-10-19 10:59:24 UTC
Target release should be placed once a package build is known to fix a issue. Since this bug is not modified, the target version has been reset. Please use target milestone to plan a fix for a oVirt release.

Comment 7 Allon Mureinik 2016-01-04 13:35:02 UTC
Roy/Sandro - is this still relevant? Doesn't your recent work on 3.6 cover this already?

Comment 8 Roy Golan 2016-01-04 14:58:27 UTC
proposing to close dup on Bug 1269768

Comment 9 Yaniv Lavi 2016-01-05 11:31:06 UTC

*** This bug has been marked as a duplicate of bug 1269768 ***


Note You need to log in before you can comment on or make changes to this bug.