Bug 1222010 - engine refuses to add hosted-engine VM cause no active store domain is present
Summary: engine refuses to add hosted-engine VM cause no active store domain is present
Keywords:
Status: CLOSED DUPLICATE of bug 1242215
Alias: None
Product: oVirt
Classification: Retired
Component: ovirt-engine-core
Version: 3.6
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: ---
: 3.6.0
Assignee: Roy Golan
QA Contact: Pavel Stehlik
URL:
Whiteboard: sla
Depends On: 1215158
Blocks: 1036731 1215623
TreeView+ depends on / blocked
 
Reported: 2015-05-15 13:09 UTC by Simone Tiraboschi
Modified: 2016-02-10 19:42 UTC (History)
10 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-09-17 11:24:42 UTC
oVirt Team: SLA


Attachments (Terms of Use)
engine's log file (807.36 KB, text/plain)
2015-08-04 10:52 UTC, wodel
no flags Details


Links
System ID Private Priority Status Summary Last Updated
Red Hat Bugzilla 1215623 0 urgent CLOSED [BLOCKED] Deploying on a shared block device, hosted-engine is unable to add the VM Disk as a direct LUN 2021-02-22 00:41:40 UTC

Internal Links: 1215623

Description Simone Tiraboschi 2015-05-15 13:09:28 UTC
Description of problem:

As for https://bugzilla.redhat.com/show_bug.cgi?id=1215623#c8
the engine now refuses to add the engine VM cause at that point there is no Acive Datacenter cause there is no no active storage domain (hosted-engine one is directly managed by hosted-engine and not by the engine itself).

In the engine logs we could found:
2015-05-04 18:23:10,994 WARN  [org.ovirt.engine.core.bll.AddVmFromScratchCommand] (DefaultQuartzScheduler_Worker-85) [1c4d795d] CanDoAction of action 'AddVmFromScratch' failed for user null@N/A. Reasons: VAR__ACTION__ADD,VAR__TYPE__VM,ACTION_TYPE_FAILED_IMAGE_REPOSITORY_NOT_FOUND
2015-05-04 18:23:10,995 INFO  [org.ovirt.engine.core.bll.AddVmFromScratchCommand] (DefaultQuartzScheduler_Worker-85) [1c4d795d] Lock freed to object 'EngineLock [exclusiveLocks= key: HostedEngine value: VM_NAME
, sharedLocks= ]'

ACTION_TYPE_FAILED_IMAGE_REPOSITORY_NOT_FOUND was recently added, change-Id: I2586b0026c85f053b6cd0aebeb555d760afc0937


Version-Release number of selected component (if applicable):
3.6-master

How reproducible:
100%

Steps to Reproduce:
1. deploy hosted-engine
2.
3.

Actual results:
It fails adding the engine-vm to the engine.

Expected results:
Engine-vm got added into the engine either cause the hosted-engine storage domains was added to the engine as for https://bugzilla.redhat.com/show_bug.cgi?id=1215158 or cause ACTION_TYPE_FAILED_IMAGE_REPOSITORY_NOT_FOUND got ignored for the engine-vm.

Additional info:
It happens on each kind of storage

Comment 1 Simone Tiraboschi 2015-05-15 13:57:10 UTC
Adding the first storage domain is enough to solve it: when you add the first data domain the datacenter comes up and the engine-VM got shown.

Comment 2 Maor 2015-05-16 07:30:16 UTC
Eldan,

Can u please take a look at this, I'm not sure if we can remove this CDA (change-id I2586b0026c85f053b6cd0aebeb555d760afc0937) right now, though it seems that the behavior currently blocks adding Hosted Engine

Comment 3 Maor 2015-05-17 17:53:54 UTC
Moving to virt per the bug description indicating the problem is mainly with the HE and Storage Pool

Comment 4 Maor 2015-05-18 12:13:47 UTC
After discussing with Roy and Omer, moving this to SLA since the fix will eventually be in the SLA side

Comment 5 wodel 2015-08-04 10:52:26 UTC
Created attachment 1059026 [details]
engine's log file

engine's VM log file

Comment 6 Roy Golan 2015-09-17 11:24:42 UTC

*** This bug has been marked as a duplicate of bug 1242215 ***


Note You need to log in before you can comment on or make changes to this bug.