Bug 121766 - Cannot change resolution and refresh rate on S3 Savage/IX in Toshiba Satellite Pro 4300
Cannot change resolution and refresh rate on S3 Savage/IX in Toshiba Satellit...
Status: CLOSED DUPLICATE of bug 120950
Product: Fedora
Classification: Fedora
Component: system-config-display (Show other bugs)
rawhide
i686 Linux
medium Severity high
: ---
: ---
Assigned To: Mike A. Harris
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-04-27 12:38 EDT by Greg Janzen
Modified: 2007-11-30 17:10 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 14:02:47 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Xorg Log File (95.96 KB, text/plain)
2004-04-27 12:39 EDT, Greg Janzen
no flags Details

  None (edit)
Description Greg Janzen 2004-04-27 12:38:13 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6) Gecko/20040422

Description of problem:
After installing Fedora Core 2 and upgrading all components to Test 3
via yum everything seemed fine. The install was done undocked. I later
docked the laptop. Still fine. I changed the monitor under display
settings to match the external Compaq V70 monitor I was using and
rebooted. Now the display is stuck at what looks like 640x480. The
changes do get written to xorg.conf but there are errors in the Xorg log.

eg.

    (EE) SAVAGE(0): vm86() syscall generated signal 11.

    (EE) SAVAGE(0): Failed to fetch any BIOS modes.  Disabling BIOS.

When removed from the docking station the laptop display only displays
640x480 as well and the refresh rate is far to low.

I'll attach the Xorg log.

Thanks for the help.

Version-Release number of selected component (if applicable):
xorg-x11-6.7.0-0.5

How reproducible:
Always

Steps to Reproduce:
1. Change monitor to an external monitor set resolution to 1024x768
2. reboot
3.
    

Actual Results:  Display @ 640x480

Expected Results:  Display @ 1024x768

Additional info:
Comment 1 Greg Janzen 2004-04-27 12:39:52 EDT
Created attachment 99716 [details]
Xorg Log File
Comment 2 Tim Whitbeck 2004-04-28 22:29:23 EDT
  I just installed FC2 Test 3 and I've had a similar problem with my
GeForce FX 5900.  The problem seems to be related to the nv driver as
when I select the VESA driver the resolution will change (however the
refresh rate is stuck at 60, ouch my eyes!)  The weird thing is the nv
driver worked FINE on my initial boot (right after I selected 1024x768
and Millions of Colors), up until the Display section of FirstBoot. 
This only gave me the option of 640x480 or 800x600.  It doesn't matter
which I select, it will only display 640x480.  The applet that handles
Xorg config also automatically reverts me to the nv driver after I
select the VESA driver, so I get stuck in low res land again.
Comment 3 Neville 2004-04-29 03:25:29 EDT
I've had a similar problem while trying to run FC2 Test 3 on an IBM
Thinkpad T23 with a Savage/IX.

Whether I specify 'Generic LCD 1024x768' or 'Generic Monitor
1024x768', I'm limited to 640x480 at a very low refresh rate.

The Display applet gives me choices of '800x600' and '640x480' only,
but no matter what I choose the resolution stays at what looks like
640x480. Similarly to Tim, the driver seemed to work fine at first
(ie. looked to be running at 1024x768), right up until FirstBoot started.
Comment 4 Phil Anderson 2004-04-29 23:59:24 EDT
Four more people with the same problem on fedora-test-list@redhat.com
today about this.

This is a bug in system-config-display, not xorg-x11


Here is my post:

I got the same problem with my Nvidia Geforce 4, except that half the
time it was in 1024x768, half the time in 640x480.

It appears that the new system-config-display doesn't enable the hard
coded screen settings in your /etc/X11/xorg.conf.  Instead, it relies
on DCC probes.  My monitor/card combination has some problem, and the
DCC Probe fails half the time.  To work around this, edit
/etc/X11/xorg.conf and look in the Monitor section.  Uncomment the
HorizSync and the VertRefresh lines.

Section "Monitor"

 ### Uncomment if you don't want to default to DDC:
    Identifier   "Monitor0"
    VendorName   "Monitor Vendor"
    ModelName    "Lite-On A1770NSL"
    DisplaySize  320    240
 ### Uncomment if you don't want to default to DDC:
    HorizSync    30.0 - 69.0
    VertRefresh  50.0 - 120.0
    Option      "dpms"
EndSection

Comment 5 dusty bradshaw 2004-04-30 07:27:37 EDT
Im having the same issue on an older box with a ati mach 64 card, my
resoution will not change either, as it is stuck on 640X480. Hopefully
this issue can get fixed soon, and I can get back to high res land. :)
Comment 6 Phil Anderson 2004-04-30 20:53:13 EDT
bug 121855 is a duplicate of this
Comment 7 Joseph Kelch 2004-05-03 15:13:02 EDT
Uncommenting HorizSync and VertRefresh on my Voodoo 3 2000 PCI got my 
screen back up to 1024x768, but now the login screen is using a TINY 
font that is unreadable!!  Not a biggie, but just thought I'd mention 
it.  Anyone know how I might edit this to a larger font?  Using the 
default bluecurve login page.
Comment 8 Mike A. Harris 2004-05-06 01:32:01 EDT
>    (EE) SAVAGE(0): vm86() syscall generated signal 11.
>    (EE) SAVAGE(0): Failed to fetch any BIOS modes.  Disabling BIOS.

This problem is a kernel bug which breaks vm86(), and is fixed in
the latest rawhide kernel.  This kernel bug will affect all video
drivers which make calls into the VESA BIOS, including savage, nv,
radeon, vesa, and other drivers.  A vast array of problems can
arise depending on what the driver is using the BIOS for, since
any call will potentially fail.  Please upgrade to the latest kernel
and see if this resolves the issue.

If the problem persists, it is possible that you may also be
experiencing bug #120950.  Please try the workaround in that report
as well to see if the issue is resolved.  If everyone else CC'd on
this report could also test that and report back, that would be
helpful information as well.


Comment 9 Greg Janzen 2004-05-07 13:46:58 EDT
Uncommenting the DDC lines seems to have resolved the problem.

I also had some other video issues where it looked like there was
static on the screen but that was resoled when I upgraded to to Kernel
2.6.5-1.350. Thanks for all the help!
Comment 10 Mike A. Harris 2004-05-08 01:53:51 EDT
Ok, thanks for the update Greg!

*** This bug has been marked as a duplicate of 120950 ***
Comment 11 Pete Sridharan 2004-05-08 09:16:39 EDT
 I have the same poblem (stuck with 640x480 resolution) on my 
Thinkpad T22 (Savage 1/X).
As per the suggestion above, I upgraded the kernel to the latest 
update (2.65.351?). 
 It did not resolve the Display issue. I still get the : "vm86() 
syscall generated signal 11" errors.
 
Comment 12 Pete Sridharan 2004-05-08 12:11:04 EDT
 I have the same poblem (stuck with 640x480 resolution) on my 
Thinkpad T22 (Savage 1/X).
As per the suggestion above, I upgraded the kernel to the latest 
update (2.65.351?). 
 It did not resolve the Display issue. I still get the : "vm86() 
syscall generated signal 11" errors.
 
Comment 13 Phil Anderson 2004-05-08 21:27:19 EDT
As well as upgrading kernel, did you modify your xorg.conf as per
Comment 4?
Comment 14 Mike A. Harris 2004-05-10 01:50:40 EDT
If you see anything concerning vm86() errors in your log file, it
is a kernel bug in the kernel you are running.  In such case, please
file a new bug report against the kernel component, and attach your
kernel log, X server log, and full details to the report, and the
output of "rpm -qa | grep ^kernel" and also "uname -a", and a kernel
engineer can review the report and determine what action is necessary
to resolve the problem.

Thanks for testing.
Comment 15 Pete Sridharan 2004-05-11 22:01:07 EDT
In my case, the kernel upgrade did not fix the problem.
But creating a new, clean config file fixed the vm86 errors. 
When I upgraded from an earlier version, the xorf.conf did not get 
correctly congigured.
 I had to follow the comment 4 suggestion to configure the X server 
resolution to > 640x480 (such as 1024x768). 
 Thanks for all your suggestions.
Comment 16 Red Hat Bugzilla 2006-02-21 14:02:47 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.