Bug 121855 - can't set resoltuion to 1400x1050
can't set resoltuion to 1400x1050
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: system-config-display (Show other bugs)
rawhide
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Brent Fox
:
: 123262 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-04-28 13:28 EDT by Sasha
Modified: 2007-11-30 17:10 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-06-24 16:50:10 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
xorg.conf file (3.43 KB, text/plain)
2004-04-28 13:30 EDT, Sasha
no flags Details

  None (edit)
Description Sasha 2004-04-28 13:28:53 EDT
system-config-display gives me the choice of resolutions 640x480 and
600x800, even though my system is capable of up to 1400x1050 - in
fact, it is at the moment runnign at 1400x1050, even though this
resoltuion does not show in system-config-display. I am attaching
xorg.conf file

The system is Dell Latitude laptop with 1400x1050 LCD screen and ATI
Radeon 9000 Mobility video card
Comment 1 Sasha 2004-04-28 13:30:06 EDT
Created attachment 99741 [details]
xorg.conf file
Comment 2 Mike Becker 2004-04-30 13:32:11 EDT
I did a clean install FC2-T3, three times.  The system here is a
Gateway M500 using a nVidia GeForce4 420 Go video card, which uses a
resolution of 1280x854. In FC1 & FC2-T2 I have been able to set the
1280x854 resolution by using a ModeLine but in FC2-T3 it fails to
work.  The log shows the 'nv' module is being loaded, etc. but it also
says that all resolutions it tries to set the X server to are out of
range, including 1280x854.  After it runs thrue all resolutions it
finally sets X to 640x480.

I was able to get the resolution in FC2-T3 "fixed" by installing
FC2-T2, setting up the system there and then doing an upgrade with the
FC2-T3 CDs.  The X server settings were carried over to FC2-T3 and now
the resolution is correct. 

Two observations - one, when I had the clean install of T3 running, it
used XF86Config.  I don't remember seeing the xorg.conf script as
reported by Sasha. I was working with XF86Config.  Two, with the
present configuration, T3 upgraded from T2, XF86Config is still being
used... 
Comment 3 Phil Anderson 2004-04-30 20:51:42 EDT
Probably a duplicate of bug 121766
Comment 4 Brent Fox 2004-05-17 14:28:47 EDT
*** Bug 123262 has been marked as a duplicate of this bug. ***
Comment 5 Darin May 2004-05-17 14:35:19 EDT
From bug 123262:

I'm using a fresh FC2-t3 install.  There are no legacy XFree86 configs.

Using system-config-display-1.0.14-1
Comment 6 Brent Fox 2004-05-17 14:37:06 EDT
Darin: Does /etc/X11/XF86Config exist?  There was a bug in test3 that
was causing both XF86Config and xorg.conf to be written, which was
confusing system-config-display.
Comment 7 Sasha 2004-05-17 14:46:35 EDT
Though the question was not addressed to me, on my system XF86COnfig
did exist. 
Comment 8 Darin May 2004-05-17 15:21:07 EDT
Yes it did.  Interesting, it was not there after the initial reinstall
of FC2-t3.

I renamed it and rebooted but the problem still persists.
Comment 9 Phil Anderson 2004-05-17 19:06:47 EDT
Isn't this a dupe of either 120950 or that kernel bug which was
recently fixed which caused DCC probes not to work?  These have both
been fixed in rawhide/FC2, but will require you to rebuild your
xorg.conf with system-config-display.
Comment 10 Darin May 2004-05-17 19:20:33 EDT
That did it.

After reselecting "Generic LCD 1024x768" and "ATI Rage Mobility" the
first panel's resolution dropdown now offered 1024x768. 
XFree86.config was not re-created.

Thanks.

Note You need to log in before you can comment on or make changes to this bug.