Bug 121943 - Adding Korean layout in keyboard preferences gives "XKB error"
Summary: Adding Korean layout in keyboard preferences gives "XKB error"
Status: CLOSED DUPLICATE of bug 130153
Alias: None
Product: Fedora
Classification: Fedora
Component: control-center   
(Show other bugs)
Version: rawhide
Hardware: i686
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Jonathan Blandford
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-04-29 09:15 UTC by Timothy Ha
Modified: 2013-04-02 04:19 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 19:02:50 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Timothy Ha 2004-04-29 09:15:31 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.7b)
Gecko/20040421

Description of problem:
I wanted to add Korean layout from GNOME - keyboard - preferences.
After choosing Korean from the right list of layouts, I get something
like "XKB error". Probably you don't have Korean keymap in test3 ?

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Go into System Settings - Keyboard Preferences
2. Choose layouts tab, try to add Korean
3. It will give error
    

Actual Results:  "XKB error"

Expected Results:  "XKB error"

Additional info:

Comment 1 Michael Young 2004-04-30 11:03:01 UTC
This might be bug 121016. Have a look at the workaround in #4.

Comment 2 Timothy Ha 2004-05-08 19:12:05 UTC
The work around with deleting a line in Xorg.conf doesn't work - since
the line just doesn't exists in a fresh Fedora 2 install (not update
of Fedora 1).

Comment 3 Nicu Buculei 2004-05-19 11:26:08 UTC
the bug is also present in the final version of FC2 when adding
Romanian language

Comment 4 Vidmantas 2004-05-25 20:26:20 UTC
the same bug in the FC2 final (i386) when trying to add Lithuanian 
azerty standart keyboard layout

Comment 5 Adeynack 2004-10-24 14:00:48 UTC
Just to be sure this is the same bug, here is the content of the
message box I see when startig Gnome:

============================
Error activating XKB configuration.
Probably internal X server problem.

X server version data:
The X.Org Foundation
60700000

If you report this situation as a bug, please include:
- The result of xprop -root | grep XKB
- The result of gconftool-2 -R /desktop/gnome/peripherals/keyboard/xkb
============================

And here are the results of what is asked by the box:

xprop -root | grep XKB
_XKB_RULES_NAMES_BACKUP(STRING) = "xorg", "pc105", "us", "", ""
_XKB_RULES_NAMES(STRING) = "xorg", "pc105", "us", "", ""

gconftool-2 -R /desktop/gnome/peripherals/keyboard/xkb
 layouts = [ca_enhanced,us]
 model = pc105
 overrideSettings = false
 options = []


Comment 6 Marco Pesenti Gritti 2004-11-04 13:28:46 UTC

*** This bug has been marked as a duplicate of 130153 ***

Comment 7 yonghan 2004-12-08 00:08:47 UTC
I have the same bug with Korean and Swiss German/French.
I get exactly the same error msg from Adeynack

Is it now fixed?



Comment 8 Red Hat Bugzilla 2006-02-21 19:02:50 UTC
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.


Note You need to log in before you can comment on or make changes to this bug.