Bug 122001 - Gstreamer seg faults
Gstreamer seg faults
Status: CLOSED DUPLICATE of bug 119958
Product: Fedora
Classification: Fedora
Component: gstreamer (Show other bugs)
rawhide
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Colin Walters
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-04-29 13:02 EDT by Will Backman
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 14:02:52 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Will Backman 2004-04-29 13:02:56 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6) Gecko/20040422

Description of problem:
In rhytmbox, I import a directory of ogg files.
It crashes.

(rhythmbox:30247): GStreamer-CRITICAL **: Factory for `oggdemux' has no
type
Segmentation fault

Version-Release number of selected component (if applicable):
gstreamer-0.8.1-1

How reproducible:
Always

Steps to Reproduce:
1. Open rhythmbox
2. Import directory of ogg files
3. Crash
    

Actual Results:  Application closes.

Expected Results:  Listen to music

Additional info:
Comment 1 Colin Walters 2004-05-03 12:15:20 EDT
Did you install GStreamer from source yourself?

Do you have a ~/.gstreamer-0.8 directory?

Comment 2 Will Backman 2004-05-03 12:59:51 EDT
This was a standard FC2T3 Net Install.  I did not install gstreamer
myself.

I do have the ~./.gstreamer-0.8 directory, which containts a file
called registry.xml
Comment 3 Will Backman 2004-05-03 13:00:55 EDT
Oh yeah, I did move my home directory over from FC2T2.  Could this be
the issue?  I'll have to try this as a newly created user.
Comment 4 Colin Walters 2004-05-03 15:05:09 EDT
What if you remove the ~/.gstreamer-0.8 directory and its contents?
Comment 5 Will Backman 2004-05-04 13:03:06 EDT
I created a new user.  No crash, but it does say it cannot pause
playback.  Same for the original user after deleting the old directory.

Looks like there is an update, so I'll download and try that.
Comment 6 Colin Walters 2004-05-13 15:14:56 EDT
Are you having any luck with this now?
Comment 7 Will Backman 2004-05-13 15:54:56 EDT
No luck still.  Cannot pause playback error as either myself or as a
newly created user, although this is different from the original
seg-fault, which was solved by removing the directory.
Comment 8 Colin Walters 2004-05-14 14:17:26 EDT
Can you give me details on your computer?  Specifically, what sound
card do you have?  If you're unsure, try running "lspci", and look for
"sound" or "audio".
Comment 9 Will Backman 2004-05-14 14:28:28 EDT
Ensoniq 5880 AudioPCI snd-ens1371 module, according to the graphical
sound card detection program.
Comment 10 Sitsofe Wheeler 2004-05-22 06:47:57 EDT
I had gstreamer trouble on my Ensoniq ES1371 too. Making gstreamer use
esd / oss source and sinks fixed the problem...
Comment 11 Sitsofe Wheeler 2004-06-01 04:41:39 EDT
This looks like a dup of bug 119958 . Perhaps the workaround described
in bug #119982 comment #10 will help...
Comment 12 Colin Walters 2004-07-07 14:28:44 EDT

*** This bug has been marked as a duplicate of 119958 ***
Comment 13 Red Hat Bugzilla 2006-02-21 14:02:52 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.