Bug 122041 - installer asks me to configure X twice
installer asks me to configure X twice
Status: CLOSED DUPLICATE of bug 121489
Product: Fedora
Classification: Fedora
Component: firstboot (Show other bugs)
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Brent Fox
Depends On:
  Show dependency treegraph
Reported: 2004-04-29 17:18 EDT by Florin Andrei
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2006-02-21 14:02:52 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)
Xorg Log files (37.30 KB, text/plain)
2004-04-30 13:04 EDT, Douglas Furlong
no flags Details
Another log file from the same system (37.47 KB, text/plain)
2004-04-30 13:05 EDT, Douglas Furlong
no flags Details
And again (1.07 KB, text/plain)
2004-04-30 13:05 EDT, Douglas Furlong
no flags Details

  None (edit)
Description Florin Andrei 2004-04-29 17:18:26 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6) Gecko/20040116

Description of problem:
I installed FC2 test 3, it booted up. After booting up, it said X is
not configured and it prompted me to do that. I entered the monitor
parameters, resolution and number of colors.
Then it went through the Welcome screen, then License Agreement, then
Date And Time, then Display.
At this point, it asked me to configure resolution again. But i
already configured resolution previously!

Version-Release number of selected component (if applicable):

How reproducible:
Didn't try

Additional info:

Maybe it has something to do with the fact that i installed in
text-mode? (booted up the installer with "linux text")
Comment 1 Florin Andrei 2004-04-29 17:24:42 EDT
And by the way, when it prompted me the second time (in the Display
screen), i could not choose 1024x768, but only lower resolutions,
although the first time i could choose 1024x768 and my system works
fine in that resolution - it's using it right now, at the gdm login
Now it's in 1024x768, even though i selected 800x600 the second time
(because i could not choose a higher res).

Ok, i rebooted the system and it came up in 1024x768.

This is inconsistent behaviour.
Comment 2 Douglas Furlong 2004-04-30 13:02:50 EDT
I have suffered the same problem as your self, after a clean install.

My monitor is not automaticly detected, and I think this may have some
thing to do with the problem.

I am using an Iiyama Vision Master 450.

At the first screen I am able to choose the monitor and appropraite
screen resolution. Once first boot starts, and I am greeted with the
screen to configure X again, I am unable to choose the monitor, and am
limited to a resolution of either 640*480 or 800*600.

When I reboot the machine, I am greeted with a resolution of 640*480.
After i login and run the system-config-display, I have an intial
Resolution option of 640*480 or 800*600.

When I change to the tab Hardware, all hardware is listed correctly.

If I go to configure the Monitor and select the same one again (Iiyama
S901GT, VisionMaster 450), and then go back to settings, the
resolution of 1600*1200 is automaticly selected (with a maximum of
1920*1440 available).

I think bug 121820 is related, but am not sure.
Comment 3 Douglas Furlong 2004-04-30 13:04:47 EDT
Created attachment 99831 [details]
Xorg Log files

This is to follow up my comments for this bug.

If any additional log files are required, then I can hopefully create them for
Comment 4 Douglas Furlong 2004-04-30 13:05:12 EDT
Created attachment 99832 [details]
Another log file from the same system
Comment 5 Douglas Furlong 2004-04-30 13:05:34 EDT
Created attachment 99833 [details]
And again
Comment 6 Brent Fox 2004-05-06 16:13:35 EDT

*** This bug has been marked as a duplicate of 121489 ***
Comment 7 Red Hat Bugzilla 2006-02-21 14:02:52 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.