Bug 121489 - firstboot runs system-config-display because XF86Config is not installed
firstboot runs system-config-display because XF86Config is not installed
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: firstboot (Show other bugs)
rawhide
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Brent Fox
:
: 121820 122041 122073 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-04-21 23:09 EDT by Alexandre Oliva
Modified: 2007-11-30 17:10 EST (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-06-21 13:58:36 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
a slightly more robust approach (1.01 KB, patch)
2004-06-17 16:52 EDT, Mike McLean
no flags Details | Diff

  None (edit)
Description Alexandre Oliva 2004-04-21 23:09:03 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6) Gecko/20040312

Description of problem:
Even after a kickstart install, firstboot runs system-config-display,
because it doesn't find /etc/X11/XF86Config.  Sure enough, this file
is no longer created by the installer or by xorg-x11; it's now named
xorg.conf.  If I'm reading this code right, it will run
system-config-display on *every* reboot, which certainly sucks.  This
is new in the 0421 compose; 0420's didn't have this problem.

Version-Release number of selected component (if applicable):
firstboot-1.3.11-1

How reproducible:
Always

Steps to Reproduce:
1.Do a fresh kickstart install of the 0421 compose
2.Wonder why system-config-display is run; tell it to keep the config
3.Reboot

Actual Results:  You get system-config-display again, I suppose.

Expected Results:  Shouldn't even have got it the first time.

Additional info:
Comment 1 Brent Fox 2004-04-22 15:19:31 EDT
Ah, it was running system-config-display if /etc/X11/XF86Config does
not exist.  It should have been looking for xorg.conf instead. 
firstboot-1.3.12-1 in Rawhide should fix this.
Comment 2 Brent Fox 2004-04-22 15:20:13 EDT
I need to test and see if this affects non-kickstarted machines as well.
Comment 3 Brent Fox 2004-04-22 15:41:34 EDT
Yes, this affects non-kickstarted machines as well.  Sopwith, I think
that this should really be fixed before test3 goes out.
Comment 4 Brent Fox 2004-04-22 15:46:02 EDT
On second thought, it's just a minor annoyance.  Let's get test3 out
the door and I'll dupe the bug reports to this one.
Comment 5 Alexandre Oliva 2004-04-22 23:07:35 EDT
It's actually a very minor annoyance, since there's no trace of
firstboot in /etc/rc.d/rc*.d after the first boot.  So my theory that
it would happen on every boot was wrong; it's really only the first time.
Comment 6 Brent Fox 2004-05-03 11:45:36 EDT
*** Bug 122073 has been marked as a duplicate of this bug. ***
Comment 7 Brent Fox 2004-05-06 16:13:37 EDT
*** Bug 122041 has been marked as a duplicate of this bug. ***
Comment 8 Brent Fox 2004-05-06 16:14:34 EDT
*** Bug 121820 has been marked as a duplicate of this bug. ***
Comment 9 Brent Fox 2004-05-06 16:14:37 EDT
*** Bug 122422 has been marked as a duplicate of this bug. ***
Comment 10 Mike McLean 2004-05-12 17:22:10 EDT
This now happens with upgrades (from say RHL-9 or FC1), b/c the config
is still named XF86Config.

The real issue though is that firstboot is doing this even though it
is supposed to be turned off.  The initscript itself does not check
/etc/sysconfig/firstboot; it just goes ahead and runs
system-config-display.
Comment 11 Brent Fox 2004-05-17 14:28:12 EDT
Is firstboot ever getting run after doing the initial install?  If so,
firstboot should call "/sbin/chkconfig --del firstboot" when it
completes which should make sure that the initscript never gets run again.
Comment 12 Mike McLean 2004-05-17 18:12:08 EDT
The scenario here is a kickstart install followed by a kickstart
upgrade.  There is never a user at the console, and firstboot should
never get run.  The problem (which I believe Elliot fixed) was that
the firstboot initscript (not the actual python code) was running
system-config-display even though /etc/sysconfig/firstboot indicated
that firstboot was disabled.
Comment 13 Brent Fox 2004-06-17 15:51:45 EDT
Mike: which version of firstboot are you seeing this problem on?  As
far as I can tell, the change that Elliot made (contained in
firstboot-1.3.14-1) should have fixed this problem.

The initscript now contains:

if [ ! -f /etc/X11/xorg.conf -a ! -f /etc/X11/XF86Config ] ; then
	echo -n $"X is not configured.  Running system-config-display"
	/usr/bin/system-config-display

which I believe will only run system-config-display only if both
xorg.conf and XF86Config do not exist.
Comment 14 Mike McLean 2004-06-17 16:51:27 EDT
Yes, Elliot's changes did fix this bug.

However, after a second look, it seems the changes may err a bit too
far on the "don't run" side.  Now the initscript will exit immediately
if /etc/sysconfig/firstboot exists, even if reconfig is passed on the
kernel cmdline.

I'm attaching a patch that takes a more balanced approach.
Comment 15 Mike McLean 2004-06-17 16:52:21 EDT
Created attachment 101229 [details]
a slightly more robust approach
Comment 16 Brent Fox 2004-06-21 13:58:36 EDT
Patch applied in firstboot-1.3.15-1.  Thanks for the patch.
Comment 17 Brent Fox 2004-06-25 11:49:34 EDT
*** Bug 121820 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.