This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 121820 - firstboot x config lists only very low screen resolutions
firstboot x config lists only very low screen resolutions
Status: CLOSED DUPLICATE of bug 121489
Product: Fedora
Classification: Fedora
Component: firstboot (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Brent Fox
:
: 122205 122459 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-04-28 05:52 EDT by Bernd Bartmann
Modified: 2007-11-30 17:10 EST (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 14:02:48 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Bernd Bartmann 2004-04-28 05:52:21 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.6)
Gecko/20040113

Description of problem:
After installing FC2T3 system-config-xfree has been started
automatically and I choose 1280x1024 as my default screen resolution.

Then firstboot started and asked me again to set my screen resolution,
but this only 640x480 and 800x600 were available.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. boot a freshly installed FC2T3
2. system-config-xfree runs --> set a default resolution
3. firstboot runs --> have a look at the available resolutions
    

Additional info:
Comment 1 Bernd Bartmann 2004-04-28 05:54:24 EDT
At the end 1280x1024 is used so the settings made in firstboot are
being ignored.
Comment 2 Luis Montes 2004-04-28 13:02:42 EDT
I've got the same problem. I just installed FC2 test3. After i
restarted I picked 1400x1050 the first time it asked (dell inspiron
5150 laptop, geforcefx go, stock nv non-accelerated driver) Then, i
got the welcome screen, license agreement, date & time screen, and Now
its asking to change screen settings again!
Its only showing options for 800x600 & 640x480 which  will look
horrible on the LCD panel.

The funny thing is, that this welcome screen is in 1400x1050. Why is
it asking again?
Comment 3 Luis Montes 2004-04-28 13:08:18 EDT
one more thing.

It uses 640x480 for the screen resolution once i logged in, even
though i picked out 800x600 which is too low a resoultion anyway.
Comment 4 David Aspinall 2004-04-30 05:14:04 EDT
I also observed this.  Possibly relevant information: I chose "Generic
LCD panel 1024x768" for my laptop display.  Bug 121946 looks similar.
Seems quite odd to be asking the user more than once to configure
display settings during install.
Comment 5 Jason Knight 2004-04-30 22:16:02 EDT
I had this problem too, I tried editing the xorg.conf file as well and
manually putting mine at 1600x1200, I would restart X and lo and
behold it would be back to 640x480 and my changes to xorg.conf would
be gone. But then I saw the lines:
 ### Uncomment if you don't want to default to DDC:
#       HorizSync    30.0 - 110.0
#       VertRefresh  50.0 - 160.0
so I uncommented them, made it 1600x1200 and voila! It worked.
Comment 6 Jeff Myers 2004-05-01 09:25:56 EDT
I ran into this problem as well, on a laptop with a generic GeForce 4
driver and an LCD 1024x768 display.
Comment 7 Alan Cox 2004-05-05 06:35:25 EDT
*** Bug 122205 has been marked as a duplicate of this bug. ***
Comment 8 Nico Kadel-Garcia 2004-05-05 15:25:59 EDT
Me too: on a Sony Vaio PCG-SRX77p that's known to work reasonably 
well with RedHat 9.
Comment 9 Mike Panetta 2004-05-05 19:11:02 EDT
It happens to me as well.  HP Pavilion Laptop Generic 1024x768 display
(NO DDC).  It seems that the X config program cannot handle non DDC
monitors well, as I had to go and manualy edit the config file for it
to completely work with my display.
Comment 10 Brent Fox 2004-05-06 16:14:29 EDT

*** This bug has been marked as a duplicate of 121489 ***
Comment 11 Brent Fox 2004-06-17 14:57:14 EDT
*** Bug 122459 has been marked as a duplicate of this bug. ***
Comment 12 Nico Kadel-Garcia 2004-06-17 16:18:01 EDT
This is *not* a duplicate of 121489, which refers to excess re-
reunning of system-config-*. The underlying issue is that the system-
config-* programs mis-set the refresh rates on at least some laptop 
LCD screens, which can only be corrected by hand-editing 
the /etc/X11/xorg.conf file to reduce the vertical refresh rate to 
something the laptop LCD can actually support, such as 60 Cycles.
Comment 13 Brent Fox 2004-06-25 11:49:29 EDT
Nico: I disagree.  The original reporter's bug is a duplicate of bug
121489.  The problem is that system-config-display was getting run
twice, and the second time it was getting run is what was causing the
rates to get messed up.  

*** This bug has been marked as a duplicate of 121489 ***
Comment 14 Red Hat Bugzilla 2006-02-21 14:02:48 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.