Bug 122065 - Serial mouse not working unless gpm running
Serial mouse not working unless gpm running
Status: CLOSED DUPLICATE of bug 121139
Product: Fedora
Classification: Fedora
Component: system-config-mouse (Show other bugs)
rawhide
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Brent Fox
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-04-30 01:04 EDT by Phil Anderson
Modified: 2007-11-30 17:10 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 14:02:52 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Phil Anderson 2004-04-30 01:04:34 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.6)
Gecko/20040206 Firefox/0.8

Description of problem:
Some of my machines have 2 button serial mice.  Unless gpm is running,
they won't work in X.

Any additional info will be provided if you need it.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Use a normal 2 button MS serial mouse
2. Don't have gpm running
3. reboot the machine
    

Actual Results:  mouse won't work in X

Expected Results:  Mouse will work in X

Additional info:

if gpm is running (or has been run since the last reboot), then the
mouse will work in X!  Possibly gpm is doing some initialisation thing
which should be done in X as well?  Worked perfectly with FC1.
Comment 1 Michael Schwendt 2004-05-01 18:32:50 EDT
Same thing here, although my serial mouse doesn't work during
installation either (bug 119474).

"service gpm start" loads the "sermouse" kernel module, for instance.
But that is not enough if loaded manually.

I've noticed that the mouse driver section in /etc/X11/xorg.conf and
/etc/X11/XF86Config is wrong. And system-config-mouse doesn't correct
it. The config files are not written to by the backend. Only
/etc/sysconfig/mouse is correct.
Comment 2 Michael Schwendt 2004-05-01 20:08:07 EDT
Indeed, after I had configured /etc/X11/xorg.conf manually, my mouse
works fine in X.
Comment 3 Mike A. Harris 2004-05-04 13:44:13 EDT
I have Logitech serial mice locally, and one Microsoft serial mouse.
I've tested them all with 6.7.0, and all of them work properly, the
Logitech mice using the "MouseMan" protocol, and the Microsoft mouse
using the "Microsoft" protocol.  The Logitech also works with a few
of the other protocols in the past, however I haven't tested other
protocols with 6.7.0, but they should work still also, as the X
mouse driver hasn't been changed in any major way in ages.

I believe this problem is entirely a configuration problem.  I'm not
sure wether we officially support serial mice in our config tools now
or not.

Reassigning to system-config-mouse component.
Comment 4 Bill Nottingham 2004-05-04 14:50:02 EDT
This is intentional; serial mice are to be routed through the input
layer, so that config files don't need to be edited.

Unfortunately, it's not getting set up right on install because of bug
#121139

*** This bug has been marked as a duplicate of 121139 ***
Comment 5 Red Hat Bugzilla 2006-02-21 14:02:52 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.