Bug 122117 - Installer hangs when performing manual partitioning (disk druid)
Installer hangs when performing manual partitioning (disk druid)
Status: CLOSED DUPLICATE of bug 100747
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
athlon Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
Mike McLean
:
: 122225 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-04-30 13:28 EDT by Aad Rijnberg
Modified: 2015-10-05 11:08 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 14:02:54 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 46987 master MERGED packaging: setup: validate full fqdn Never

  None (edit)
Description Aad Rijnberg 2004-04-30 13:28:30 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4.1)
Gecko/20031114

Description of problem:
When I perform a new (graphic) install of Fedora Core 2 test3, using
the DVD image, then after selecting manual partitioning I get the disk
druid screen. First, when I move over buttons in that screen the
button color will change (slightly), but when I try to select a
partition, it will not react upon further commands (both from mouse
and keyboard) anymore (and the color changing of buttons when moving
over them is also not performed anymore). The computer is not
completely hanging, as the LED still reacts to pressing the CAPS-lock
button. I can not select Next, Prev or anything else (the reset button
did the trick :-( ). I have retried it several times, and each time it
got stuck there.
In Fedora Core 2 test2, I think I also had this behaviour, but then
after one or two retries I could get past this point.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.Boot with DVD
2.custom install
3.manual partition
    

Actual Results:  Installer does not continue, and won't react on user
input anymore.

Expected Results:  I should have been able to manually partition the
disk of my choice

Additional info:

I have two ATA100 harddisks and one SCSI harddisk. On the latter I
tried to install FC2test3.
Comment 1 Jeremy Katz 2004-05-03 10:16:14 EDT
What does your partition table look like before the install begins?
Comment 2 Jeremy Katz 2004-05-03 14:10:15 EDT
*** Bug 122225 has been marked as a duplicate of this bug. ***
Comment 3 Aad Rijnberg 2004-05-04 13:51:42 EDT
Here are my partition tables (if still useful...): 

# /sbin/fdisk -l

Disk /dev/sda: 9180 MB, 9180515328 bytes
255 heads, 63 sectors/track, 1116 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes

   Device Boot    Start       End    Blocks   Id  System
/dev/sda1   *         1        16    128488+  83  Linux
/dev/sda2            17      1074   8498385   83  Linux
/dev/sda3          1075      1116    337365   82  Linux swap

Disk /dev/hde: 200.0 GB, 200049647616 bytes
255 heads, 63 sectors/track, 24321 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes

   Device Boot    Start       End    Blocks   Id  System
/dev/hde1   *         1      3824  30716248+   7  HPFS/NTFS
/dev/hde2          3825     16708 103490730    f  Win95 Ext'd (LBA)
/dev/hde5          3825     11473  61440561    7  HPFS/NTFS

Disk /dev/hdf: 30.7 GB, 30735581184 bytes
16 heads, 63 sectors/track, 59554 cylinders
Units = cylinders of 1008 * 512 = 516096 bytes

   Device Boot    Start       End    Blocks   Id  System
/dev/hdf1   *         1       305    153688+  83  Linux
/dev/hdf2           306     36876  18431784   83  Linux
/dev/hdf3         36877     53130   8192016   83  Linux
/dev/hdf4         53131     59554   3237696    f  Win95 Ext'd (LBA)
/dev/hdf5         53131     59554   3237664+  83  Linux
[root@localhost root]#

I normally boot from hde (using grub).
Comment 4 David Balažic 2004-07-28 08:29:51 EDT
Duplicate of bug 100747 ?
Comment 5 Jeremy Katz 2004-09-22 15:38:08 EDT

*** This bug has been marked as a duplicate of 100747 ***
Comment 6 Red Hat Bugzilla 2006-02-21 14:02:54 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.