Bug 100747 - severn - diskdruid locks up
severn - diskdruid locks up
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
2
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
:
: 122117 128199 (view as bug list)
Depends On:
Blocks: CambridgeTarget
  Show dependency treegraph
 
Reported: 2003-07-24 18:15 EDT by Carlos Morgado
Modified: 2007-11-30 17:10 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-09-21 09:02:57 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Results of lspci -nvv on my system (4.90 KB, text/plain)
2003-11-24 06:34 EST, David Balažic
no flags Details
Otputs of fdisk, sfdisk and parted (7.14 KB, text/plain)
2004-01-10 10:54 EST, David Balažic
no flags Details

  None (edit)
Description Carlos Morgado 2003-07-24 18:15:05 EDT
If I click around enough (usually just 2 or 3 clicks) on the diskdruid screen
anaconda locks up - no keyboard or mouse response.

My partitition tables:
cat /proc/partitions
major minor  #blocks  name     rio rmerge rsect ruse wio wmerge wsect wuse
running use aveq
 
  22     0   80418240 hdc 20 59 242 80 4 3 32 0 -2 3110930 36727892
  22     1   65536096 hdc1 19 56 234 70 4 3 32 0 0 70 70
  22     2   14882112 hdc2 0 0 0 0 0 0 0 0 0 0 0
   3     0   20044080 hda 10240 24056 273494 147640 4029 4343 67488 161320 -3
3093460 33981272
   3     1    1052226 hda1 12 3 19 40 0 0 0 0 0 40 40
   3     2    1028160 hda2 3082 7677 86060 59340 1763 672 19624 39770 0 43010 99110
   3     3          1 hda3 0 0 0 0 0 0 0 0 0 0 0
   3     5   11269566 hda5 20 3 27 30 0 0 0 0 0 30 30
   3     6     530113 hda6 1 0 8 10 13 62 640 60 0 30 70
   3     7    4096543 hda7 5875 15783 172898 65250 766 230 8240 76520 0 58720 141770
   3     8    2064321 hda8 1245 575 14442 22900 1487 3379 38984 44970 0 13800 67870
Comment 1 Jeremy Katz 2003-07-24 18:25:09 EDT
Are the keyboard LEDs flashing?
Comment 2 Carlos Morgado 2003-07-24 18:55:31 EDT
No, X is responsive - I can do ctrl-alt stuff and the mouse pointer moves. As
far as I can tell it's just anaconda that stops processing events.
Comment 3 Jeremy Katz 2003-07-25 10:56:18 EDT
If you switch to tty2, does top show anything interesting going on?
Comment 4 Carlos Morgado 2003-07-25 12:30:26 EDT
Lots :) python2.2 (pid 145) runs away with 99.9% cpu and 24M RSS.

I also narrowed down the way to reproduce - it happens as soon as I click on the
graphical display of the disks. 
Comment 5 Kyle R Maxwell 2003-07-26 01:20:07 EDT
Just to note that the same thing happened to me while trying to upgrade 9 to
9.0.93. I reinstalled, this time telling it to do a fresh install, and it did
not reoccur.
Comment 6 Michael Fulbright 2003-07-30 14:32:32 EDT
Is it a particular area in the graphical display that causes the problem?
Comment 7 Carlos Morgado 2003-07-30 15:02:44 EDT
It happens when I click on the disk layout diagram.
Comment 8 Michael Fulbright 2003-08-11 16:47:51 EDT
Could you add the output from 'fdisk -l' to this report?
Comment 9 Carlos Morgado 2003-08-13 15:21:28 EDT
# fdisk -l
 
Disk /dev/hdc: 16 heads, 63 sectors, 159560 cylinders
Units = cylinders of 1008 * 512 bytes
 
   Device Boot    Start       End    Blocks   Id  System
/dev/hdc1             1    130032  65536096+  83  Linux
/dev/hdc2        130033    159560  14882112   83  Linux
 
Disk /dev/hda: 255 heads, 63 sectors, 2495 cylinders
Units = cylinders of 16065 * 512 bytes
 
   Device Boot    Start       End    Blocks   Id  System
/dev/hda1   *         1       131   1052226    b  Win95 FAT32
/dev/hda2           132       259   1028160   83  Linux
/dev/hda3           260      2495  17960670    f  Win95 Ext'd (LBA)
/dev/hda5           260      1662  11269566    b  Win95 FAT32
/dev/hda6          1663      1728    530113+  82  Linux swap
/dev/hda7          1729      2238   4096543+  83  Linux
/dev/hda8          2239      2495   2064321   83  Linux
Comment 10 Jeremy Katz 2003-10-15 16:31:55 EDT
Does this still happen with test3?  (I just clicked around a lot in the
partition display on a 40-ish partition system)
Comment 11 Carlos Morgado 2003-10-21 18:51:59 EDT
I can still reproduce with 9.0.95. I'm choosing fresh install -> disk druid.
My disks are already partitioned and have RH installed, all partiotions have
filesystems. 
Do you need any more info ? 
Comment 12 Jeremy Katz 2003-10-21 18:56:49 EDT
What sort of video card?
Comment 13 Carlos Morgado 2003-10-21 19:18:22 EDT
geforce4 ti4200 01:00.0 Class 0300: 10de:0281 (rev a1)
when I opened the bug the box had a gf4mx440 iirc

the monitor is a sony g200 - it doesn't get detected which I find odd.
Comment 14 Jeremy Katz 2003-10-23 15:41:18 EDT
And things just completely lock up?  And it's very reproducible?  Do
you see similar hangs on the installed system in any way?
Comment 15 David Balažic 2003-11-24 06:32:29 EST
This happened to me too :

Was installing FC1.

Deleted partition hde6 in DD, clicked DELETE in the confirmation dialog.
Then clicked on another partition on the grahical display on top, but
there
was no response. A switched to VT2 and back and the screen did not
redraw. top on VT2 shows that process /usr/bin/python2.2 (PID 180)
is suing 99.9% of CPU. That process is actually anaconda.

This is reproducible:

Boot yarrow cd1. Press enter in boot menu to select default.
Skip CD test ( self burned CD, they all passed test earlier on this
hardware )
- select english language
- select Slovenian keyboard
- accept autoprobed PS/2 3-button mouse
- select monitor Hyundai HT-7695B
- select install ( not update )
- select custom install
- select manual partitioning
- delete hde6
- /usr/bin/python2-2 process hangs ( now it is PID 173 )

On another try  it did not hang when deleting hde6, but later ( still
inside disk druid )
Again the python process is at 99% CPU.

gfx card is radeon 8500LE

fdisk -lu :

Disk /dev/hdg: 20.4 GB, 20416757760 bytes
255 heads, 63 sectors/track, 2482 cylinders, total 39876480 sectors
Units = sectors of 1 * 512 = 512 bytes

   Device Boot    Start       End    Blocks   Id  System
/dev/hdg1   *        63    208844    104391   83  Linux
/dev/hdg2        208845  10442249   5116702+  83  Linux
/dev/hdg3      10442250  11566799    562275   82  Linux swap
/dev/hdg4      11566800  39873329  14153265    f  Win95 Ext'd (LBA)
/dev/hdg5      11566863  19759949   4096543+  83  Linux

Disk /dev/hde: 61.4 GB, 61492838400 bytes
255 heads, 63 sectors/track, 7476 cylinders, total 120103200 sectors
Units = sectors of 1 * 512 = 512 bytes

   Device Boot    Start       End    Blocks   Id  System
/dev/hde1   *        63   6136829   3068383+   7  HPFS/NTFS
/dev/hde2       6136830  26619704  10241437+   c  Win95 FAT32 (LBA)
/dev/hde3      26619705 120085874  46733085    f  Win95 Ext'd (LBA)
/dev/hde5      26619768  47102579  10241406    7  HPFS/NTFS
/dev/hde6      47102643  57335984   5116671   83  Linux
/dev/hde7      57336048  57946454    305203+  82  Linux swap
/dev/hde8      57946518 120085874  31069678+   7  HPFS/NTFS

Comment 16 David Balažic 2003-11-24 06:34:07 EST
Created attachment 96148 [details]
Results of lspci -nvv on my system

BTW, are there any updated anaconda versions ( update floppies ) ?
Comment 17 Michael Schwendt 2003-11-24 09:03:02 EST
For reference: bug 102641 (but I can't help, since after
repartitioning I can no longer reproduce the problem)
Comment 18 David Balažic 2003-11-26 04:47:29 EST
It seems the lockup happens when I click on any part of the second
disk in the upper graphical display ( the bar representing the disk
and its partitions ).

Clicking on the first disk is no problem. Also selecting partitions in
the bottom table is no problem either.

The partition layout of the second disk seems not to play any role,
since I wiped it out and created a new partition and the same thing
happens.

In short :
Two already partitioned disks. Click on the second.  Lockup.

Lockup = 99.9% CPU in the anaconda process, no X display updates any
more, everything else still works.
Comment 19 David Balažic 2003-12-07 03:16:51 EST
Tried it (yarrow) on another computer with two IDE disks and it does
not lock up there ...
Comment 20 David Balažic 2004-01-10 10:50:17 EST
Tried it again on my PC , this time with 3 disks ( hde, hdg, hdh ).
Lock up the first time I click on the third disk in the upper
graphical part. Clicking in the table below works without problems.

Version : Fedora Core 1
Steps :
boot the FC1 install cd
select Personal Desktop
select manual partitioning
click around in the table ( works OK )
click on the second or third disk in the upper graphical representation
lockup
top shows /usr/bin/python2.2 running with 99.9% CPU

Disk layout details attached below
Comment 21 David Balažic 2004-01-10 10:54:03 EST
Created attachment 96877 [details]
Otputs of fdisk, sfdisk and parted
Comment 22 David Balažic 2004-07-28 08:27:20 EDT
Still there in FC2 ( and probably FC3test-x , judging by other bug
reports, like bug 128199 )
Comment 23 Stef Walter 2004-09-20 23:27:39 EDT
I have experienced this as well. It's happened on two different
machines. Clicking on the graphical display of disks causes a hang. 
Comment 24 Jeremy Katz 2004-09-21 09:02:57 EDT
A cause of this occurring should be fixed in FC3 test2
Comment 25 Jeremy Katz 2004-09-22 15:38:26 EDT
*** Bug 122117 has been marked as a duplicate of this bug. ***
Comment 26 Jeremy Katz 2004-09-22 15:52:39 EDT
*** Bug 128199 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.