Bug 1222194 - Upgrade failed from satellite 6.0.6 could not evaluate
Summary: Upgrade failed from satellite 6.0.6 could not evaluate
Status: CLOSED DUPLICATE of bug 924383
Alias: None
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Upgrades
Version: 6.1.0
Hardware: Unspecified
OS: Unspecified
unspecified
high vote
Target Milestone: Unspecified
Assignee: Eric Helms
QA Contact: Katello QA List
David O'Brien
URL:
Whiteboard:
Keywords: ReleaseNotes, Triaged
Depends On:
Blocks: GSS_Sat6Beta_Tracker, GSS_Sat6_Tracker sat61-release-notes
TreeView+ depends on / blocked
 
Reported: 2015-05-16 07:42 UTC by jnikolak
Modified: 2016-03-09 21:12 UTC (History)
5 users (show)

(edit)
Clone Of:
(edit)
Last Closed: 2016-03-09 21:12:29 UTC


Attachments (Terms of Use)
rhel7_update_log (352.29 KB, text/plain)
2015-05-16 07:42 UTC, jnikolak
no flags Details
foreman-debug (429.12 KB, application/x-xz)
2015-05-16 07:56 UTC, jnikolak
no flags Details

Description jnikolak 2015-05-16 07:42:37 UTC
Created attachment 1026162 [details]
rhel7_update_log

The upgrade failed to satellite 6.1, this issue may occur if customer installed satellite with one hostname, then changed the hostname to another.

Followed process to change hostname -> https://access.redhat.com/solutions/1232133 before upgrading, satellite was functioning as normal.

Uploading foreman-debug and install log attached.

Comment 1 RHEL Product and Program Management 2015-05-16 07:42:48 UTC
Since this issue was entered in Red Hat Bugzilla, the release flag has been
set to ? to ensure that it is properly evaluated for this release.

Comment 3 jnikolak 2015-05-16 07:56:04 UTC
Created attachment 1026165 [details]
foreman-debug

Comment 4 jnikolak 2015-05-16 08:52:16 UTC
The documentation to change the answers.katello-installer was not verified.

After i verified and corrected it using perl, 

I then re ran the upgrade which worked.

 katello-installer --upgrade
Upgrading...
Upgrade Step: migrate_pulp...
Upgrade Step: migrate_candlepin...
Upgrade Step: migrate_foreman...
Upgrade Step: Running installer...
Installing             Done                                               [100%] [...............................................................................................................................]
  The full log is at /var/log/katello-installer/katello-installer.log
Upgrade Step: Restarting services...
Upgrade Step: db:seed...
Upgrade Step: Running errata import task (this may take a while)...
Katello upgrade completed!


However after logging in and trying to access the about page.
http:fqdn/about it hanged.

Comment 5 David O'Brien 2015-08-11 06:11:50 UTC
Is there any info I can add to this rel note request as a workaround or similar to help guide the customer?

thanks

Comment 6 Mike McCune 2015-08-18 21:00:31 UTC
There isn't a specific workaround. To ensure a proper upgrade do not change the Satellite hostname prior or during the upgrade.

Currently changing the hostname is not supported but will be in a future release.

Comment 8 Eric Helms 2016-03-09 21:12:29 UTC

*** This bug has been marked as a duplicate of bug 924383 ***


Note You need to log in before you can comment on or make changes to this bug.