Bug 924383 - [RFE] Need a server side tool to assist with the process of changing the hostname of the Katello server
[RFE] Need a server side tool to assist with the process of changing the host...
Status: CLOSED ERRATA
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Infrastructure (Show other bugs)
6.0.0
Unspecified Unspecified
high Severity high with 1 vote (vote)
: 6.2.12
: --
Assigned To: John Mitsch
Peter Ondrejka
http://projects.theforeman.org/issues...
: FutureFeature, PrioBumpGSS, Reopened, Triaged
: 1152797 1222194 (view as bug list)
Depends On:
Blocks: CEE_Sat6_Top_BZs/GSS_Sat6_Top_Bugs 1152797 sat61-release-notes 1269671 1451564
  Show dependency treegraph
 
Reported: 2013-03-21 12:14 EDT by Mike McCune
Modified: 2017-09-25 14:59 EDT (History)
37 users (show)

See Also:
Fixed In Version: katello-3.0.0-26
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
: 1480346 (view as bug list)
Environment:
Last Closed: 2017-09-25 14:59:44 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
kickstart-sync-log (16.40 KB, text/plain)
2017-09-21 05:02 EDT, Peter Ondrejka
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Knowledge Base (Solution) 1232133 None None None Never
Foreman Issue Tracker 17522 None None None 2016-11-29 17:01 EST
Foreman Issue Tracker 18403 None None None 2017-04-27 13:50 EDT
Red Hat Product Errata RHBA-2017:2803 normal SHIPPED_LIVE Satellite 6.2.12 bug fix update 2017-10-12 15:22:49 EDT

  None (edit)
Description Mike McCune 2013-03-21 12:14:09 EDT
Spacewalk has a tool called 'spacewalk-hostname-rename' that will update the certificates and configurations on the spacewalk server so it can be migrated to a new hostname.

We need this for katello as well.  The current process to change your Katello hostname is undocumented and painful.
Comment 2 Bryan Kearney 2014-06-13 11:27:51 EDT
See also: https://bugzilla.redhat.com/show_bug.cgi?id=876359
Comment 3 Mike McCune 2014-10-15 00:19:57 EDT
we have this now:

https://access.redhat.com/solutions/1232133

closing:currentrelease
Comment 4 Xixi 2014-10-22 19:13:01 EDT
(In reply to Mike McCune from comment #3)
> https://access.redhat.com/solutions/1232133

Documentation BZ tracking official doc inclusion:
Bug 1152797 - [RFE] Provide Method to update Satellite FQDN and associated certificates
Comment 6 David O'Brien 2014-12-10 07:36:52 EST
https://access.redhat.com/solutions/1232133

Please refer to djuran's comments in this article. Procedure doesn't seem to work.
Comment 9 Eric Helms 2016-03-09 16:12:29 EST
*** Bug 1222194 has been marked as a duplicate of this bug. ***
Comment 10 Pavel Moravec 2016-07-15 03:24:04 EDT
Does this BZ cover changing hostname of Satellite only, or also Capsule (there are customers with both requests)?
Comment 11 Mike McCune 2016-08-04 11:47:52 EDT
*** Bug 1152797 has been marked as a duplicate of this bug. ***
Comment 14 Bryan Kearney 2016-08-04 16:19:45 EDT
Moving 6.2 bugs out to sat-backlog.
Comment 16 John Mitsch 2016-11-29 16:04:28 EST
Created redmine issue http://projects.theforeman.org/issues/17522 from this bug
Comment 19 pm-sat@redhat.com 2017-01-25 16:03:41 EST
Moving this bug to POST for triage into Satellite 6 since the upstream issue http://projects.theforeman.org/issues/17522 has been resolved.
Comment 21 John Mitsch 2017-04-27 13:50:43 EDT
Connecting redmine issue http://projects.theforeman.org/issues/18403 from this bug
Comment 33 John Mitsch 2017-09-14 13:37:35 EDT
I updated my MR to fix the installation media paths, peter tested it with success, it is now merged. 

I reviewed Evgeni's upstream PRs for the issues he mentioned, one is merged, one is waiting on a rebase, and the third is waiting on the contributor. Thanks Evgeni!

I'll submit an upstream PR for http://projects.theforeman.org/issues/20925 and link up these issues with this BZ. After these are merged we will be all set.

-John
Comment 38 Peter Ondrejka 2017-09-21 05:02 EDT
Created attachment 1328879 [details]
kickstart-sync-log
Comment 41 errata-xmlrpc 2017-09-25 14:59:44 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2017:2803

Note You need to log in before you can comment on or make changes to this bug.