Bug 1222450 - Trackpad has physical buttons, but two finger scrolling option is greyed out.
Summary: Trackpad has physical buttons, but two finger scrolling option is greyed out.
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: control-center
Version: 22
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Control Center Maintainer
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-05-18 09:01 UTC by Rodd Clarkson
Modified: 2015-05-19 06:13 UTC (History)
9 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-05-19 06:13:01 UTC


Attachments (Terms of Use)
output from libinput-list-devices (2.21 KB, text/plain)
2015-05-18 09:35 UTC, Rodd Clarkson
no flags Details
output for evemu-describe /dev/input/event12 (3.68 KB, text/plain)
2015-05-18 09:38 UTC, Rodd Clarkson
no flags Details

Description Rodd Clarkson 2015-05-18 09:01:33 UTC
Description of problem:

This is a follow up to https://bugzilla.redhat.com/show_bug.cgi?id=1222445#c61

My trackpad has physical buttons for left and right click but the two finger scrolling is grey out.



Version-Release number of selected component (if applicable):

control-center-3.16.2-1.fc22.x86_64


How reproducible:

Always


Steps to Reproduce:
1. Open Setings > Mouse & Touchpad


Actual results:

The two finger scrolling option is grey out (and selected).


Expected results:

The two finger scrolling option is available on trackpads with physical buttons.

Comment 1 Peter Hutterer 2015-05-18 09:30:21 UTC
Do me a favour and run libinput-list-local-devices and attach the output, followed by an evemu-describe of your device. Judging by Bug 1206961#c60, only two-finger scrolling is available anyway which is unusual for your touchpad.

That aside, I think the greyed out toggle is intentional: looks like g-c-c only sets it sensitive if you can switch between methods, otherwise it's greyed out and permanently enabled. 

https://git.gnome.org/browse/gnome-control-center/tree/panels/mouse/gnome-mouse-properties.c#n157

Comment 2 Rodd Clarkson 2015-05-18 09:35:00 UTC
Created attachment 1026641 [details]
output from libinput-list-devices

Comment 3 Rodd Clarkson 2015-05-18 09:38:38 UTC
Created attachment 1026642 [details]
output for evemu-describe /dev/input/event12

Comment 4 Peter Hutterer 2015-05-19 00:07:18 UTC
What laptop is this again? the device lists as INPUT_PROP_BUTTONPAD but you say it has physical buttons?

Comment 5 Rodd Clarkson 2015-05-19 02:01:57 UTC
Maybe I'm confused about what physical buttons are?

It's a Dell XPS 13 (2014).  The mousepad is a single surface, but there are distinct spots marked on the trackpad as left and right 'buttons' and when you click them the 'click' and act like left and right buttons (as seperate from tapping the trackpad and getting a click-like behaviour.)

Comment 6 Peter Hutterer 2015-05-19 06:13:01 UTC
rightyo, so in this case everything works as intended then.

by physical buttons we mean separate buttons like in the olden days. if the touchpad is a single surface it's a so-called clickpad (or BUTTONPAD in kernel terminology) and button emulation is all handled in the userspace stack (either software buttons or by multi-finger click).
http://wayland.freedesktop.org/libinput/doc/latest/clickpad_softbuttons.html

since we only support two-finger scrolling on such touchpads, gnome greys out the option, but scrolling should continue to work. so, afaict this is not a bug, it's everything working as intended.


Note You need to log in before you can comment on or make changes to this bug.