Bug 1224894 - Quota: spurious failures with quota testcases
Summary: Quota: spurious failures with quota testcases
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: GlusterFS
Classification: Community
Component: quota
Version: 3.7.0
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Vijaikumar Mallikarjuna
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks: qe_tracker_everglades glusterfs-3.7.1
TreeView+ depends on / blocked
 
Reported: 2015-05-26 07:19 UTC by Vijaikumar Mallikarjuna
Modified: 2016-05-11 22:48 UTC (History)
3 users (show)

Fixed In Version: glusterfs-3.7.1
Doc Type: Bug Fix
Doc Text:
Clone Of: 1223798
Environment:
Last Closed: 2015-06-02 08:03:20 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)

Description Vijaikumar Mallikarjuna 2015-05-26 07:19:15 UTC
+++ This bug was initially created as a clone of Bug #1223798 +++

Some of the below test cases spuriously failing.
./tests/bugs/distribute/bug-1161156.t
./tests/bugs/quota/bug-1038598.t


Problem is quota enforcer doesn't consider parallel writes and fail to send EDQUOT and allow to exceed quota with few %.


For now, with this patch we fix the testcases not to send parallel writes.
Bug# 1223658 tracks the parallel write issue with quota.

--- Additional comment from Anand Avati on 2015-05-21 09:13:26 EDT ---

REVIEW: http://review.gluster.org/10878 (Quota: fix testcases not to send parallel writes for accurate quota enforcement) posted (#1) for review on master by Vijaikumar Mallikarjuna (vmallika@redhat.com)

--- Additional comment from Anand Avati on 2015-05-21 22:20:14 EDT ---

REVIEW: http://review.gluster.org/10878 (Quota: fix testcases not to send parallel writes for accurate quota enforcement) posted (#2) for review on master by Vijaikumar Mallikarjuna (vmallika@redhat.com)

--- Additional comment from Anand Avati on 2015-05-25 04:09:00 EDT ---

REVIEW: http://review.gluster.org/10878 (Quota: fix testcases not to send parallel writes for accurate quota enforcement) posted (#3) for review on master by Vijaikumar Mallikarjuna (vmallika@redhat.com)

--- Additional comment from Anand Avati on 2015-05-25 04:16:42 EDT ---

REVIEW: http://review.gluster.org/10878 (Quota: fix testcases not to send parallel writes for accurate quota enforcement) posted (#4) for review on master by Vijaikumar Mallikarjuna (vmallika@redhat.com)

--- Additional comment from Anand Avati on 2015-05-25 14:34:28 EDT ---

COMMIT: http://review.gluster.org/10878 committed in master by Raghavendra G (rgowdapp@redhat.com) 
------
commit 225ff553106396066d68d8c757e5c001f5d9ab15
Author: vmallika <vmallika@redhat.com>
Date:   Mon May 25 13:35:48 2015 +0530

    Quota: fix testcases not to send parallel writes for accurate
    quota enforcement
    
    Currently quota enforcer doesn't consider parallel writes
    and allows quota to exceed limit where there are high rate
    of parallel writes. Bug# 1223658 tracks the issue.
    
    This patch fixes the spurious failures by not sending
    parallel writes.
    Using O_SYNC and O_APPEND flags and block size
    not more that 256k (For higher block size NFS client
    splits the block into 256k chinks and does parallel writes)
    
    Change-Id: I297c164b030cecb87ce5b494c02b09e8b073b276
    BUG: 1223798
    Signed-off-by: vmallika <vmallika@redhat.com>
    Reviewed-on: http://review.gluster.org/10878
    Tested-by: NetBSD Build System
    Tested-by: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Raghavendra G <rgowdapp@redhat.com>
    Tested-by: Raghavendra G <rgowdapp@redhat.com>

Comment 1 Anand Avati 2015-05-26 07:20:03 UTC
REVIEW: http://review.gluster.org/10910 (Quota: fix testcases not to send parallel writes for accurate quota enforcement) posted (#1) for review on release-3.7 by Vijaikumar Mallikarjuna (vmallika@redhat.com)

Comment 2 Anand Avati 2015-05-28 06:39:13 UTC
REVIEW: http://review.gluster.org/10958 (quota: fix for spurious failure) posted (#1) for review on release-3.7 by Vijaikumar Mallikarjuna (vmallika@redhat.com)

Comment 3 Anand Avati 2015-05-28 07:01:45 UTC
REVIEW: http://review.gluster.org/10910 (Quota: fix testcases not to send parallel writes for accurate  quota enforcement) posted (#2) for review on release-3.7 by Vijaikumar Mallikarjuna (vmallika@redhat.com)

Comment 4 Anand Avati 2015-05-29 06:25:03 UTC
COMMIT: http://review.gluster.org/10958 committed in release-3.7 by Pranith Kumar Karampuri (pkarampu@redhat.com) 
------
commit e3408108e36dac08d217f558b5cc69dff71bbcbf
Author: vmallika <vmallika@redhat.com>
Date:   Thu May 28 12:03:22 2015 +0530

    quota: fix for spurious failure
    
    This is a backport of http://review.gluster.org/#/c/10918/
    
    > During ancestry build, loc path was set to invalid
    > path. path was set to one of its child instead
    > of itself. Because of this quota accounting was
    > going wrong
    >
    > This patch fix the issue
    >
    > Below mentioned tests removed from bad test list
    > as part of patch# 10930
    >         ./tests/basic/ec/quota.t
    >         ./tests/basic/quota-nfs.t
    >         ./tests/bugs/quota/bug-1035576.t
    >
    > Change-Id: Iaa65b2d968c04c9abcd476d0e9f588cb7fd39294
    > BUG: 1223798
    > Signed-off-by: vmallika <vmallika@redhat.com>
    > Reviewed-on: http://review.gluster.org/10918
    > Tested-by: NetBSD Build System
    > Reviewed-by: Vijay Bellur <vbellur@redhat.com>
    
    Change-Id: I2986d18c111790bef8f2a7a1df5e43f46755e85e
    BUG: 1224894
    Signed-off-by: vmallika <vmallika@redhat.com>
    Reviewed-on: http://review.gluster.org/10958
    Tested-by: Gluster Build System <jenkins@build.gluster.com>
    Tested-by: NetBSD Build System
    Reviewed-by: Pranith Kumar Karampuri <pkarampu@redhat.com>

Comment 5 Anand Avati 2015-05-29 06:29:10 UTC
COMMIT: http://review.gluster.org/10910 committed in release-3.7 by Pranith Kumar Karampuri (pkarampu@redhat.com) 
------
commit f6e72c45ad754073bc8269e954d236bab9e4a0e7
Author: vmallika <vmallika@redhat.com>
Date:   Thu May 28 12:30:02 2015 +0530

    Quota: fix testcases not to send parallel writes for accurate
     quota enforcement
    
    This is a backport of http://review.gluster.org/#/c/10878
    
    > Currently quota enforcer doesn't consider parallel writes
    > and allows quota to exceed limit where there are high rate
    > of parallel writes. Bug# 1223658 tracks the issue.
    >
    > This patch fixes the spurious failures by not sending
    > parallel writes.
    > Using O_SYNC and O_APPEND flags and block size
    > not more that 256k (For higher block size NFS client
    > splits the block into 256k chinks and does parallel writes)
    >
    > Change-Id: I297c164b030cecb87ce5b494c02b09e8b073b276
    > BUG: 1223798
    > Signed-off-by: vmallika <vmallika@redhat.com>
    > Reviewed-on: http://review.gluster.org/10878
    > Tested-by: NetBSD Build System
    > Tested-by: Gluster Build System <jenkins@build.gluster.com>
    > Reviewed-by: Raghavendra G <rgowdapp@redhat.com>
    > Tested-by: Raghavendra G <rgowdapp@redhat.com>
    
    Change-Id: I78b6250eb0b3fbbbab1d4348d4e81d6292c6c6bb
    BUG: 1224894
    Signed-off-by: vmallika <vmallika@redhat.com>
    Reviewed-on: http://review.gluster.org/10910
    Tested-by: Gluster Build System <jenkins@build.gluster.com>
    Tested-by: NetBSD Build System
    Reviewed-by: Pranith Kumar Karampuri <pkarampu@redhat.com>

Comment 6 Anand Avati 2015-05-31 04:07:25 UTC
COMMIT: http://review.gluster.org/11013 committed in release-3.7 by Vijay Bellur (vbellur@redhat.com) 
------
commit f52e77d57fd64881a653d61ecb325b75f7f009c6
Author: Raghavendra Bhat <raghavendra@redhat.com>
Date:   Tue May 26 15:10:25 2015 +0530

    tests/uss.t: wait for connection to complete before accessing a file in snapshot
    
    Change-Id: I82d0cb378d006777d5a304afe8d5be15e92c7245
    BUG: 1224894
    Signed-off-by: Raghavendra Bhat <raghavendra@redhat.com>
    Reviewed-on: http://review.gluster.org/10915
    Tested-by: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Vijay Bellur <vbellur@redhat.com>
    Reviewed-on: http://review.gluster.org/11013
    Reviewed-by: Niels de Vos <ndevos@redhat.com>
    Tested-by: NetBSD Build System <jenkins@build.gluster.org>

Comment 7 Anand Avati 2015-05-31 04:09:49 UTC
REVIEW: http://review.gluster.org/11014 (tests: Add mount-nfs-auth.t to is_bad_test()) posted (#1) for review on release-3.7 by Vijay Bellur (vbellur@redhat.com)

Comment 8 Niels de Vos 2015-06-02 08:03:20 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.7.1, please reopen this bug report.

glusterfs-3.7.1 has been announced on the Gluster Packaging mailinglist [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://thread.gmane.org/gmane.comp.file-systems.gluster.packaging/1
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user


Note You need to log in before you can comment on or make changes to this bug.