Bug 1225999 - Update gluster op version to 30701
Summary: Update gluster op version to 30701
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: GlusterFS
Classification: Community
Component: glusterd
Version: 3.7.0
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Shyamsundar
QA Contact:
URL:
Whiteboard:
Depends On: 1223432
Blocks: glusterfs-3.7.2
TreeView+ depends on / blocked
 
Reported: 2015-05-28 17:26 UTC by Shyamsundar
Modified: 2015-06-20 09:49 UTC (History)
3 users (show)

Fixed In Version: glusterfs-3.7.2
Doc Type: Bug Fix
Doc Text:
Clone Of: 1223432
: 1227884 (view as bug list)
Environment:
Last Closed: 2015-06-20 09:49:00 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)

Description Shyamsundar 2015-05-28 17:26:45 UTC
+++ This bug was initially created as a clone of Bug #1223432 +++

Description of problem:
Increment the operating version for gluster to 3.7.1 now that 3.7 is released. Also, there is a dependent DHT change for a new configuration option that needs an incremented gluster operating version.

--- Additional comment from Anand Avati on 2015-05-20 09:48:52 EDT ---

REVIEW: http://review.gluster.org/10849 (glusterd: Bump op version and max op version for 3.7.1) posted (#1) for review on master by Shyamsundar Ranganathan (srangana@redhat.com)

--- Additional comment from Anand Avati on 2015-05-20 16:37:40 EDT ---

REVIEW: http://review.gluster.org/10849 (glusterd: Bump op version and max op version for 3.7.1) posted (#2) for review on master by Shyamsundar Ranganathan (srangana@redhat.com)

--- Additional comment from Anand Avati on 2015-05-21 11:41:28 EDT ---

REVIEW: http://review.gluster.org/10849 (glusterd: Bump op version and max op version for 3.7.1) posted (#3) for review on master by Shyamsundar Ranganathan (srangana@redhat.com)

--- Additional comment from Anand Avati on 2015-05-22 15:11:50 EDT ---

REVIEW: http://review.gluster.org/10849 (glusterd: Bump op version and max op version for 3.7.1) posted (#5) for review on master by Shyamsundar Ranganathan (srangana@redhat.com)

--- Additional comment from Anand Avati on 2015-05-28 00:19:45 EDT ---

REVIEW: http://review.gluster.org/10849 (glusterd: Bump op version and max op version for 3.7.1) posted (#7) for review on master by Raghavendra G (rgowdapp@redhat.com)

--- Additional comment from Anand Avati on 2015-05-28 10:08:31 EDT ---

COMMIT: http://review.gluster.org/10849 committed in master by Krishnan Parthasarathi (kparthas@redhat.com) 
------
commit 433d1154d36cbb2b0c3218247e656940e1fc40fb
Author: Shyam <srangana@redhat.com>
Date:   Wed May 20 09:47:05 2015 -0400

    glusterd: Bump op version and max op version for 3.7.1
    
    As 3.7 is released, and a DHT configuration option needs higher
    op version, bumping the gluster op-version to 3.7.1 (or 30701).
    
    Change-Id: I9747cf93b41be72e43077ed8e977e21eed99ccc3
    BUG:  1223432
    Signed-off-by: Shyam <srangana@redhat.com>
    Reviewed-on: http://review.gluster.org/10849
    Reviewed-by: Kaushal M <kaushal@redhat.com>
    Tested-by: NetBSD Build System
    Tested-by: Gluster Build System <jenkins@build.gluster.com>

Comment 1 Anand Avati 2015-05-28 18:06:55 UTC
REVIEW: http://review.gluster.org/10975 (glusterd: Bump op version and max op version for 3.7.1) posted (#2) for review on release-3.7 by Shyamsundar Ranganathan (srangana@redhat.com)

Comment 2 Niels de Vos 2015-06-02 08:20:22 UTC
The required changes to fix this bug have not made it into glusterfs-3.7.1. This bug is now getting tracked for glusterfs-3.7.2.

Comment 3 Anand Avati 2015-06-02 11:57:45 UTC
COMMIT: http://review.gluster.org/10975 committed in release-3.7 by Krishnan Parthasarathi (kparthas@redhat.com) 
------
commit ffb207dfbd118e4dad8055a2c2ebe53b893c9745
Author: Shyam <srangana@redhat.com>
Date:   Wed May 20 09:47:05 2015 -0400

    glusterd: Bump op version and max op version for 3.7.1
    
    As 3.7 is released, and a DHT configuration option needs higher
    op version, bumping the gluster op-version to 3.7.1 (or 30701).
    
    Change-Id: I9747cf93b41be72e43077ed8e977e21eed99ccc3
    BUG:  1225999
    Signed-off-by: Shyam <srangana@redhat.com>
    Reviewed-upstream-on: http://review.gluster.org/10849
    Reviewed-by: Kaushal M <kaushal@redhat.com>
    Reviewed-on: http://review.gluster.org/10975
    Tested-by: NetBSD Build System <jenkins@build.gluster.org>
    Tested-by: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Kaleb KEITHLEY <kkeithle@redhat.com>

Comment 4 Niels de Vos 2015-06-20 09:49:00 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.7.2, please reopen this bug report.

glusterfs-3.7.2 has been announced on the Gluster Packaging mailinglist [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://www.gluster.org/pipermail/packaging/2015-June/000006.html
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user


Note You need to log in before you can comment on or make changes to this bug.