Bug 122618 - Spell checking for emacs passes wrong names for language specific dictionaries
Spell checking for emacs passes wrong names for language specific dictionaries
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: emacs (Show other bugs)
rawhide
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jens Petersen
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-05-06 08:38 EDT by David Jansen
Modified: 2007-11-30 17:10 EST (History)
2 users (show)

See Also:
Fixed In Version: 21.3-15
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-08-24 00:46:28 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description David Jansen 2004-05-06 08:38:32 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4.1)
Gecko/20031114

Description of problem:
Spellchecking from emacs doesn't work in the Dutch language. The
"Tools - Spellchecking" menu in emacs lists choices "Nederlands" and
"Nederlands8" but then an error is returned:
Error: The file "/usr/lib/aspell/nederlands" can not be opened for
reading.

$ rpm -ql aspell-nl
/usr/lib/aspell/dutch.alias
/usr/lib/aspell/nl.multi
/usr/lib/aspell/nl.rws
/usr/share/aspell/nl.dat

So actually, aspell should be called with a reference to "dutch", not
"nederlands" since that is what the file in the aspell distribution is
called (actually, as a workaround 'ln -s dutch.alias nederlands.alias
seems to work).

When investigating, similar problems showed up for french (emacs calls
for 'francais'), whereas English and German are ok.



Version-Release number of selected component (if applicable):
emacs-21.3-7 aspell-0.50.3-16

How reproducible:
Always

Steps to Reproduce:
1. start emacs
2. select from the menu "tools" the item "spell checking" and select
as language "Nederlands" (or "Francais")
3. go back to this same menu and selct "spell check buffer" or any of
the other entries which actually starts aspell
    

Actual Results:  Error: The file "/usr/lib/aspell/nederlands" can not
be opened for reading.

Expected Results:  spellchecking on the current file or buffer

Additional info:

Note: I tried the same in a fully updated Fedora Core 2 test 3, with
the same results.
Comment 1 David Jansen 2004-05-28 05:42:59 EDT
Bug is still present in Fedora Core 2

Version-Release number of selected component (if applicable):
emacs-21.3-12
aspell-0.50.3-19.1
Comment 2 Jens Petersen 2004-09-29 11:49:21 EDT
Thanks for the report and your patience.

Applying a patch for dutch, spanish and portuguese
in 21.3-15.  AFAICT current aspell-fr has francais.alias
so it should be ok I think.
Comment 3 Jens Petersen 2005-02-24 09:14:22 EST
*** Bug 147964 has been marked as a duplicate of this bug. ***
Comment 4 Ivana Varekova 2005-08-23 03:56:56 EDT
*** Bug 166286 has been marked as a duplicate of this bug. ***
Comment 5 Alexandre Oliva 2005-08-23 10:14:55 EDT
Spanish is broken in emacs-21.4-7, apparently because aspell changed it back
`spanish.alias', removing `castellano' (that emacs uses) as a valid alias :-(
Comment 6 Jens Petersen 2005-08-23 23:19:35 EDT
So just to be clear, this is a new issue with FC devel, ie FC4 is ok?

I'm still a little confused since I don't see any changes related to this.

I suggest to close this bug though and re-open the new one, unless the
original fix was wrong.
Comment 7 Alexandre Oliva 2005-08-24 00:46:28 EDT
I hadn't tried FC4, but now I have, and it's just as broken.  castellano.alias
does not exist, and spanish is what emacs should expect to find.

I'm closing this bug and reopening the new one.

Note You need to log in before you can comment on or make changes to this bug.