Bug 166286 - emacs expects castellano.alias
emacs expects castellano.alias
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: aspell-es (Show other bugs)
4
All Linux
medium Severity medium
: ---
: ---
Assigned To: Ivana Varekova
Ben Levenson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-08-18 15:11 EDT by Alexandre Oliva
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version: aspell-es-0.50-13
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-08-28 15:41:14 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Alexandre Oliva 2005-08-18 15:11:19 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.8b3) Gecko/20050815 Fedora/1.1-0.2.6.deerpark.alpha2 Firefox/1.0+

Description of problem:
If you switch to the spanish dictionary with ispell-change-dictionary, emacs complains it can't find castellano, as specified in the command-line arguments to be passed to the ispell wrapper in ispell-dictionary-alias.  It's not too hard to fix ispell-dictionary-alias such that ispell is started with -d spanish instead of -d castellano, but I think it would be much simpler to provide castellano.alias as a hard-link to spanish.alias, no?

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.Start emacs
2.M-x ispell-change-dictionary ENTER spanish ENTER
3.M-x ispell-buffer

Actual Results:  Error: The file "/usr/lib/aspell-0.60/castellano" cannot be opened for reading


Expected Results:  It would be nice if this worked

Additional info:
Comment 1 Ivana Varekova 2005-08-23 03:56:43 EDT
Which version-release of emacs and Fedora Core?
This should be already fixed in 21.3-15.

*** This bug has been marked as a duplicate of 122618 ***
Comment 2 Alexandre Oliva 2005-08-23 10:13:46 EDT
emacs-21.4-7, from the development tree.
Comment 3 Alexandre Oliva 2005-08-24 00:48:22 EDT
Jens prefers the new bug to be separate, so I'm reopening this.  I've just
verified that the problem is present in FC4 too, with emacs-21.4-5 and
aspell-es-0.50-11.
Comment 4 Ivana Varekova 2005-08-24 03:54:11 EDT
This should be emacs bug (duplicate of 147964).
Comment 5 Jens Petersen 2005-08-24 04:40:15 EDT
Oops - yes Ivana you're right.  Thanks.

*** This bug has been marked as a duplicate of 147964 ***
Comment 6 Alexandre Oliva 2005-08-24 11:22:32 EDT
While I do agree that it's possible to fix the problem in emacs, I don't see why
it has to be fixed there.  I think emacs has used castellano for Spanish for
quite a while, and others might have as well, so why not add castellano.alias to
aspell-es?  This was exactly the reason why I filed this against aspell-es, and
not emacs.  Changing emacs might just trade one error for another (if the
installed version of aspell-es doesn't provide spanish.alias, for example),
whereas making aspell-es more inclusive will get all uses to work.
Comment 7 Jens Petersen 2005-08-24 21:43:19 EDT
Ok, fair point.  We already have a aspell-es related patch
to ispell.el in our emacs package.  In my mind "fixing" both sides
is also ok.  However even cvs emacs is still using "castellano",
so it would be good to push the castellano alias upstream IMHO.
Comment 8 Ivana Varekova 2005-08-25 05:28:20 EDT
Thank you for your notices.
I added catallano alias to new aspell-es version (aspell-es-0.50-13). 
If there is any problem with this fix please reopen this bug.
 
Comment 9 Alexandre Oliva 2005-08-25 19:25:38 EDT
catallano?  It should have been castellano.  Cataluña and Castela are two
different parts of Spain, if memory serves, and they spoke different languages
back then.  Spanish is what used to be spoken in Castela; I've no idea of how
Catallan sounds like.
Comment 10 Ivana Varekova 2005-08-26 08:29:34 EDT
I added castellano alias, aspell-es-0.50-13 should be OK. In comment 8,
catallano is typo - thank you for your explanation.
Comment 11 Alexandre Oliva 2005-08-28 15:41:14 EDT
Thanks, confirmed fixed.

Note You need to log in before you can comment on or make changes to this bug.