Bug 147964 - emacs fails to open /usr/lib/aspell/castellano
Summary: emacs fails to open /usr/lib/aspell/castellano
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: emacs   
(Show other bugs)
Version: 3
Hardware: i686 Linux
medium
medium
Target Milestone: ---
Assignee: Jens Petersen
QA Contact: Ben Levenson
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-02-14 07:10 UTC by Luis Marqueta
Modified: 2007-11-30 22:11 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-11-22 01:47:36 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
patch which changes emacs spanish dict files (3.99 KB, patch)
2005-02-22 14:13 UTC, Ivana Varekova
no flags Details | Diff

Description Luis Marqueta 2005-02-14 07:10:49 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.5)
Gecko/20041111 Firefox/1.0

Description of problem:
emacs fails to open /usr/lib/aspell/castellano. Package
aspell-es-0.50-10.i386.rpm does not provide that file:

rpm -qpl aspell-es-0.50-10.i386.rpm
/usr/lib/aspell/es.multi
/usr/lib/aspell/es.rws
/usr/lib/aspell/espa�ol.alias
/usr/lib/aspell/esponol.alias
/usr/lib/aspell/spanish.alias
/usr/share/aspell/es.dat


Version-Release number of selected component (if applicable):
aspell-es-0.50-10.i386.rpm

How reproducible:
Always

Steps to Reproduce:
1. Open emacs
2. Tools -> Spell checking -> Select Spanish dict
3. Try to spell-check (M-$) and you get Error: The file
"/usr/lib/aspell/castellano" can not be opened for reading
    

Actual Results:  Error: The file "/usr/lib/aspell/castellano" can not
be opened for reading

Expected Results:  Spell schecked

Additional info:

Comment 1 Ivana Varekova 2005-02-22 14:13:13 UTC
Created attachment 111295 [details]
patch which changes emacs spanish dict files

Comment 2 Ivana Varekova 2005-02-22 14:16:57 UTC
Thank you for your notice.
I think this is emacs bug.
Emacs try to use castellano dictationary, but the spanish dictationary
name is "spanish".
I added patch which changes emacs dict files.

Ivana Varekova

Comment 3 Jens Petersen 2005-02-24 14:14:09 UTC
Which version-release of emacs and Fedora Core?

This was already fixed in 21.3-15.




*** This bug has been marked as a duplicate of 122618 ***

Comment 4 Jens Petersen 2005-08-24 08:40:22 UTC
*** Bug 166286 has been marked as a duplicate of this bug. ***

Comment 5 Jens Petersen 2005-08-24 09:08:46 UTC
Thanks - should get fixed in next build for rawhide.

Comment 6 Jens Petersen 2005-09-29 09:14:40 UTC
I committed the patch to package cvs.

But I see that spell-es-0.50-13 has castellano.alias now.
Should I revert?

Comment 7 Jens Petersen 2005-11-22 01:47:36 UTC
Leaving it at spanish.alias for now.


Note You need to log in before you can comment on or make changes to this bug.