Bug 1226233 - Mount broker user add command removes existing volume for a mountbroker user when second volume is attached to same user
Summary: Mount broker user add command removes existing volume for a mountbroker user ...
Keywords:
Status: CLOSED DUPLICATE of bug 1235428
Alias: None
Product: GlusterFS
Classification: Community
Component: geo-replication
Version: 3.7.0
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: ---
Assignee: Aravinda VK
QA Contact:
URL:
Whiteboard:
Depends On: 1226223 1234869 1235428
Blocks: glusterfs-3.7.3
TreeView+ depends on / blocked
 
Reported: 2015-05-29 09:27 UTC by Aravinda VK
Modified: 2015-06-25 06:03 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of: 1226223
Environment:
Last Closed: 2015-06-25 06:03:37 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)

Description Aravinda VK 2015-05-29 09:27:33 UTC
+++ This bug was initially created as a clone of Bug #1226223 +++

Description of problem:
Mount broker user add command(gluster system:: execute mountbroker user geoaccount slavevol) removes existing volume for a mountbroker user when second volume is attached to the same mount broker user.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.Add a volume to a mount broker user using the above mentioned command.
2.Add another volume to same mount broker user using command.
3.

Actual results:
The volume added first is removed from the volfile

Expected results:
The volume added second must be appended to the existing list of volumes for a mount broker user.

Additional info:

Comment 1 Niels de Vos 2015-06-02 08:20:23 UTC
The required changes to fix this bug have not made it into glusterfs-3.7.1. This bug is now getting tracked for glusterfs-3.7.2.

Comment 2 Niels de Vos 2015-06-20 10:08:50 UTC
Unfortunately glusterfs-3.7.2 did not contain a code change that was associated with this bug report. This bug is now proposed to be a blocker for glusterfs-3.7.3.

Comment 3 Darshan 2015-06-25 06:03:37 UTC

*** This bug has been marked as a duplicate of bug 1235428 ***


Note You need to log in before you can comment on or make changes to this bug.