Bug 1235428 - Mount broker user add command removes existing volume for a mountbroker user when second volume is attached to same user
Summary: Mount broker user add command removes existing volume for a mountbroker user ...
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: GlusterFS
Classification: Community
Component: geo-replication
Version: 3.7.0
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: ---
Assignee: Kotresh HR
QA Contact:
URL:
Whiteboard:
: 1226233 (view as bug list)
Depends On: 1226223
Blocks: 1226233 glusterfs-3.7.3 1234869
TreeView+ depends on / blocked
 
Reported: 2015-06-24 19:12 UTC by Kotresh HR
Modified: 2015-07-30 09:48 UTC (History)
5 users (show)

Fixed In Version: glusterfs-3.7.3
Doc Type: Bug Fix
Doc Text:
Clone Of: 1226223
Environment:
Last Closed: 2015-07-30 09:48:55 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)

Description Kotresh HR 2015-06-24 19:12:46 UTC
+++ This bug was initially created as a clone of Bug #1226223 +++

Description of problem:
Mount broker user add command(gluster system:: execute mountbroker user geoaccount slavevol) removes existing volume for a mountbroker user when second volume is attached to the same mount broker user.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.Add a volume to a mount broker user using the above mentioned command.
2.Add another volume to same mount broker user using command.
3.

Actual results:
The volume added first is removed from the volfile

Expected results:
The volume added second must be appended to the existing list of volumes for a mount broker user.

Additional info:

--- Additional comment from Anand Avati on 2015-06-24 14:59:10 EDT ---

REVIEW: http://review.gluster.org/11385 (geo-rep: Fix add user in mountbroker user management) posted (#1) for review on master by Kotresh HR (khiremat@redhat.com)

Comment 1 Anand Avati 2015-06-24 19:14:14 UTC
REVIEW: http://review.gluster.org/11386 (geo-rep: Fix add user in mountbroker user management) posted (#1) for review on release-3.7 by Kotresh HR (khiremat@redhat.com)

Comment 2 Darshan 2015-06-25 06:03:37 UTC
*** Bug 1226233 has been marked as a duplicate of this bug. ***

Comment 3 Anand Avati 2015-06-25 08:36:40 UTC
REVIEW: http://review.gluster.org/11386 (geo-rep: Fix add user in mountbroker user management) posted (#2) for review on release-3.7 by Kotresh HR (khiremat@redhat.com)

Comment 4 Kaushal 2015-07-30 09:48:55 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.7.3, please open a new bug report.

glusterfs-3.7.3 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://thread.gmane.org/gmane.comp.file-systems.gluster.devel/12078
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user


Note You need to log in before you can comment on or make changes to this bug.