Bug 12292 - Error unmounting hda1
Error unmounting hda1
Status: CLOSED DUPLICATE of bug 12106
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
7.1
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-06-15 03:40 EDT by Stephen Rasku
Modified: 2008-05-01 11:37 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-06-27 13:18:47 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Stephen Rasku 2000-06-15 03:40:47 EDT
I got the following error:

Error unmounting hda1:  Device or resource busy

It occured after I got the db3 Invalid argument message (bug 11884) and
after it notified me that I didn't have enough disk space to install the
selected packages.
Comment 1 Michael Fulbright 2000-06-15 11:28:04 EDT
Could you please give a script of how to reproduce this bug, accompanied by
the partition tables of your system.
Comment 2 Chris Evans 2000-06-26 17:44:42 EDT
I had this with BETA1
Verified it occurs with BETA2. It is IMHO a _very_ serious bug
To reproduce
1) Custom install
2) Pick "everything"
3) Pick "choose individual packages"
4) I attempted to install to a 1.5Gb /   (no other partitions)
5) It runs out of space, says I need a few hundred Mb more
6) Hit OK to "out of space" message
7) Message box appeared: "unable to unmount /dev/hdc2" /dev/hdc2 was /
8) Hit OK to error dialog
9) Hit BACK a few times and select a set of packages that fit in the space
10) Hit NEXT a few times to attempt re-install AND
11) Install dies _totally_ with "error mounting /dev/hdc2"
12) Ouch! Ouch!
NOTES
=====
- I'm not 100% sure, but I think it also goes wrong with a large / partition
and a /usr which was too small
Please mail me if it cannot be reproduced; the field will cane you guys if it
doesn't get fixed for 7.0 release ;-)
Comment 3 Brock Organ 2000-06-27 13:14:03 EDT

*** This bug has been marked as a duplicate of 12106 ***
Comment 4 Brock Organ 2000-06-27 13:18:46 EDT
this issue has been noted and marked as a duplicate of 12106 even though
circumstances are slightly different, since the base cause is the installer not
handling insufficient space reqs more gracefully ... thank you for your report !
Comment 5 Stephen Rasku 2000-07-12 23:45:24 EDT
This particular issue still happens in beta 3.  Not reopening since this is
already marked DUPLICATE.

Note You need to log in before you can comment on or make changes to this bug.