Bug 1230930 - Can't create external registries from API or CLI
Summary: Can't create external registries from API or CLI
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Container Management
Version: 6.1.0
Hardware: Unspecified
OS: Unspecified
unspecified
high vote
Target Milestone: Unspecified
Assignee: David Davis
QA Contact: Lukas Pramuk
URL:
Whiteboard:
Depends On:
Blocks: sat61-release-notes
TreeView+ depends on / blocked
 
Reported: 2015-06-11 19:26 UTC by Elyézer Rezende
Modified: 2019-04-01 20:26 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-07-27 09:16:02 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2016:1501 normal SHIPPED_LIVE Red Hat Satellite 6.2 Capsule and Server 2016-07-27 12:28:58 UTC

Description Elyézer Rezende 2015-06-11 19:26:49 UTC
Description of problem:
It is not available API or CLI for creating external registries


Version-Release number of selected component (if applicable):
S8C1

How reproducible:
Aways

Steps to Reproduce:
1. Check for API or CLI entry in the API docs or hammer docker help respectively
2.
3.

Actual results:
No API or CLI available for external registries

Expected results:
API and CLI should be available for external registries

Additional info:

Comment 2 David O'Brien 2015-06-16 04:32:36 UTC
Can I get some draft text for a release note for this? I'm not fluent with the use of docker, containers, and external registries, so prefer that someone close to the topic put something together first.

thanks a lot.

Comment 3 Elyézer Rezende 2015-06-18 13:13:02 UTC
Docker images are stored on servers called registries. Satellite 6 have the ability to inspect not only the official docker registry (registry.hub.docker.com) but to inspect custom registries (information about how to create a private custom registry can be found here https://access.redhat.com/articles/881893#private).

In the current state, the ability to add a custom registry is only available though the UI but not using hammer (CLI) or the API. With that said, user are recommended to use the UI to create an External Registry and point to an registry other than the official one. This is used when creating containers using the tab "External Registry" in order to search for a desired image and selecting a tag. This way the user can make Satellite pull the image from the custom registry and create the container.

Let me know if you need more information.

Comment 7 David Davis 2016-03-15 21:47:19 UTC
We need to pull in the newest hammer_cli_foreman_docker. Released 0.0.4 upstream and opened a pull request against foreman-packaging here:

https://github.com/theforeman/foreman-packaging/pull/1062

Comment 8 David Davis 2016-03-24 13:46:56 UTC
Unfortunately, this won't be testable until this bug is ON_QA:

https://bugzilla.redhat.com/show_bug.cgi?id=1320338

Comment 10 Lukas Pramuk 2016-04-06 11:43:28 UTC
Unfortunately, this is still not testable due to another bug:
https://bugzilla.redhat.com/show_bug.cgi?id=1230710

# hammer docker registry create --name docker.io --url https://registry-1.docker.io/
Could not create the registry:
  Unable to log in to this Docker Registry - Expected([200, 201, 202, 203, 204, 304]) <=> Actual(503 Service Unavailable)

(Same error as reported in #1230710)

Comment 11 Lukas Pramuk 2016-04-14 09:56:51 UTC
VERIFIED.

@Sat6.2.0-Beta-Snap8
tfm-rubygem-hammer_cli_foreman_docker-0.0.4-1.el7sat.noarch

# hammer docker registry create --name access.redhat.com --url https://registry.access.redhat.com
Docker registry created
# hammer docker registry list
---|-------------------|-----------------------------------
ID | NAME              | URL                               
---|-------------------|-----------------------------------
2  | access.redhat.com | https://registry.access.redhat.com
---|-------------------|-----------------------------------

...

>>> hammer docker registry {create,info,update,delete,list} commands are available and work as expected

>>> As hammer CLI relies on API calls, by testing hammer we also tested API

Comment 13 errata-xmlrpc 2016-07-27 09:16:02 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:1501


Note You need to log in before you can comment on or make changes to this bug.