Bug 123205 - strange cursor behavior in vi - edit-mode
strange cursor behavior in vi - edit-mode
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: vim (Show other bugs)
rawhide
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Karsten Hopp
David Lawrence
:
: 123891 124367 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-05-13 15:48 EDT by shrek-m
Modified: 2007-11-30 17:10 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-06-02 07:54:05 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description shrek-m 2004-05-13 15:48:19 EDT
Description of problem:
vi has a strange cursor-behaviour in edit-mode

$ vi test
[i] = edit-mode

cursors:
top => A
down => B
left => D
right => C
home, end, page up, page down => inverse upper<->lower case


Version-Release number of selected component (if applicable):
vim-minimal-6.2.457-1

How reproducible:
Always

Steps to Reproduce:
1. start "vi test" local
2. start "vi test" via ssh from a fc1-system
3. edit and try to navigate with the cursors

Actual Results:  strange cursor-behavior in edit-mode
i am not able to edit a simple config-file in the usual speed

Expected Results:  vi should have the same behaviour as in rhl 6.x - fc1

Additional info:

clean fresh install fc2t3

# cat /etc/sysconfig/i18n
LANG="de_DE.UTF-8"
SUPPORTED="de_DE.UTF-8:de_DE:de"
SYSFONT="latarcyrheb-sun16"
Comment 1 Karsten Hopp 2004-05-21 09:26:34 EDT
*** Bug 123891 has been marked as a duplicate of this bug. ***
Comment 2 Robert Scheck 2004-05-21 10:57:21 EDT
The problem is caused by the missing /etc/vimrc in vim-minimal.
/etc/vimrc at current is only provided with vim-common...Karsten, 
what was such hard to trigger out that? ;-)

The solution I personally prefer is, to break out a -config package.
A diff from my solution is below:

--- vim.spec       2004-04-09 13:10:24.000000000 +0200
+++ vim.spec.rsc   2004-05-21 16:37:19.000000000 +0200
@@ -555,6 +555,7 @@
 %package minimal
 Summary: A minimal version of the VIM editor.
 Group: Applications/Editors
+Requires: vim-config
 Obsoletes:  vim

 %description minimal
@@ -570,7 +571,7 @@
 %package enhanced
 Summary: A version of the VIM editor which includes recent enhancements.
 Group: Applications/Editors
-Requires: vim-common
+Requires: vim-common, vim-config
 Requires:  %(perl -le 'use Config;print $Config{archlibexp}')
 Obsoletes: vim-color

@@ -587,6 +588,14 @@
 interpreters for the Python and Perl scripting languages.  You'll also
 need to install the vim-common package.

+%package config
+Summary: The config file for the the VIM editor.
+Group: Applications/Editors
+
+%description config
+This package contains the config file for the minimal and the enhanced
+variant of VIM (VIsual editor iMproved).
+
 %if "%{withgui}" == "1"
 %package X11
 Summary: The VIM version of the vi editor for the X Window System.
@@ -1247,7 +1256,6 @@

 %files common
 %defattr(-,root,root)
-%config(noreplace) /etc/vimrc
 %doc README*
 %doc runtime/docs
 /usr/share/vim
@@ -1294,6 +1302,10 @@
 %{_mandir}/man1/vimdiff.*
 %{_mandir}/man1/vimtutor.*

+%files config
+%defattr(-,root,root)
+%config(noreplace) /etc/vimrc
+
 %if "%{withgui}" == "1"
 %files X11
 %defattr(-,root,root)
Comment 3 Karsten Hopp 2004-05-22 09:38:10 EDT
no, a simple strace would have revealed the problem. I'm just too 
busy at the moment with other things to spend time on such minor 
bugs. I'll fix this one during the next round of package updates, 
although I don't think that I'll add a -config package. Maybe I'll 
just patch the /bin/vi defaults, but I'm not sure yet. 
Comment 4 Karsten Hopp 2004-05-26 05:22:27 EDT
*** Bug 124367 has been marked as a duplicate of this bug. ***
Comment 5 Karsten Hopp 2004-06-02 07:54:05 EDT
fixed in the development tree 

Note You need to log in before you can comment on or make changes to this bug.