Bug 1232673 - X crashes when starting LibreOffice Writer
Summary: X crashes when starting LibreOffice Writer
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-ati
Version: 22
Hardware: x86_64
OS: Linux
unspecified
high
Target Milestone: ---
Assignee: X/OpenGL Maintenance List
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-06-17 09:34 UTC by Tarjei Knapstad
Modified: 2015-07-31 07:55 UTC (History)
5 users (show)

Fixed In Version: xorg-x11-server-1.17.2-2.fc22
Doc Type: Bug Fix
Doc Text:
Clone Of:
: 1248850 (view as bug list)
Environment:
Last Closed: 2015-07-31 07:55:14 UTC
Type: Bug


Attachments (Terms of Use)
X.org log with backtrace of crash (71.39 KB, text/plain)
2015-06-17 09:34 UTC, Tarjei Knapstad
no flags Details

Description Tarjei Knapstad 2015-06-17 09:34:51 UTC
Created attachment 1039842 [details]
X.org log with backtrace of crash

Description of problem:
I'm seeing severe stability issues when attempting to use LibreOffice Writer. When starting writer, X crashes and returns med to the login screen. This has also occured when starting Xemacs. From the stacktrace this looks like a nullpointer exception occuring in OsLookupColor, see attached files.

I've also tried with LibreOffice 4.3 using the official RPM's. With this version I can start Writer and edit documents, but X still crashes the moment I click the "View" menu item (the others seem to work). 

The same issue seems to occur randomly if I attempt to resize an XEmacs window.

Version-Release number of selected component (if applicable):
xorg-x11-server-Xorg-1.17.1-14.fc22.x86_64


How reproducible:
Always

Steps to Reproduce:
1. Login with GNOME or MATE desktop environment
2. Start LibreOffice Writer

Actual results:
X crashes and returns me to the login screen.

Expected results:
Normal startup of program.

Additional info:
$ lspci |grep VGA
03:00.0 VGA compatible controller: Advanced Micro Devices, Inc. [AMD/ATI] Vesuvius [Radeon R9 295X2]

Comment 1 Tarjei Knapstad 2015-06-17 10:43:27 UTC
After downgrading X11 from 1.17 to the F21 1.16 packages, everything seems stable again, so this bug was introduced in 1.17 (possibly an incompatability with the ATI driver?)

Packages Altered:
    Downgrade  xorg-x11-drv-ati-7.5.0-1.fc21.x86_64                        @fedora21
    Downgraded                  7.5.0-3.fc22.x86_64                        (unknown)
    Downgrade  xorg-x11-drv-fbdev-0.4.3-19.fc21.x86_64                     @fedora21
    Downgraded                    0.4.3-20.fc22.x86_64                     (unknown)
    Downgrade  xorg-x11-drv-intel-2.99.916-4.20141117.fc21.x86_64          @updates21
    Downgraded                    2.99.917-11.20150603.fc22.x86_64         @updates
    Downgrade  xorg-x11-drv-libinput-0.9.0-1.fc22.x86_64                   @fedora
    Downgraded                       0.11.0-1.fc22.x86_64                  @updates-testing
    Downgrade  xorg-x11-drv-nouveau-1:1.0.11-1.fc21.x86_64                 @fedora21
    Downgraded                      1:1.0.11-2.fc22.x86_64                 (unknown)
    Downgrade  xorg-x11-drv-openchrome-0.3.3-12.fc21.x86_64                @fedora21
    Downgraded                         0.3.3-14.fc22.x86_64                (unknown)
    Downgrade  xorg-x11-drv-qxl-0.1.2-1.fc21.x86_64                        @fedora21
    Downgraded                  0.1.3-2.fc22.x86_64                        (unknown)
    Downgrade  xorg-x11-drv-vesa-2.3.2-19.fc21.x86_64                      @fedora21
    Downgraded                   2.3.2-20.fc22.x86_64                      (unknown)
    Downgrade  xorg-x11-drv-vmware-13.0.2-8.20150211git8f0cf7c.fc21.x86_64 @updates21
    Downgraded                     13.0.2-8.20150211git8f0cf7c.fc22.x86_64 (unknown)
    Downgrade  xorg-x11-server-Xorg-1.16.3-2.fc21.x86_64                   @updates21
    Downgraded                      1.17.1-14.fc22.x86_64                  (unknown)
    Downgrade  xorg-x11-server-Xwayland-1.16.3-2.fc21.x86_64               @updates21
    Downgraded                          1.17.1-14.fc22.x86_64              (unknown)
    Downgrade  xorg-x11-server-common-1.16.3-2.fc21.x86_64                 @updates21
    Downgraded                        1.17.1-14.fc22.x86_64                (unknown)

Comment 2 Sam 2015-07-03 15:20:18 UTC
I can confirm this, as I was having the same issue. I am also running gnome, have an AMD card (R9 290x), and every time I tried to open a file with Libreoffice X would crash. I had the same result trying to use OpenOffice. Are there any updates on this or is the only solution to downgrade?

Comment 3 Sam 2015-07-06 22:04:28 UTC
I downgraded all of the packages listed by OP to the packages listed in the post, and I can confirm that fixed the problem and LibreOffice is working just fine now.

Comment 4 Hendrik Borghorst 2015-07-17 15:18:39 UTC
The bugfix from upstream bugreport fixes the issue for my Radeon 280x.

https://bugs.freedesktop.org/show_bug.cgi?id=90667 (Comment 27)

Comment 5 Sam 2015-07-26 23:23:43 UTC
Any chance you could provide instructions on how to apply this patch?

Comment 6 Dave Airlie 2015-07-27 00:48:49 UTC
it should be in the xorg-x11-server-Xorg packages in updates-testing already.

Comment 7 Fedora Update System 2015-07-27 01:00:19 UTC
xorg-x11-server-1.17.2-2.fc22 has been submitted as an update for Fedora 22.
https://admin.fedoraproject.org/updates/xorg-x11-server-1.17.2-2.fc22

Comment 8 Tarjei Knapstad 2015-07-27 07:29:37 UTC
Confirmed working with the 1.17.2-2 packages (thanks Dave!)

Comment 9 Luya Tshimbalanga 2015-07-27 16:53:13 UTC
Very similar to the bug 1210931 although LibreOffice worked with version 4.4.3.x

Comment 10 Fedora Update System 2015-07-30 01:14:19 UTC
Package xorg-x11-server-1.17.2-2.fc22:
* should fix your issue,
* was pushed to the Fedora 22 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing xorg-x11-server-1.17.2-2.fc22'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2015-12282/xorg-x11-server-1.17.2-2.fc22
then log in and leave karma (feedback).

Comment 11 Fedora Update System 2015-07-31 07:55:14 UTC
xorg-x11-server-1.17.2-2.fc22 has been pushed to the Fedora 22 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.