Bug 1248850 - X crashes when starting LibreOffice Writer
X crashes when starting LibreOffice Writer
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: xorg-x11-server (Show other bugs)
7.2
x86_64 Linux
unspecified Severity high
: rc
: ---
Assigned To: Adam Jackson
Desktop QE
: Patch, Regression
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-07-30 21:33 EDT by Dave Airlie
Modified: 2015-11-18 23:27 EST (History)
1 user (show)

See Also:
Fixed In Version: xorg-x11-server-1.17.2-6.el7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 1232673
Environment:
Last Closed: 2015-11-18 23:27:39 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
glamor fix (1.06 KB, patch)
2015-07-30 21:48 EDT, Dave Airlie
no flags Details | Diff

  None (edit)
Description Dave Airlie 2015-07-30 21:33:36 EDT
This bug is present in glamor on RHEL7.2, the fix should be included there.

+++ This bug was initially created as a clone of Bug #1232673 +++

Description of problem:
I'm seeing severe stability issues when attempting to use LibreOffice Writer. When starting writer, X crashes and returns med to the login screen. This has also occured when starting Xemacs. From the stacktrace this looks like a nullpointer exception occuring in OsLookupColor, see attached files.

I've also tried with LibreOffice 4.3 using the official RPM's. With this version I can start Writer and edit documents, but X still crashes the moment I click the "View" menu item (the others seem to work). 

The same issue seems to occur randomly if I attempt to resize an XEmacs window.

Version-Release number of selected component (if applicable):
xorg-x11-server-Xorg-1.17.1-14.fc22.x86_64


How reproducible:
Always

Steps to Reproduce:
1. Login with GNOME or MATE desktop environment
2. Start LibreOffice Writer

Actual results:
X crashes and returns me to the login screen.

Expected results:
Normal startup of program.

Additional info:
$ lspci |grep VGA
03:00.0 VGA compatible controller: Advanced Micro Devices, Inc. [AMD/ATI] Vesuvius [Radeon R9 295X2]

--- Additional comment from Tarjei Knapstad on 2015-06-17 06:43:27 EDT ---

After downgrading X11 from 1.17 to the F21 1.16 packages, everything seems stable again, so this bug was introduced in 1.17 (possibly an incompatability with the ATI driver?)

Packages Altered:
    Downgrade  xorg-x11-drv-ati-7.5.0-1.fc21.x86_64                        @fedora21
    Downgraded                  7.5.0-3.fc22.x86_64                        (unknown)
    Downgrade  xorg-x11-drv-fbdev-0.4.3-19.fc21.x86_64                     @fedora21
    Downgraded                    0.4.3-20.fc22.x86_64                     (unknown)
    Downgrade  xorg-x11-drv-intel-2.99.916-4.20141117.fc21.x86_64          @updates21
    Downgraded                    2.99.917-11.20150603.fc22.x86_64         @updates
    Downgrade  xorg-x11-drv-libinput-0.9.0-1.fc22.x86_64                   @fedora
    Downgraded                       0.11.0-1.fc22.x86_64                  @updates-testing
    Downgrade  xorg-x11-drv-nouveau-1:1.0.11-1.fc21.x86_64                 @fedora21
    Downgraded                      1:1.0.11-2.fc22.x86_64                 (unknown)
    Downgrade  xorg-x11-drv-openchrome-0.3.3-12.fc21.x86_64                @fedora21
    Downgraded                         0.3.3-14.fc22.x86_64                (unknown)
    Downgrade  xorg-x11-drv-qxl-0.1.2-1.fc21.x86_64                        @fedora21
    Downgraded                  0.1.3-2.fc22.x86_64                        (unknown)
    Downgrade  xorg-x11-drv-vesa-2.3.2-19.fc21.x86_64                      @fedora21
    Downgraded                   2.3.2-20.fc22.x86_64                      (unknown)
    Downgrade  xorg-x11-drv-vmware-13.0.2-8.20150211git8f0cf7c.fc21.x86_64 @updates21
    Downgraded                     13.0.2-8.20150211git8f0cf7c.fc22.x86_64 (unknown)
    Downgrade  xorg-x11-server-Xorg-1.16.3-2.fc21.x86_64                   @updates21
    Downgraded                      1.17.1-14.fc22.x86_64                  (unknown)
    Downgrade  xorg-x11-server-Xwayland-1.16.3-2.fc21.x86_64               @updates21
    Downgraded                          1.17.1-14.fc22.x86_64              (unknown)
    Downgrade  xorg-x11-server-common-1.16.3-2.fc21.x86_64                 @updates21
    Downgraded                        1.17.1-14.fc22.x86_64                (unknown)

--- Additional comment from Sam on 2015-07-03 11:20:18 EDT ---

I can confirm this, as I was having the same issue. I am also running gnome, have an AMD card (R9 290x), and every time I tried to open a file with Libreoffice X would crash. I had the same result trying to use OpenOffice. Are there any updates on this or is the only solution to downgrade?

--- Additional comment from Sam on 2015-07-06 18:04:28 EDT ---

I downgraded all of the packages listed by OP to the packages listed in the post, and I can confirm that fixed the problem and LibreOffice is working just fine now.

--- Additional comment from Hendrik Borghorst on 2015-07-17 11:18:39 EDT ---

The bugfix from upstream bugreport fixes the issue for my Radeon 280x.

https://bugs.freedesktop.org/show_bug.cgi?id=90667 (Comment 27)

--- Additional comment from Sam on 2015-07-26 19:23:43 EDT ---

Any chance you could provide instructions on how to apply this patch?

--- Additional comment from Dave Airlie on 2015-07-26 20:48:49 EDT ---

it should be in the xorg-x11-server-Xorg packages in updates-testing already.

--- Additional comment from Fedora Update System on 2015-07-26 21:00:19 EDT ---

xorg-x11-server-1.17.2-2.fc22 has been submitted as an update for Fedora 22.
https://admin.fedoraproject.org/updates/xorg-x11-server-1.17.2-2.fc22

--- Additional comment from Tarjei Knapstad on 2015-07-27 03:29:37 EDT ---

Confirmed working with the 1.17.2-2 packages (thanks Dave!)

--- Additional comment from Luya Tshimbalanga on 2015-07-27 12:53:13 EDT ---

Very similar to the bug 1210931 although LibreOffice worked with version 4.4.3.x

--- Additional comment from Fedora Update System on 2015-07-29 21:14:19 EDT ---

Package xorg-x11-server-1.17.2-2.fc22:
* should fix your issue,
* was pushed to the Fedora 22 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing xorg-x11-server-1.17.2-2.fc22'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2015-12282/xorg-x11-server-1.17.2-2.fc22
then log in and leave karma (feedback).
Comment 1 Dave Airlie 2015-07-30 21:48:26 EDT
Created attachment 1057895 [details]
glamor fix
Comment 6 errata-xmlrpc 2015-11-18 23:27:39 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHEA-2015-2198.html

Note You need to log in before you can comment on or make changes to this bug.