Bug 1233106 - [RFE] Remove all kernel, firmware, and .py file blacklisting
Summary: [RFE] Remove all kernel, firmware, and .py file blacklisting
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-node
Version: 3.6.0
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: ovirt-3.6.0-rc
: 3.6.0
Assignee: Fabian Deutsch
QA Contact: cshao
URL:
Whiteboard:
Depends On: 1276260
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-06-18 08:55 UTC by Fabian Deutsch
Modified: 2016-03-09 14:31 UTC (History)
7 users (show)

Fixed In Version: ovirt-node-3.3.0-0.4.20150906git14a6024.el7ev
Doc Type: Enhancement
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-03-09 14:31:33 UTC
oVirt Team: Node


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2016:0378 normal SHIPPED_LIVE ovirt-node bug fix and enhancement update for RHEV 3.6 2016-03-09 19:06:36 UTC
oVirt gerrit 42532 master MERGED recipe: Drop kernel blacklisting Never
oVirt gerrit 42533 master MERGED recipe: Drop augeas blacklisting Never
oVirt gerrit 46310 master MERGED recipe: Drop some pyc specific logic Never
oVirt gerrit 46313 master MERGED recipe: Drop some virt-who / pyc related changes Never
oVirt gerrit 46314 master MERGED hooks: Run .py file Never
oVirt gerrit 46323 ovirt-3.6 MERGED recipe: Drop some pyc specific logic Never
oVirt gerrit 46325 ovirt-3.6 MERGED recipe: Drop some virt-who / pyc related changes Never
oVirt gerrit 46326 ovirt-3.6 MERGED hooks: Run .py file Never
oVirt gerrit 48007 master MERGED utils: Fix missing namespace Never
oVirt gerrit 48026 ovirt-3.6 MERGED utils: Fix missing namespace Never

Description Fabian Deutsch 2015-06-18 08:55:11 UTC
Description of problem:
Currently parts of the kernel are dropped to save space.
Wioth RHEV-H 7 more space is available and we can drop the blacklisting for kernel related stuff.

We could also consider to - after investigation - to drop the blacklisting in total.

Comment 2 Yaniv Lavi 2015-06-18 10:26:30 UTC
(In reply to Fabian Deutsch from comment #0)
> Description of problem:
> Currently parts of the kernel are dropped to save space.
> Wioth RHEV-H 7 more space is available and we can drop the blacklisting for
> kernel related stuff.
> 
> We could also consider to - after investigation - to drop the blacklisting
> in total.

Please consider removing all blacklisting. I believe this is the best option.

Comment 3 Ying Cui 2015-06-18 11:54:24 UTC
Before qa_ack+, I want to know how QE check more space available in rhevh 7 and how do we verify this bug? Thanks.

Comment 4 Fabian Deutsch 2015-06-19 07:02:16 UTC
To check the available space:
1. Drop to shell
2. Check the size of the partitions of the installation disk using parted

After 2:
The size of the partitions 2 and 3 should be 4300MB


To verify this bug, on the terminal, run:
$ dracut -f
That will generate a new initramfs and needs to read all kernel modules, and should show no errors related to missing files.

Comment 5 Ying Cui 2015-06-19 07:29:47 UTC
(In reply to Fabian Deutsch from comment #4)
> To check the available space:
> 1. Drop to shell
> 2. Check the size of the partitions of the installation disk using parted
> 
> After 2:
> The size of the partitions 2 and 3 should be 4300MB
> 
> 
> To verify this bug, on the terminal, run:
> $ dracut -f
> That will generate a new initramfs and needs to read all kernel modules, and
> should show no errors related to missing files.

Thanks!
qa_ack+ and we will cover install and upgrade for this bug verification.

Comment 6 cshao 2015-10-29 09:41:22 UTC
The bug is blocked by bug 1276260, I will verify this bug after 1276260 fixed.

Comment 7 cshao 2015-11-03 08:42:06 UTC
According bug 1276260 #c 1, On 3.6 $ ovirt-node-rebuild-initramfs  can be used to rebuild the initramfs. but actually we still got below error info:

# ovirt-node-rebuild-initramfs
ERROR - Initramfs regeneration failed
Traceback (most recent call last):
  File "/sbin/ovirt-node-rebuild-initramfs", line 34, in <module>
    kver = check_output(["uname", "-r"])
NameError: name 'check_output' is not defined


Test version:
rhev-hypervisor7-7.2-20151025.0.el7ev
ovirt-node-3.3.0-0.18.20151022git82dc52c.el7ev.noarch
dracut-033-359.el7.x86_64

Hi fabian,

ovirt-node-rebuild-initramfs doesn't work on 3.6. can I report a new bug to trace then new issue or reopen the old one?

Comment 8 Fabian Deutsch 2015-11-03 11:39:20 UTC
We'll use this bug to fix the bug in comment 7

Comment 9 Ying Cui 2015-11-09 12:46:00 UTC
according to comment 8, reassigned this bug.

Comment 10 cshao 2015-11-23 09:09:18 UTC
Test version:
rhev-hypervisor7-7.2-20151112.1
ovirt-node-3.6.0-0.20.20151103git3d3779a.el7ev.noarch


# ovirt-node-rebuild-initramfs
INFO - Preparing to regenerate the initramfs
INFO - The regenreation will overwrite the existing
INFO - Rebuilding for kver: 3.10.0-327.el7.x86_64
INFO - Mounting '/liveos' to /boot
ERROR - Initramfs regeneration failed
Traceback (most recent call last):
  File "/sbin/ovirt-node-rebuild-initramfs", line 35, in <module>
    initramfs.rebuild(kver)
  File "/usr/lib/python2.7/site-packages/ovirt/node/utils/system.py", line 1403, in rebuild
    with mounted_boot(source=self.boot_source):
  File "/usr/lib64/python2.7/contextlib.py", line 17, in __enter__
    return self.gen.next()
  File "/usr/lib/python2.7/site-packages/ovirt/node/utils/system.py", line 374, in mounted_boot
    raise RuntimeError("Failed to mount /liveos")
RuntimeError: Failed to mount /liveos

# cat /etc/redhat-release 
Red Hat Enterprise Virtualization Hypervisor (Beta) release 7.2 (20151112.1.el7ev)


I have to assigned this bug due to ovirt-node-rebuild-initramfs still doesn't work on latest 3.6.

Comment 11 Fabian Deutsch 2015-11-23 09:46:13 UTC
Please create a separate bug for comment 10.

To verify this bug, please ensure that .py files are present, and that depmod -a does not lead to a problem.

Comment 12 cshao 2015-11-26 03:17:18 UTC
Hi fabian,

I have to assigned this bug due to below error.

Test version:
rhev-hypervisor7-7.2-20151112.1
ovirt-node-3.6.0-0.20.20151103git3d3779a.el7ev.noarch


# depmod -a
depmod: ERROR: openat(/lib/modules/3.10.0-327.el7.x86_64, modules.dep.tmp, 1101, 644): Read-only file system
depmod: ERROR: openat(/lib/modules/3.10.0-327.el7.x86_64, modules.dep.bin.tmp, 1101, 644): Read-only file system
depmod: ERROR: openat(/lib/modules/3.10.0-327.el7.x86_64, modules.alias.tmp, 1101, 644): Read-only file system
depmod: ERROR: openat(/lib/modules/3.10.0-327.el7.x86_64, modules.alias.bin.tmp, 1101, 644): Read-only file system
depmod: ERROR: openat(/lib/modules/3.10.0-327.el7.x86_64, modules.softdep.tmp, 1101, 644): Read-only file system
depmod: ERROR: openat(/lib/modules/3.10.0-327.el7.x86_64, modules.symbols.tmp, 1101, 644): Read-only file system
depmod: ERROR: openat(/lib/modules/3.10.0-327.el7.x86_64, modules.symbols.bin.tmp, 1101, 644): Read-only file system
depmod: ERROR: openat(/lib/modules/3.10.0-327.el7.x86_64, modules.builtin.bin.tmp, 1101, 644): Read-only file system
depmod: ERROR: openat(/lib/modules/3.10.0-327.el7.x86_64, modules.devname.tmp, 1101, 644): Read-only file system

# ls -al /lib/modules/3.10.0-327.el7.x86_64/
total 2852
drwxr-xr-x.  7 root root   4096 Nov 12 22:49 .
drwxr-xr-x.  3 root root   4096 Nov 12 22:53 ..
lrwxrwxrwx.  1 root root     38 Nov 12 22:47 build -> /usr/src/kernels/3.10.0-327.el7.x86_64
drwxr-xr-x.  2 root root   4096 Oct 29 21:35 extra
drwxr-xr-x. 11 root root   4096 Nov 12 22:47 kernel
-rw-r--r--.  1 root root 705037 Nov 12 22:49 modules.alias
-rw-r--r--.  1 root root 681768 Nov 12 22:49 modules.alias.bin
-rw-r--r--.  1 root root   1288 Oct 29 21:35 modules.block
-rw-r--r--.  1 root root   5995 Oct 29 21:32 modules.builtin
-rw-r--r--.  1 root root   7744 Nov 12 22:49 modules.builtin.bin
-rw-r--r--.  1 root root 218218 Nov 12 22:49 modules.dep
-rw-r--r--.  1 root root 316220 Nov 12 22:49 modules.dep.bin
-rw-r--r--.  1 root root    339 Nov 12 22:49 modules.devname
-rw-r--r--.  1 root root    108 Oct 29 21:35 modules.drm
-rw-r--r--.  1 root root    100 Oct 29 21:35 modules.modesetting
-rw-r--r--.  1 root root   1522 Oct 29 21:35 modules.networking
-rw-r--r--.  1 root root  84666 Oct 29 21:32 modules.order
-rw-r--r--.  1 root root     89 Nov 12 22:49 modules.softdep
-rw-r--r--.  1 root root 311845 Nov 12 22:49 modules.symbols
-rw-r--r--.  1 root root 387028 Nov 12 22:49 modules.symbols.bin
lrwxrwxrwx.  1 root root      5 Nov 12 22:47 source -> build
drwxr-xr-x.  2 root root   4096 Oct 29 21:35 updates
drwxr-xr-x.  2 root root   4096 Nov 12 22:47 vdso
drwxr-xr-x.  2 root root   4096 Oct 29 21:35 weak-updates



To completely verify this bug, please help to ack the following steps. 

Test machines coverage:
1. singlepath FC and iSCSI
2. multipath FC and iSCSI
3. localdisk

Test coverage:
1. clean TUI isntall
2. dirty TUI install
3. upgrade via TUI
4. upgrade via cmd
5. upgrade via rhevm

Check points
1. The initrd0.img is rebuild from 3.6, #ls -al /run/initramfs/live/initrd0.img, can check the time update. vs. the initrd0.img in rhevh.iso

2. lsinitrd /run/initramfs/live/initrd0.img -- no error output.

3. check and attach the output for  #tree /lib/modules/ according to https://gerrit.ovirt.org/#/c/42532/2/recipe/common-minimizer.ks

4. ovirt-node-rebuild-initramfs is present, execute, then -- no error output as comment in bug 1276260.

5. depmod -a  -- no error output.

Thanks!

Comment 13 cshao 2015-11-26 03:38:50 UTC
(In reply to Fabian Deutsch from comment #11)
> Please create a separate bug for comment 10.
> 

Bug 1285607 - Initramfs regeneration failed during run command "ovirt-node-rebuild-initramfs" can trace the new issue.

Comment 14 Fabian Deutsch 2015-11-26 09:02:06 UTC
(In reply to shaochen from comment #12)
> Hi fabian,
> 
> I have to assigned this bug due to below error.
> 
> Test version:
> rhev-hypervisor7-7.2-20151112.1
> ovirt-node-3.6.0-0.20.20151103git3d3779a.el7ev.noarch
> 
> 
> # depmod -a
> depmod: ERROR: openat(/lib/modules/3.10.0-327.el7.x86_64, modules.dep.tmp,
> 1101, 644): Read-only file system

Okay, the problem is because / is ro.

Because to us it is only important if all dependencies of all kmods are met, it is okay to remount / rw.
If then depmod -a completes without errors, then we are sure that all necessary kernel modules are present.

So please verify this bug with:

1. mount -oremount,rw /
2. depmod -a

(Dropping FailedQA because the failure was not because of a problem with the kmods, but because of a ro /)

> To completely verify this bug, please help to ack the following steps. 
> 
> Test machines coverage:
> 1. singlepath FC and iSCSI
> 2. multipath FC and iSCSI
> 3. localdisk
> 
> Test coverage:
> 1. clean TUI isntall
> 2. dirty TUI install
> 3. upgrade via TUI
> 4. upgrade via cmd
> 5. upgrade via rhevm
> 
> Check points
> 1. The initrd0.img is rebuild from 3.6, #ls -al
> /run/initramfs/live/initrd0.img, can check the time update. vs. the
> initrd0.img in rhevh.iso
> 
> 2. lsinitrd /run/initramfs/live/initrd0.img -- no error output.
> 
> 3. check and attach the output for  #tree /lib/modules/ according to
> https://gerrit.ovirt.org/#/c/42532/2/recipe/common-minimizer.ks
> 
> 4. ovirt-node-rebuild-initramfs is present, execute, then -- no error output
> as comment in bug 1276260.

Don't use 4. for verification of this bug, because 4. (ovirt-node-rebuild-initramfs) is not only depending on the kernel modules.

> 5. depmod -a  -- no error output.

The verification steps are very good!

Comment 15 cshao 2015-11-26 09:15:43 UTC
(In reply to Fabian Deutsch from comment #14)
> (In reply to shaochen from comment #12)
> > Hi fabian,
> > 
> > I have to assigned this bug due to below error.
> > 
> > Test version:
> > rhev-hypervisor7-7.2-20151112.1
> > ovirt-node-3.6.0-0.20.20151103git3d3779a.el7ev.noarch
> > 
> > 
> > # depmod -a
> > depmod: ERROR: openat(/lib/modules/3.10.0-327.el7.x86_64, modules.dep.tmp,
> > 1101, 644): Read-only file system
> 
> Okay, the problem is because / is ro.
> 
> Because to us it is only important if all dependencies of all kmods are met,
> it is okay to remount / rw.
> If then depmod -a completes without errors, then we are sure that all
> necessary kernel modules are present.
> 
> So please verify this bug with:
> 
> 1. mount -oremount,rw /
> 2. depmod -a


# mount -o remount,rw /
# depmod -a
# 

After run "mount -o remount,rw /", depmod: ERROR was gone.

I will try to used above check points to verify the bug on different kinds of machines.

Comment 16 cshao 2015-11-30 07:52:21 UTC
Test version:
rhev-hypervisor7-7.2-20151112.1
ovirt-node-3.6.0-0.20.20151103git3d3779a.el7ev.noarch

Test machines coverage:
1. singlepath FC and iSCSI
2. multipath FC and iSCSI
3. localdisk

Test coverage:
1. clean TUI isntall
2. dirty TUI install
3. upgrade via TUI
4. upgrade via cmd
5. upgrade via rhevm

Test scenario 1:
Singlepath iscsi + clean TUi install

Test steps:
1. The initrd0.img is rebuild from 3.6, #ls -al /run/initramfs/live/initrd0.img, can check the time update. vs. the initrd0.img in rhevh.iso

2. lsinitrd /run/initramfs/live/initrd0.img -- no error output.

3. check and attach the output for  #tree /lib/modules/ according to https://gerrit.ovirt.org/#/c/42532/2/recipe/common-minimizer.ks

4. mount -oremount,rw /
depmod -a  -- no error output.



Test scenario 2:
singlepath FC + dirty TUI install

Test steps:
1. The initrd0.img is rebuild from 3.6, #ls -al /run/initramfs/live/initrd0.img, can check the time update. vs. the initrd0.img in rhevh.iso

2. lsinitrd /run/initramfs/live/initrd0.img -- no error output.

3. check and attach the output for  #tree /lib/modules/ according to https://gerrit.ovirt.org/#/c/42532/2/recipe/common-minimizer.ks

4. mount -oremount,rw /
depmod -a  -- no error output.



Test scenario 3:
multipath iscsi(z600-03) + upgrade via TUI
Test steps:
1. The initrd0.img is rebuild from 3.6, #ls -al /run/initramfs/live/initrd0.img, can check the time update. vs. the initrd0.img in rhevh.iso

2. lsinitrd /run/initramfs/live/initrd0.img -- no error output.

3. check and attach the output for  #tree /lib/modules/ according to https://gerrit.ovirt.org/#/c/42532/2/recipe/common-minimizer.ks

4. mount -oremount,rw /
depmod -a  -- no error output.


Test scenario 4:
multipath FC + upgrade via cmd (dell-per510-01)
1. The initrd0.img is rebuild from 3.6, #ls -al /run/initramfs/live/initrd0.img, can check the time update. vs. the initrd0.img in rhevh.iso

2. lsinitrd /run/initramfs/live/initrd0.img -- no error output.

3. check and attach the output for  #tree /lib/modules/ according to https://gerrit.ovirt.org/#/c/42532/2/recipe/common-minimizer.ks

4. mount -oremount,rw /
depmod -a  -- no error output.


Test scenario 5:
localdisk + upgrade via rhevm

1. The initrd0.img is rebuild from 3.6, #ls -al /run/initramfs/live/initrd0.img, can check the time update. vs. the initrd0.img in rhevh.iso

2. lsinitrd /run/initramfs/live/initrd0.img -- no error output.

3. check and attach the output for  #tree /lib/modules/ according to https://gerrit.ovirt.org/#/c/42532/2/recipe/common-minimizer.ks

4. mount -oremount,rw /
depmod -a  -- no error output.

So the bug is fixed, change bug stauts to VERIFIED.

Comment 17 cshao 2015-12-02 09:18:34 UTC
Hi fabiand,

 I noticed that this is a error output after run "lsinitrd /run/initramfs/live/initrd0.img"

Does it have effect on this bug? Do we need care this error? 

# lsinitrd /run/initramfs/live/initrd0.img 
Image: /run/initramfs/live/initrd0.img: 46M
========================================================================
cat: write error: Broken pipe
Version: dracut-033-359.el7

Thanks!

Comment 18 Fabian Deutsch 2015-12-02 10:04:20 UTC
Is there any further output than those few lines?

The "Broken pipe" error is in general not something unusual when working wiht dracut.

Comment 19 Fabian Deutsch 2015-12-02 10:10:56 UTC
I manually cheked the output of lsinitrd on the system provided by Chen, and the output is good (it finishes without errors).

If the broken pipe error is a problem, please file a bug on the dracut component in RHEL.

Comment 20 cshao 2015-12-02 10:14:27 UTC
(In reply to Fabian Deutsch from comment #19)
> I manually cheked the output of lsinitrd on the system provided by Chen, and
> the output is good (it finishes without errors).
> 
> If the broken pipe error is a problem, please file a bug on the dracut
> component in RHEL.

Cancel the need info flag according #c19, and thank you very much, fabian :)

Comment 22 errata-xmlrpc 2016-03-09 14:31:33 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-0378.html


Note You need to log in before you can comment on or make changes to this bug.