Bug 1233282 - Possible double execution of the state machine for fops that start other subfops
Summary: Possible double execution of the state machine for fops that start other subfops
Keywords:
Status: CLOSED DUPLICATE of bug 1233484
Alias: None
Product: GlusterFS
Classification: Community
Component: disperse
Version: 3.7.1
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Xavi Hernandez
QA Contact:
URL:
Whiteboard:
Depends On: 1233258 1233484
Blocks: glusterfs-3.7.3
TreeView+ depends on / blocked
 
Reported: 2015-06-18 15:16 UTC by Xavi Hernandez
Modified: 2015-06-30 13:25 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of: 1233258
Environment:
Last Closed: 2015-06-30 13:25:59 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)

Description Xavi Hernandez 2015-06-18 15:16:49 UTC
+++ This bug was initially created as a clone of Bug #1233258 +++

Description of problem:

When a fop starts a subfop as part of its own execution, it's possible that this subfop finishes before the manager has completed the processing of the current state. In this case ec_resume() is called and a new instance of the same state machine is executed by another thread.

This could cause multiple problems.

Version-Release number of selected component (if applicable): mainline


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

--- Additional comment from Anand Avati on 2015-06-18 16:52:24 CEST ---

REVIEW: http://review.gluster.org/11317 (cluster/ec: Avoid parallel executions of the same state machine) posted (#1) for review on master by Xavier Hernandez (xhernandez@datalab.es)

Comment 1 Xavi Hernandez 2015-06-30 13:25:59 UTC

*** This bug has been marked as a duplicate of bug 1233484 ***


Note You need to log in before you can comment on or make changes to this bug.