Bug 1237212 - Enable FCoE by default in RHEV-H
Summary: Enable FCoE by default in RHEV-H
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-node
Version: 3.5.1
Hardware: Unspecified
OS: Unspecified
urgent
urgent
Target Milestone: ovirt-3.6.0-rc
: 3.6.0
Assignee: Fabian Deutsch
QA Contact: Virtualization Bugs
URL:
Whiteboard:
Depends On:
Blocks: 1238659 RHEV_FCOE 1263203 1334745 1334748
TreeView+ depends on / blocked
 
Reported: 2015-06-30 14:34 UTC by Pavel Zhukov
Modified: 2019-10-10 09:58 UTC (History)
19 users (show)

Fixed In Version: ovirt-node-3.3.0-0.4.20150906git14a6024.el7ev
Doc Type: Bug Fix
Doc Text:
Previously, FCoE storage did not work by default due to FCoE services not being enabled. Now, FCoE services are enabled by default in the Red Hat Enterprise Virtualization Hypervisor.
Clone Of:
: 1238659 1263203 (view as bug list)
Environment:
Last Closed: 2016-03-09 14:31:58 UTC
oVirt Team: Node
Target Upstream Version:
mgoldboi: Triaged+


Attachments (Terms of Use)
sosreport (5.37 MB, application/x-xz)
2015-07-02 07:45 UTC, Chaofeng Wu
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Bugzilla 1017151 unspecified CLOSED [RHEV-H 6.5] do not turn fcoe service on by default 2020-10-14 00:28:05 UTC
Red Hat Bugzilla 1353456 high CLOSED [vdsm] FCoE hook doesn't enable fcoe and lldpad services to start on boot 2020-10-14 00:28:05 UTC
Red Hat Product Errata RHBA-2016:0378 normal SHIPPED_LIVE ovirt-node bug fix and enhancement update for RHEV 3.6 2016-03-09 19:06:36 UTC
oVirt gerrit 43064 None None None Never
oVirt gerrit 43071 master MERGED init: Isolate the default target again Never
oVirt gerrit 46172 ovirt-3.5 MERGED init: Isolate the default target again Never

Internal Links: 1017151 1353456

Description Pavel Zhukov 2015-06-30 14:34:42 UTC
Description of problem:
FCOE doesn't work by default because it requires enabling of lldpad and fcoe services. 
Persistence of symlinks under /etc/systemd doesn't work

Version-Release number of selected component (if applicable):


How reproducible:
100%

Steps to Reproduce:
1. systemctl enable fcoe
2. reboot the system


Actual results:
fcoe/lldpad service are not started

Expected results:
started services

Additional info:

Comment 4 Chaofeng Wu 2015-07-02 07:45:31 UTC
Created attachment 1045378 [details]
sosreport

Comment 5 Chaofeng Wu 2015-07-02 07:47:47 UTC
Can reproduce.

Description of problem:

Version-Release number of selected component (if applicable):
rhev-hypervisor7-7.1-20150603.0.iso
ovirt-node-3.2.3-3.el7.noarch

How reproducible:
100%

Steps to Reproduce:
1. Step by step to install the rhev-hypervisor7-7.1-20150603.0.iso on the FCoE machine.
2. Configure the system network, then drop into command.
3. Enable and start lldpad.socket, lldpad.service and fcoe service by command 'systemctl'
4. Run command "persist /etc/systemd/", then reboot the system.
5. Check the status of lldpad.socket, lldpad.service and fcoe service.


Actual results:
lldpad.socket, lldpad.service and fcoe are enabled, but not running.

Expected results:
lldpad.socket, lldpad.service and fcoe are enabled and running.

Additional info:
We try the above steps on the FCoE machine with ixgbe driver(Hareware: Intel Corporation 82599ES 10-Gigabit SFI/SFP+ Network Connection). Sosreport is attached.

Comment 8 Dan Kenigsberg 2015-07-03 23:17:54 UTC
Is this issue a 3.5.0 regression? If so, I guess it is yet another consequence of Bug 1203422 (which is to be fixed in 3.5.4).

Both ifcfg-em1 and ifcfg-em2 have ONBOOT=no, and are taken up by vdsm too late (after fcoe have failed to start on top them).

# Generated by VDSM version 4.16.20-1.el7ev
DEVICE=em1
HWADDR=XXXX
ONBOOT=no
MTU=9000
DEFROUTE=no
NM_CONTROLLED=no

However, I don't understand where the symmetry between em1 and em2 breaks.

Please check if ONBOOT=no is the sole problem by setting ONBOOT=yes in ifcfg*, and setting net_persistence=ifcfg in vdsm.conf. Remember to persist edited files so they show up after boot.

Comment 9 Sachin Raje 2015-07-06 12:25:18 UTC
Dan, I'm checking with customer about your suggestion in comment #8 . I'll let you know about test result.

Comment 10 Ying Cui 2015-07-07 11:09:55 UTC
Adding this comment for _original_ bug description issue on node side.

1. This is rhevh 7.1 only bug. lldpad.socket, lldpad.service and fcoe are enabled, but not running as default after reboot rhevh.

2. No such issue on RHEVH 6 whatever rhevh 6.5 and 6.6 for 3.4.z and rhevh 6.6 and 6.7 for 3.5.z.
lldpad and fcoe are already enabled as default, and daemon running as default in rhevh.
Test version:
rhev-hypervisor6-6.5-20150115.0.el6ev - 3.4.z
rhev-hypervisor6-6.6-20150123.1.el6ev - 3.4.z
rhev-hypervisor6-6.6-20150603.0.el6ev - 3.5.z
rhev-hypervisor6-6.7-20150609.0.el6ev - 3.5.z

Comment 11 Ying Cui 2015-07-07 11:19:38 UTC
It seems comment 6 and comment 7 are different from the original bug description.
To avoid confusing on bug fix and verify, we'd consider to split new bug to trace detail for comment 6 and comment 7.

Comment 19 Chaofeng Wu 2015-10-08 09:39:06 UTC
Test version:
rhev-hypervisor7-7.2-20150928.0.iso
ovirt-node-3.3.0-0.10.20150928gite7ee3f1.el7ev.noarch

Test steps:
1. PXE boot and install RHEV-H.
2. Configure RHEV-H network.
3. Reboot RHEV-H.

Test result:
After step1, check fcoe.service, lldpad.socket and lldpad.service status, all of them are running and enabled.
After step2, all of three services are running and enabled.
After step3, all of three services are running and enabled.

This bug has been fixed, change the status to VERIFIED.

Comment 21 errata-xmlrpc 2016-03-09 14:31:58 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-0378.html


Note You need to log in before you can comment on or make changes to this bug.