Bug 1238460 - RHEL Images for overcloud use EDT as timezone
Summary: RHEL Images for overcloud use EDT as timezone
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-tripleo-heat-templates
Version: 7.0 (Kilo)
Hardware: Unspecified
OS: Unspecified
urgent
medium
Target Milestone: y3
: 7.0 (Kilo)
Assignee: James Slagle
QA Contact: Omri Hochman
URL:
Whiteboard:
Keywords: Triaged, ZStream
: 1274620 (view as bug list)
Depends On:
Blocks: 1191185 1243520 1299081 1309818 1311366
TreeView+ depends on / blocked
 
Reported: 2015-07-01 23:56 UTC by Graeme Gillies
Modified: 2018-02-08 10:44 UTC (History)
15 users (show)

(edit)
Previous Overcloud images used EDT for the timezone, which caused problems for users outside of the EDT timezone. This fix adds a customizable 'TimeZone' parameter to the Heat template collection. Users can set the 'TimeZone' parameter to their own timezone. If blank, it defaults to UTC.
Clone Of:
: 1299081 1309818 (view as bug list)
(edit)
Last Closed: 2016-02-18 16:46:41 UTC


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2016:0264 normal SHIPPED_LIVE Red Hat Enterprise Linux OSP 7 director Bug Fix Advisory 2016-02-18 21:41:29 UTC
OpenStack gerrit 249886 None None None Never
OpenStack gerrit 273623 None None None 2016-01-28 15:31 UTC

Description Graeme Gillies 2015-07-01 23:56:41 UTC
The prebuilt Overcloud images we currently have for use in Puddles have the timezone set to EDT. This is not fun for those of us who aren't in the US. Can we please make sure all the images built have UTC set as the timezone. In fact, all RHOS systems in general should always be configured to use UTC

Regards,

Graeme

Comment 4 David Hill 2015-09-04 15:22:32 UTC
Hi guys,

  Would it be possible to add a configuration parameter for this so any timezone could be used ?  Some companies requires the timezone to be UTC, some other might require to have their local timezone configured.

Thank you very much,

David Hill

Comment 5 Mike Burns 2015-10-23 16:08:56 UTC
*** Bug 1274620 has been marked as a duplicate of this bug. ***

Comment 10 Udi Shkalim 2016-02-16 16:48:10 UTC
From: openstack-tripleo-heat-templates-0.8.6-120.el7ost.noarch

[root@overcloud-controller-1 ~]# timedatectl 
      Local time: Tue 2016-02-16 16:42:07 UTC
  Universal time: Tue 2016-02-16 16:42:07 UTC
        RTC time: Tue 2016-02-16 16:42:06
       Time zone: UTC (UTC, +0000)
     NTP enabled: yes
NTP synchronized: yes
 RTC in local TZ: no
      DST active: n/a

Will try to modify the default value and will update with results.

Comment 11 Udi Shkalim 2016-02-17 10:14:54 UTC
[root@overcloud-controller-0 ~]# date
Wed Feb 17 10:12:54 UTC 2016

[root@overcloud-controller-0 ~]# timedatectl 
      Local time: Wed 2016-02-17 10:13:03 UTC
  Universal time: Wed 2016-02-17 10:13:03 UTC
        RTC time: Wed 2016-02-17 10:13:03
       Time zone: IST (UTC, +0000)
     NTP enabled: yes
NTP synchronized: yes
 RTC in local TZ: no
      DST active: n/a

[root@overcloud-controller-0 ~]# ls -ltr /etc/localtime 
lrwxrwxrwx. 1 root root 23 Feb 16 20:40 /etc/localtime -> /usr/share/zoneinfo/IST
[root@overcloud-controller-0 ~]# ls -ltr /usr/share/zoneinfo/IST
ls: cannot access /usr/share/zoneinfo/IST: No such file or directory


It seems to be failing to configuring the correct timezone...

Comment 12 Omri Hochman 2016-02-17 20:35:52 UTC
seems like I'm getting EST time-zone on the OC

[root@overcloud-controller-0 ~]#  date
Wed Feb 17 15:18:38 EST 2016
[root@overcloud-controller-0 ~]# timedatectl 
      Local time: Wed 2016-02-17 15:18:46 EST
  Universal time: Wed 2016-02-17 20:18:46 UTC
        RTC time: Wed 2016-02-17 20:18:45
        Timezone: America/New_York (EST, -0500)
     NTP enabled: yes
NTP synchronized: yes
 RTC in local TZ: no
      DST active: no
 Last DST change: DST ended at
                  Sun 2015-11-01 01:59:59 EDT
                  Sun 2015-11-01 01:00:00 EST
 Next DST change: DST begins (the clock jumps one hour forward) at
                  Sun 2016-03-13 01:59:59 EST
                  Sun 2016-03-13 03:00:00 EDT
[root@overcloud-controller-0 ~]# ls -ltr /etc/localtime 
lrwxrwxrwx. 1 root root 38 Oct  7 10:36 /etc/localtime -> ../usr/share/zoneinfo/America/New_York
[root@overcloud-controller-0 ~]# ls -ltr /usr/share/zoneinfo/America/New_York
-rw-r--r--. 3 root root 3519 Aug 11  2015 /usr/share/zoneinfo/America/New_York

Comment 13 Alexander Chuzhoy 2016-02-18 03:25:29 UTC
Environment:
openstack-tripleo-heat-templates-0.8.6-121.el7ost.noarch

I'm getting UTC:

[root@overcloud-controller-0 ~]# date
Thu Feb 18 03:24:28 UTC 2016
[root@overcloud-controller-0 ~]# timedatectl
      Local time: Thu 2016-02-18 03:24:31 UTC
  Universal time: Thu 2016-02-18 03:24:31 UTC
        RTC time: Thu 2016-02-18 03:24:31
       Time zone: UTC (UTC, +0000)
     NTP enabled: yes
NTP synchronized: yes
 RTC in local TZ: no
      DST active: n/a

Comment 14 Alexander Chuzhoy 2016-02-18 04:03:11 UTC
Depoyed with:
  TimeZone: Asia/Tel_Aviv

And got:

[root@overcloud-controller-2 ~]# date
Thu Feb 18 06:02:35 IST 2016
[root@overcloud-controller-2 ~]# timedatectl
      Local time: Thu 2016-02-18 06:02:36 IST
  Universal time: Thu 2016-02-18 04:02:36 UTC
        RTC time: Thu 2016-02-18 04:02:36
       Time zone: Asia/Tel_Aviv (IST, +0200)
     NTP enabled: yes
NTP synchronized: no
 RTC in local TZ: no
      DST active: no
 Last DST change: DST ended at
                  Sun 2015-10-25 01:59:59 IDT
                  Sun 2015-10-25 01:00:00 IST
 Next DST change: DST begins (the clock jumps one hour forward) at
                  Fri 2016-03-25 01:59:59 IST
                  Fri 2016-03-25 03:00:00 IDT

Comment 15 Udi Shkalim 2016-02-18 12:54:57 UTC
(In reply to Alexander Chuzhoy from comment #14)
> Depoyed with:
>   TimeZone: Asia/Tel_Aviv
> 
> And got:
> 
> [root@overcloud-controller-2 ~]# date
> Thu Feb 18 06:02:35 IST 2016
> [root@overcloud-controller-2 ~]# timedatectl
>       Local time: Thu 2016-02-18 06:02:36 IST
>   Universal time: Thu 2016-02-18 04:02:36 UTC
>         RTC time: Thu 2016-02-18 04:02:36
>        Time zone: Asia/Tel_Aviv (IST, +0200)
>      NTP enabled: yes
> NTP synchronized: no
>  RTC in local TZ: no
>       DST active: no
>  Last DST change: DST ended at
>                   Sun 2015-10-25 01:59:59 IDT
>                   Sun 2015-10-25 01:00:00 IST
>  Next DST change: DST begins (the clock jumps one hour forward) at
>                   Fri 2016-03-25 01:59:59 IST
>                   Fri 2016-03-25 03:00:00 IDT

How did you know what is the correct syntax for the new parameter?
It's need to be documented and explain how to use it. I've tried "GMT+2" and "IST" and it did not worked.

Comment 16 Alexander Chuzhoy 2016-02-18 15:31:47 UTC
@Udi,
I simply looked under /usr/share/zoneinfo.

There's a folder named Asia with Tel_Aviv (amongst others) under it.

Comment 18 errata-xmlrpc 2016-02-18 16:46:41 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-0264.html


Note You need to log in before you can comment on or make changes to this bug.