Bug 1239269 - [Scheduler]: Unable to create Snapshots on RHEL-7.1 using Scheduler
Summary: [Scheduler]: Unable to create Snapshots on RHEL-7.1 using Scheduler
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: GlusterFS
Classification: Community
Component: snapshot
Version: mainline
Hardware: Unspecified
OS: Unspecified
urgent
urgent
Target Milestone: ---
Assignee: Avra Sengupta
QA Contact:
URL:
Whiteboard:
Depends On: 1231647 1234847 1247056 1395643
Blocks: 1202842 1223636 1239270
TreeView+ depends on / blocked
 
Reported: 2015-07-05 07:02 UTC by Avra Sengupta
Modified: 2016-11-16 10:49 UTC (History)
10 users (show)

Fixed In Version: glusterfs-3.8rc2
Doc Type: Bug Fix
Doc Text:
Clone Of: 1231647
: 1239270 (view as bug list)
Environment:
Last Closed: 2016-06-16 13:19:46 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)

Comment 1 Anand Avati 2015-07-05 07:31:47 UTC
REVIEW: http://review.gluster.org/11535 (snapshot/scheduler: Use /var/run/gluster/shared_storage/snaps/tmp_file for writing data into tmp file and then making an atomic rename to the required filename.) posted (#1) for review on master by Avra Sengupta (asengupt@redhat.com)

Comment 2 Anand Avati 2015-07-06 08:46:39 UTC
REVIEW: http://review.gluster.org/11535 (snapshot/scheduler: Use /var/run/gluster/shared_storage/snaps/tmp_file for writing data into tmp file and then making an atomic rename to the required filename.) posted (#2) for review on master by Avra Sengupta (asengupt@redhat.com)

Comment 3 Nagaprasad Sathyanarayana 2015-10-25 14:52:12 UTC
Fix for this BZ is already present in a GlusterFS release. You can find clone of this BZ, fixed in a GlusterFS release and closed. Hence closing this mainline BZ as well.

Comment 4 Niels de Vos 2016-06-16 13:19:46 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.8.0, please open a new bug report.

glusterfs-3.8.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://blog.gluster.org/2016/06/glusterfs-3-8-released/
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user


Note You need to log in before you can comment on or make changes to this bug.