Bug 1247056 - [SELinux] [Scheduler]: Unable to create Snapshots on RHEL-7.1 using Scheduler [NEEDINFO]
[SELinux] [Scheduler]: Unable to create Snapshots on RHEL-7.1 using Scheduler
Status: CLOSED ERRATA
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: snapshot (Show other bugs)
3.1
Unspecified Unspecified
urgent Severity urgent
: ---
: RHGS 3.3.0
Assigned To: Avra Sengupta
Anil Shah
: Triaged, ZStream
Depends On:
Blocks: 1202842 1216951 1223636 1239269 1239270 1395643 1417147
  Show dependency treegraph
 
Reported: 2015-07-27 04:57 EDT by Avra Sengupta
Modified: 2017-09-21 00:53 EDT (History)
13 users (show)

See Also:
Fixed In Version: glusterfs-3.8.4-19
Doc Type: Bug Fix
Doc Text:
The boolean cron_system_cronjob_use_shares should be set to 'on' for the snapshot scheduler to function. Workaround: To check if the boolean is set to on: # q --> off To set the boolean to 'on': # setsebool cron_system_cronjob_use_shares on To verify that the boolean is set to 'on': # getsebool -a |grep cron_system_cronjob_use_shares cron_system_cronjob_use_shares --> on
Story Points: ---
Clone Of: 1231647
: 1395643 (view as bug list)
Environment:
Last Closed: 2017-09-21 00:25:52 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
lbailey: needinfo? (asengupt)


Attachments (Terms of Use)

  None (edit)
Comment 7 Avra Sengupta 2016-02-26 01:29:24 EST
Removing this from 3.1.3. Will be fixing it later.
Comment 8 Avra Sengupta 2016-11-16 05:48:14 EST
Cloning this to master, and adding setting of the boolean in the init of snap scheduler, so that this bug can be removed from known issues
Comment 9 Avra Sengupta 2016-11-16 05:54:32 EST
Patch sent to master : http://review.gluster.org/15857
Comment 12 Atin Mukherjee 2017-03-24 05:52:39 EDT
downstream patch : https://code.engineering.redhat.com/gerrit/#/c/101319/
Comment 14 Anil Shah 2017-05-02 08:00:49 EDT
[root@dhcp43-49 ~]# getsebool -a |grep cron_system_cronjob_use_shares
cron_system_cronjob_use_shares --> off

[root@dhcp43-49 ~]# gluster v set all cluster.enable-shared-storage enable
volume set: success

[root@dhcp43-49 ~]# getsebool -a |grep cron_system_cronjob_use_shares
cron_system_cronjob_use_shares --> off

[root@dhcp43-49 ~]# snap_scheduler.py init
snap_scheduler: Successfully initialised snapshot scheduler for this node
[root@dhcp43-49 ~]# getsebool -a |grep cron_system_cronjob_use_shares
cron_system_cronjob_use_shares --> on



[root@dhcp43-49 ~]gluster snapshot list

Scheduled-job1-vol0_GMT-2017.05.02-11.55.02
Scheduled-job1-vol0_GMT-2017.05.02-11.57.01
Scheduled-job1-vol0_GMT-2017.05.02-11.58.01

bug verified on build glusterfs-3.8.4-24.el7rhgs.x86_64
Comment 17 errata-xmlrpc 2017-09-21 00:25:52 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2017:2774
Comment 18 errata-xmlrpc 2017-09-21 00:53:56 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2017:2774

Note You need to log in before you can comment on or make changes to this bug.