Bug 1239270 - [Scheduler]: Unable to create Snapshots on RHEL-7.1 using Scheduler
Summary: [Scheduler]: Unable to create Snapshots on RHEL-7.1 using Scheduler
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: GlusterFS
Classification: Community
Component: snapshot
Version: 3.7.2
Hardware: Unspecified
OS: Unspecified
urgent
urgent
Target Milestone: ---
Assignee: Avra Sengupta
QA Contact:
URL:
Whiteboard:
Depends On: 1231647 1234847 1239269 1247056 1395643
Blocks: 1202842 1223636
TreeView+ depends on / blocked
 
Reported: 2015-07-05 07:05 UTC by Avra Sengupta
Modified: 2016-11-16 10:49 UTC (History)
11 users (show)

Fixed In Version: glusterfs-3.7.3
Doc Type: Bug Fix
Doc Text:
Clone Of: 1239269
Environment:
Last Closed: 2015-07-30 09:51:32 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)

Comment 1 Anand Avati 2015-07-05 07:36:23 UTC
REVIEW: http://review.gluster.org/11536 (snapshot/scheduler: Use /var/run/gluster/shared_storage/snaps/tmp_file for writing data into tmp file and then making an atomic rename to the required filename.) posted (#1) for review on release-3.7 by Avra Sengupta (asengupt@redhat.com)

Comment 2 Anand Avati 2015-07-06 09:05:19 UTC
REVIEW: http://review.gluster.org/11536 (snapshot/scheduler: Use /var/run/gluster/shared_storage/snaps/tmp_file for writing data into tmp file and then making an atomic rename to the required filename) posted (#2) for review on release-3.7 by Avra Sengupta (asengupt@redhat.com)

Comment 3 Anand Avati 2015-07-08 09:39:38 UTC
COMMIT: http://review.gluster.org/11536 committed in release-3.7 by Rajesh Joseph (rjoseph@redhat.com) 
------
commit a2e041458cbdf7b758e1af5d1e0c897f34bbc7c0
Author: Avra Sengupta <asengupt@redhat.com>
Date:   Sun Jul 5 12:57:39 2015 +0530

    snapshot/scheduler: Use /var/run/gluster/shared_storage/snaps/tmp_file for writing data into tmp file and then making an atomic rename to the required filename
    
    The reason for using this location is that it adheres to
    the selinux policies.
    
    Also moving the update of the current_scheduler file,
    under the lock so as to avoid multiple writes
    
    Change-Id: I61e62b5daf6f1bce2319f64f7b1dfb8b93726077
    BUG: 1239270
    Signed-off-by: Avra Sengupta <asengupt@redhat.com>
    Reviewed-on: http://review.gluster.org/11536
    Tested-by: NetBSD Build System <jenkins@build.gluster.org>
    Tested-by: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Rajesh Joseph <rjoseph@redhat.com>

Comment 4 Kaushal 2015-07-30 09:51:32 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.7.3, please open a new bug report.

glusterfs-3.7.3 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://thread.gmane.org/gmane.comp.file-systems.gluster.devel/12078
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user


Note You need to log in before you can comment on or make changes to this bug.