Bug 1240711 - Syslog Filled With "Invalid response packet from host" Messages
Summary: Syslog Filled With "Invalid response packet from host" Messages
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: avahi
Version: 23
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Rex Dieter
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 1177166 1260744 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-07-07 14:37 UTC by Garry T. Williams
Modified: 2015-10-26 13:20 UTC (History)
7 users (show)

Fixed In Version: avahi-0.6.31-43.fc22 avahi-0.6.31-43.fc21
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-10-08 19:51:50 UTC
Type: Bug


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Avahi Bug Tracker 352 None None None Never

Internal Links: 1269541 1290890 1292727

Description Garry T. Williams 2015-07-07 14:37:43 UTC
Description of problem: The system log is filled with many thousands of these messages:

avahi-daemon[570]: Invalid response packet from host 10.6.13.57.

There is no useful purpose to sending this message to the log; it bloats the file system; it obscures important messages.


Version-Release number of selected component (if applicable): avahi-0.6.31-31.fc22.x86_64


How reproducible: always


Steps to Reproduce:
1. Run f22 ona network with whatever avahi doesn't like.
2.
3.

Actual results: thousands of messages.


Expected results: fewer (one!) messages


Additional info: This may be a regression -- it hasn't shown up in earlier releases: http://www.avahi.org/ticket/284 .

Comment 1 Garry T. Williams 2015-07-15 19:55:15 UTC
This is really silly and wasteful:

garry@ifr$ journalctl|grep -c 'Invalid response packet'
122561
garry@ifr$

Comment 2 Dan Mossor [danofsatx] 2015-09-17 02:24:41 UTC
*** Bug 1260744 has been marked as a duplicate of this bug. ***

Comment 3 Dan Mossor [danofsatx] 2015-09-17 02:25:21 UTC
*** Bug 1177166 has been marked as a duplicate of this bug. ***

Comment 4 Dan Mossor [danofsatx] 2015-09-17 02:43:58 UTC
This is becoming unreasonable. This bug has been open for 9 months, and no action has been taken. Avahi is a useful service for those who need it. However, for some, it can fill the journal - when I take my laptop to my university and connect to the campus LAN, my journal is overwhelmed with reports of "Invalid response packet from host ..."

Even here at home, I have one Canon MFP device that doesn't either doesn't implement the standard properly, or isn't interpreted by my laptop correctly, so an entry is logged every 20 seconds. A proper way to handle this is to log it once, and then ignore it.

[dan@g55 ~]$ journalctl | grep -c 'Invalid response packet'
286620
[dan@g55 ~]$

Comment 5 Rex Dieter 2015-09-17 14:49:19 UTC
Looks like http://avahi.org/ticket/352 has a concrete proposal on how to address this, maybe worth trying.

any objections?

Comment 6 Rex Dieter 2015-09-17 15:58:39 UTC
%changelog
* Thu Sep 17 2015 Rex Dieter <rdieter@fedoraproject.org> 0.6.31-39
- Syslog Filled With "Invalid response packet from host" Message (#1240711)
- avahi-daemon manpage references file locations under /home/lennart/tmp (#991094)

Comment 7 Fedora Update System 2015-09-17 17:13:48 UTC
avahi-0.6.31-40.fc23 has been submitted as an update to Fedora 23. https://bodhi.fedoraproject.org/updates/FEDORA-2015-16117

Comment 8 Fedora Update System 2015-09-17 17:22:46 UTC
avahi-0.6.31-40.fc22 has been submitted as an update to Fedora 22. https://bodhi.fedoraproject.org/updates/FEDORA-2015-16118

Comment 9 Fedora Update System 2015-09-17 17:32:24 UTC
avahi-0.6.31-40.fc21 has been submitted as an update to Fedora 21. https://bodhi.fedoraproject.org/updates/FEDORA-2015-16119

Comment 10 Fedora Update System 2015-09-17 21:29:26 UTC
avahi-0.6.31-40.fc23 has been pushed to the Fedora 23 testing repository. If problems still persist, please make note of it in this bug report.\nIf you want to test the update, you can install it with \n su -c 'yum --enablerepo=updates-testing update avahi'. You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2015-16117

Comment 11 Fedora Update System 2015-09-18 05:20:33 UTC
avahi-0.6.31-40.fc21 has been pushed to the Fedora 21 testing repository. If problems still persist, please make note of it in this bug report.\nIf you want to test the update, you can install it with \n su -c 'yum --enablerepo=updates-testing update avahi'. You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2015-16119

Comment 12 Michal Sekletar 2015-09-18 11:06:42 UTC
Recently I've seen that mDNS implementation on some Windows 10 machines also violates RFC6762, in particular this clause,

A Multicast DNS responder MUST only respond when it has a positive,
non-null response to send, or it authoritatively knows that a
particular record does not exist.  For unique records, where the host
has already established sole ownership of the name, it MUST return
negative answers to queries for records that it knows not to exist.

It does so by sending responses to queries asked by non fully compliant mDNS queriers (source port is high-number ephemeral UDP port, not 5353) with ANSCOUNT == 0. It literally sends back empty DNS packets without no RRs in them, nor any useful header flags (NXDOMAIN) set.

Comment 13 Rex Dieter 2015-09-18 12:33:50 UTC
<nod>, since this snippet of code to me seems more like a tool for debugging, I was tempted to drop the syslog output for this case completely.

If problems persist, we could consider doing that.

Comment 14 Fedora Update System 2015-09-18 16:24:02 UTC
avahi-0.6.31-40.fc22 has been pushed to the Fedora 22 testing repository. If problems still persist, please make note of it in this bug report.\nIf you want to test the update, you can install it with \n su -c 'yum --enablerepo=updates-testing update avahi'. You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2015-16118

Comment 15 Pacho Ramos 2015-09-21 08:23:10 UTC
Hello

Even with the http://pkgs.fedoraproject.org/cgit/avahi.git/tree/avahi-0.6.31-invalid_packet.patch I still get a lot of messages with the 
avahi-daemon[412]: Invalid response packet from host ...

error :(

Thanks for your help

Comment 16 Michal Sekletar 2015-09-21 08:39:05 UTC
(In reply to Pacho Ramos from comment #15)

> Even with the
> http://pkgs.fedoraproject.org/cgit/avahi.git/tree/avahi-0.6.31-
> invalid_packet.patch I still get a lot of messages with the 
> avahi-daemon[412]: Invalid response packet from host ...
> 

Do you have any Windows 10 machine on your network? If yes, then this is most likely caused by problem I described in comment #12.

Comment 17 Pacho Ramos 2015-09-21 13:21:25 UTC
Yes, there are machines with Windows 10 in the network of my center :/

Comment 18 Fedora Update System 2015-09-22 18:43:15 UTC
avahi-0.6.31-42.fc22 has been submitted as an update to Fedora 22. https://bodhi.fedoraproject.org/updates/FEDORA-2015-16118

Comment 19 Fedora Update System 2015-09-22 18:43:37 UTC
avahi-0.6.31-42.fc21 has been submitted as an update to Fedora 21. https://bodhi.fedoraproject.org/updates/FEDORA-2015-16119

Comment 20 Fedora Update System 2015-09-23 07:00:18 UTC
avahi-0.6.31-40.fc23 has been pushed to the Fedora 23 stable repository. If problems still persist, please make note of it in this bug report.

Comment 21 Pacho Ramos 2015-09-23 17:54:10 UTC
The last patch finally works for me, thanks!

Comment 22 Fedora Update System 2015-09-24 09:53:43 UTC
avahi-0.6.31-42.fc21 has been pushed to the Fedora 21 testing repository. If problems still persist, please make note of it in this bug report.
If you want to test the update, you can install it with
$ su -c 'dnf --enablerepo=updates-testing update avahi'
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2015-16119

Comment 23 Fedora Update System 2015-09-25 21:21:47 UTC
avahi-0.6.31-42.fc22 has been pushed to the Fedora 22 testing repository. If problems still persist, please make note of it in this bug report.
If you want to test the update, you can install it with
$ su -c 'dnf --enablerepo=updates-testing update avahi'
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2015-16118

Comment 24 Fedora Update System 2015-09-29 19:32:19 UTC
avahi-0.6.31-43.fc22 has been submitted as an update to Fedora 22. https://bodhi.fedoraproject.org/updates/FEDORA-2015-16118

Comment 25 Fedora Update System 2015-09-29 19:36:25 UTC
avahi-0.6.31-43.fc21 has been submitted as an update to Fedora 21. https://bodhi.fedoraproject.org/updates/FEDORA-2015-16119

Comment 26 Garry T. Williams 2015-10-02 17:10:29 UTC
(In reply to Fedora Update System from comment #24)
> avahi-0.6.31-43.fc22 has been submitted as an update to Fedora 22.

That fixed it.

Thank you.

Comment 27 Fedora Update System 2015-10-04 01:38:15 UTC
avahi-0.6.31-43.fc22 has been pushed to the Fedora 22 testing repository. If problems still persist, please make note of it in this bug report.
If you want to test the update, you can install it with
$ su -c 'dnf --enablerepo=updates-testing update avahi'
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2015-16118

Comment 28 Fedora Update System 2015-10-04 02:21:40 UTC
avahi-0.6.31-43.fc21 has been pushed to the Fedora 21 testing repository. If problems still persist, please make note of it in this bug report.
If you want to test the update, you can install it with
$ su -c 'dnf --enablerepo=updates-testing update avahi'
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2015-16119

Comment 29 Fedora Update System 2015-10-08 19:51:41 UTC
avahi-0.6.31-43.fc22 has been pushed to the Fedora 22 stable repository. If problems still persist, please make note of it in this bug report.

Comment 30 Fedora Update System 2015-10-26 13:20:11 UTC
avahi-0.6.31-43.fc21 has been pushed to the Fedora 21 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.