Bug 124127 - Touchpad only works if USB mouse not plugged in
Touchpad only works if USB mouse not plugged in
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
2
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Arjan van de Ven
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-05-24 07:09 EDT by Nicholas Allen
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-07-14 10:08:25 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Nicholas Allen 2004-05-24 07:09:34 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (compatible; Konqueror/3.2; Linux) (KHTML, like Gecko)

Description of problem:
When I boot up fedora core 2 with a USB mouse plugged in then the touchpad no longer works. However, if I reboot with the USB mouse not connected the touchpad does work (although tapping on touchpad does not simulate mouse click). In fedora core 1 they both worked together. I could use the touchpad and USB mouse without having to reboot the computer. 

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.Turn on computer with USB mouse plugged in
2.
3.
    

Actual Results:  Touchpad no longer functions

Expected Results:  Touchpad and USB mouse should work together. Also should be able to tap on touchpad to simulate a mouse click.

Additional info:
Comment 1 Barry K. Nathan 2004-07-14 07:13:14 EDT
If your BIOS has an option for "USB legacy emulation" or anything of
that sort, try disabling it. That won't make touchpad tapping work
(see bug 116091 and bug 122014 for more information), but it might
allow the touchpad and the USB mouse to work together.

If you can't find such an option, you may want to try plugging the USB
mouse in after the system finishes booting.
Comment 2 Barry K. Nathan 2004-07-14 07:14:08 EDT
Regarding the touchpad tapping again, you may also want to look at bug
123529.
Comment 3 Nicholas Allen 2004-07-14 08:53:00 EDT
The problem seems to be fixed in later versions of the kernel. I have 
tried a few now and have not reencountered the problem. 
Comment 4 Mike A. Harris 2004-07-14 10:08:11 EDT
reassigning to kernel component and closing as ERRATA

Note You need to log in before you can comment on or make changes to this bug.