Bug 1241379 - Reduce 'CTR disabled' brick log message from ERROR to INFO/DEBUG
Summary: Reduce 'CTR disabled' brick log message from ERROR to INFO/DEBUG
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: GlusterFS
Classification: Community
Component: tiering
Version: mainline
Hardware: x86_64
OS: Linux
low
low
Target Milestone: ---
Assignee: bugs@gluster.org
QA Contact: bugs@gluster.org
URL:
Whiteboard:
Depends On:
Blocks: 1260923 1275157 1275515
TreeView+ depends on / blocked
 
Reported: 2015-07-09 06:47 UTC by Anoop C S
Modified: 2016-05-28 05:58 UTC (History)
1 user (show)

Fixed In Version: glusterfs-3.7.6
Doc Type: Bug Fix
Doc Text:
Clone Of:
: 1275157 (view as bug list)
Environment:
Last Closed: 2016-05-28 05:58:51 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)

Description Anoop C S 2015-07-09 06:47:20 UTC
Description of problem:
The following error log related to CTR translator is being generated in brick logs at each volume start.

[ctr-helper.c:256:extract_ctr_options] 0-gfdbdatastore: CTR Xlator is disabled.


Version-Release number of selected component (if applicable):
mainline

How reproducible:
Always

Steps to Reproduce:
1. Create and start simple distributed volume.
2. Check the brick logs for the above mentioned message.

Actual results:
Error log entry is seen.

Expected results:
Error log shouldn't be present in brick logs.

Additional info:

Comment 1 Anand Avati 2015-07-09 08:04:41 UTC
REVIEW: http://review.gluster.org/11592 (features/ctr: Reduce the log-level for ctr-disabled message) posted (#1) for review on master by Anoop C S (achiraya@redhat.com)

Comment 2 Anand Avati 2015-07-09 19:15:19 UTC
COMMIT: http://review.gluster.org/11592 committed in master by Dan Lambright (dlambrig@redhat.com) 
------
commit b6a7a44079c724cbf6fb24c7ac83892f551dc5f6
Author: Anoop C S <anoopcs@redhat.com>
Date:   Thu Jul 9 11:06:01 2015 +0530

    features/ctr: Reduce the log-level for ctr-disabled message
    
    Since by default CTR translator is disabled, the following
    log message is being displayed in brick logs.
    
    [ctr-helper.c:256:extract_ctr_options] 0-gfdbdatastore: CTR Xlator is disabled.
    
    Therefore this change is to reduce the log-level to INFO.
    
    Change-Id: I3b82d6b0dc0445286f91490fb497167a36914a2b
    BUG: 1241379
    Signed-off-by: Anoop C S <anoopcs@redhat.com>
    Reviewed-on: http://review.gluster.org/11592
    Reviewed-by: Joseph Fernandes
    Tested-by: Joseph Fernandes
    Tested-by: NetBSD Build System <jenkins@build.gluster.org>

Comment 3 Anoop C S 2015-11-17 06:45:49 UTC
Fix for this BZ is already present in a GlusterFS release. You can find clone
of this BZ, fixed in a GlusterFS release and closed. Hence closing this
mainline BZ as well.


Note You need to log in before you can comment on or make changes to this bug.