Bug 1275157 - Reduce 'CTR disabled' brick log message from ERROR to INFO/DEBUG
Reduce 'CTR disabled' brick log message from ERROR to INFO/DEBUG
Status: CLOSED CURRENTRELEASE
Product: GlusterFS
Classification: Community
Component: tiering (Show other bugs)
3.7.5
All All
low Severity low
: ---
: ---
Assigned To: Anoop C S
bugs@gluster.org
:
Depends On: 1241379
Blocks: 1275515 glusterfs-3.7.6
  Show dependency treegraph
 
Reported: 2015-10-26 03:29 EDT by Anoop C S
Modified: 2015-11-17 01:01 EST (History)
3 users (show)

See Also:
Fixed In Version: glusterfs-3.7.6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 1241379
: 1275515 (view as bug list)
Environment:
Last Closed: 2015-11-17 01:01:01 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Anoop C S 2015-10-26 03:29:20 EDT
+++ This bug was initially created as a clone of Bug #1241379 +++

Description of problem:
The following error log related to CTR translator is being generated in brick logs at each volume start.

[ctr-helper.c:256:extract_ctr_options] 0-gfdbdatastore: CTR Xlator is disabled.


Version-Release number of selected component (if applicable):
mainline

How reproducible:
Always

Steps to Reproduce:
1. Create and start simple distributed volume.
2. Check the brick logs for the above mentioned message.

Actual results:
Error log entry is seen.

Expected results:
Error log shouldn't be present in brick logs.

Additional info:

--- Additional comment from Anand Avati on 2015-07-09 04:04:41 EDT ---

REVIEW: http://review.gluster.org/11592 (features/ctr: Reduce the log-level for ctr-disabled message) posted (#1) for review on master by Anoop C S (achiraya@redhat.com)

--- Additional comment from Anand Avati on 2015-07-09 15:15:19 EDT ---

COMMIT: http://review.gluster.org/11592 committed in master by Dan Lambright (dlambrig@redhat.com) 
------
commit b6a7a44079c724cbf6fb24c7ac83892f551dc5f6
Author: Anoop C S <anoopcs@redhat.com>
Date:   Thu Jul 9 11:06:01 2015 +0530

    features/ctr: Reduce the log-level for ctr-disabled message
    
    Since by default CTR translator is disabled, the following
    log message is being displayed in brick logs.
    
    [ctr-helper.c:256:extract_ctr_options] 0-gfdbdatastore: CTR Xlator is disabled.
    
    Therefore this change is to reduce the log-level to INFO.
    
    Change-Id: I3b82d6b0dc0445286f91490fb497167a36914a2b
    BUG: 1241379
    Signed-off-by: Anoop C S <anoopcs@redhat.com>
    Reviewed-on: http://review.gluster.org/11592
    Reviewed-by: Joseph Fernandes
    Tested-by: Joseph Fernandes
    Tested-by: NetBSD Build System <jenkins@build.gluster.org>
Comment 1 Vijay Bellur 2015-10-26 03:34:39 EDT
REVIEW: http://review.gluster.org/12424 (features/ctr: Reduce the log-level for ctr-disabled message) posted (#1) for review on release-3.7 by Anoop C S (anoopcs@redhat.com)
Comment 2 Vijay Bellur 2015-10-28 00:57:38 EDT
REVIEW: http://review.gluster.org/12424 (features/ctr: Reduce the log-level for ctr-disabled message) posted (#2) for review on release-3.7 by Anoop C S (anoopcs@redhat.com)
Comment 3 Vijay Bellur 2015-10-28 07:47:31 EDT
COMMIT: http://review.gluster.org/12424 committed in release-3.7 by Dan Lambright (dlambrig@redhat.com) 
------
commit 6fcccc0af61b4e11ed9deeb0e4357d0fcfe8401b
Author: Anoop C S <anoopcs@redhat.com>
Date:   Thu Jul 9 11:06:01 2015 +0530

    features/ctr: Reduce the log-level for ctr-disabled message
    
         Backport of http://review.gluster.org/#/c/11592/
    
    Since by default CTR translator is disabled, the following
    log message is being displayed in brick logs.
    
    [ctr-helper.c:256:extract_ctr_options] 0-gfdbdatastore: CTR Xlator is disabled.
    
    Therefore this change is to reduce the log-level to INFO.
    
    >Change-Id: I3b82d6b0dc0445286f91490fb497167a36914a2b
    >BUG: 1241379
    >Signed-off-by: Anoop C S <anoopcs@redhat.com>
    >Reviewed-on: http://review.gluster.org/11592
    >Reviewed-by: Joseph Fernandes
    >Tested-by: Joseph Fernandes
    >Tested-by: NetBSD Build System <jenkins@build.gluster.org>
    BUG: 1275157
    Signed-off-by: Anoop C S <anoopcs@redhat.com>
    (cherry picked from commit b6a7a44079c724cbf6fb24c7ac83892f551dc5f6)
    
    Change-Id: I1bcea5258da525b955606f2353f749b2e37449cc
    Reviewed-on: http://review.gluster.org/12424
    Tested-by: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Dan Lambright <dlambrig@redhat.com>
    Tested-by: Dan Lambright <dlambrig@redhat.com>
Comment 4 Raghavendra Talur 2015-11-17 01:01:01 EST
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.7.6, please open a new bug report.

glusterfs-3.7.6 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://www.gluster.org/pipermail/gluster-users/2015-November/024359.html
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user

Note You need to log in before you can comment on or make changes to this bug.