This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 1275515 - Reduce 'CTR disabled' brick log message from ERROR to INFO/DEBUG
Reduce 'CTR disabled' brick log message from ERROR to INFO/DEBUG
Status: CLOSED ERRATA
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: tier (Show other bugs)
3.1
All All
low Severity low
: ---
: RHGS 3.1.2
Assigned To: Bug Updates Notification Mailing List
Bhaskarakiran
: ZStream
Depends On: 1241379 1275157
Blocks: 1260783 1260923
  Show dependency treegraph
 
Reported: 2015-10-27 02:57 EDT by Anoop C S
Modified: 2016-11-23 18:12 EST (History)
7 users (show)

See Also:
Fixed In Version: glusterfs-3.7.5-5
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 1275157
Environment:
Last Closed: 2016-03-01 00:45:07 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Anoop C S 2015-10-27 02:57:58 EDT
+++ This bug was initially created as a clone of Bug #1275157 +++

Description of problem:
The following error log related to CTR translator is being generated in brick logs at each volume start.

[ctr-helper.c:256:extract_ctr_options] 0-gfdbdatastore: CTR Xlator is disabled.


Version-Release number of selected component (if applicable):
mainline

How reproducible:
Always

Steps to Reproduce:
1. Create and start simple distributed volume.
2. Check the brick logs for the above mentioned message.

Actual results:
Error log entry is seen.

Expected results:
Error log shouldn't be present in brick logs.

Additional info:

--- Additional comment from Anand Avati on 2015-07-09 04:04:41 EDT ---

REVIEW: http://review.gluster.org/11592 (features/ctr: Reduce the log-level for ctr-disabled message) posted (#1) for review on master by Anoop C S (achiraya@redhat.com)

--- Additional comment from Anand Avati on 2015-07-09 15:15:19 EDT ---

COMMIT: http://review.gluster.org/11592 committed in master by Dan Lambright (dlambrig@redhat.com) 
------
commit b6a7a44079c724cbf6fb24c7ac83892f551dc5f6
Author: Anoop C S <anoopcs@redhat.com>
Date:   Thu Jul 9 11:06:01 2015 +0530

    features/ctr: Reduce the log-level for ctr-disabled message
    
    Since by default CTR translator is disabled, the following
    log message is being displayed in brick logs.
    
    [ctr-helper.c:256:extract_ctr_options] 0-gfdbdatastore: CTR Xlator is disabled.
    
    Therefore this change is to reduce the log-level to INFO.
    
    Change-Id: I3b82d6b0dc0445286f91490fb497167a36914a2b
    BUG: 1241379
    Signed-off-by: Anoop C S <anoopcs@redhat.com>
    Reviewed-on: http://review.gluster.org/11592
    Reviewed-by: Joseph Fernandes
    Tested-by: Joseph Fernandes
    Tested-by: NetBSD Build System <jenkins@build.gluster.org>

--- Additional comment from Vijay Bellur on 2015-10-26 03:34:39 EDT ---

REVIEW: http://review.gluster.org/12424 (features/ctr: Reduce the log-level for ctr-disabled message) posted (#1) for review on release-3.7 by Anoop C S (anoopcs@redhat.com)
Comment 6 Bhaskarakiran 2015-11-18 01:03:08 EST
The log message is changed from ERROR to INFO. Verified on 3.7.5-6.


/var/log/glusterfs/bricks/rhs-brick12-vol2-tier2.log-20151108:[2015-11-02 07:02:25.965392] I [MSGID: 121050] [ctr-helper.c:256:extract_ctr_options] 0-gfdbdatastore: CTR Xlator is disabled.
/var/log/glusterfs/bricks/rhs-brick12-vol2-tier2.log-20151108:[2015-11-03 09:03:13.296520] I [MSGID: 121050] [ctr-helper.c:256:extract_ctr_options] 0-gfdbdatastore: CTR Xlator is disabled.


[2015-11-17 13:18:57.755119] I [MSGID: 121050] [ctr-helper.c:256:extract_ctr_options] 0-gfdbdatastore: CTR Xlator is disabled.
[2015-11-17 14:35:36.843984] I [MSGID: 121050] [ctr-helper.c:256:extract_ctr_options] 0-gfdbdatastore: CTR Xlator is disabled.
Comment 8 errata-xmlrpc 2016-03-01 00:45:07 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-0193.html

Note You need to log in before you can comment on or make changes to this bug.