Bug 124251 - can't install fedora core 2 on virtual pc
can't install fedora core 2 on virtual pc
Status: CLOSED DUPLICATE of bug 136018
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
2
i686 Linux
medium Severity high
: ---
: ---
Assigned To: Dave Jones
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-05-24 23:09 EDT by Brian Myers
Modified: 2015-01-04 17:06 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-11-27 17:13:20 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Screen shot showing Fedora Core 2 running properly in Virtual PC 2004 (66.46 KB, image/jpeg)
2004-07-01 23:24 EDT, David Sanders
no flags Details
config-2.6.7 and xorg.conf for working FC2 under Virtual PC (6.13 KB, application/octet-stream)
2004-07-01 23:27 EDT, David Sanders
no flags Details
Screenshot of Fedora Core 3 Test 1 working under Virtual PC 2004 (147.70 KB, image/jpeg)
2004-07-14 20:23 EDT, David Sanders
no flags Details

  None (edit)
Description Brian Myers 2004-05-24 23:09:53 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4.1)
Gecko/20031030

Description of problem:
Attempting to install Fedora Core 2 on a Virtual Pc machine leads
quickly to kernel panic:

Code: 0f 01 c8 8b 43 08 a8 08 75 0c 89 c8 0f 01 c9 8b 43 08 a8 08
<0>Kernel panic: Attempted to kill the idle task! In idle task - not
syncing



Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Launch Virtual PC. Start a new virtual machine choosing "Other" for
OS. I upped the memory allocation from 128k to 256k.
2. Choose Capture ISo image and point the machine to Fedora Core DvD
iso #1.
3. When Fedora reaches the Install: prompt, click OK (with no special
options.
4) Wait.    

Actual Results:  Some data scrolled off the screen too fast for me to
capture it all, but here's the last screenful. 

apm: overridden by ACPI. audit: initializing netlink socket (disabled)
audit(1084995019.304:0): initialized Total HugeTLB memory allocated, 0
vFS: Disk quotas dquot_6.5.1 Dquot-cache hash table entries: 1024
(order 0, 4096 bytes) SELinux: Registering netfilter hooks invalid
operand: 0000 [#1] CPU: 0 EIP: 0060:[<c01040c2>] Not tainted EFlAGS:
00000286 (2.6.5-1.358) EIP is at mwait_idle+0x23/0x40 eax: c031f008
ebx: c031f000 ecx: 00000000 edx: 00000000 esi: 00039100 edi: c034e7a0
ebp: 003b2007 esp: c031ffec ds: 007b es: 007b ss: 0068 Process swapper
(pid: 0, threadinfo=c031f000 task=c02cdaa0) Stack: 00020800 c010408a
c03205fe c034e7c0 c010019f Call Trace: [<c010408a>] cpu_idle+0x1d/0x32
[<c03205fe>] start_kernel+0x174/0x176 

Code: 0f 01 c8 8b 43 08 a8 08 75 0c 89 c8 0f 01 c9 8b 43 08 a8 08
<0>Kernel panic: Attempted to kill the idle task! In idle task - not
syncing

Expected Results:  Install should have continued without hanging.

Additional info:

I'm running Windows XP Pro SP1 on a P4 2.8 ghz with hyper-threading;
1GB ram. I have Virtual PC 2004 (build 582.)

Perhaps it's relevant that I have an ASUS P4P800 SE motherboard, and
that's already known to cause trouble for Fedora Core 2. 

Yes, I did run the checksums to be sure the ISOs I downloaded were
accurate.

Fedora Core 1 installed on Virtual PC 2004 just fine. This problem is new.
Comment 1 Dave Jones 2004-05-25 12:01:16 EDT
can you cat /proc/cpuinfo of the host, and also in virtual pc running
FC1 if possible ?

My hypothesis is that vpc thinks it can use mwait instructions, and it
can't.  You might also try the idle=poll or idle=halt boot parameters.
Comment 2 Brian Myers 2004-05-25 21:56:50 EDT
Here's the cygnus cpuinfo result for the host machine:

/usr/bin$ cat /proc/cpuinfo
processor       : 0
vendor_id       : GenuineIntel
type            : primary processor
cpu family      : 15
model           : 3
model name      :               Intel(R) Pentium(R) 4 CPU 2.80GHz
stepping        : 3
brand id        : 0
cpu count       : 2
apic id         : 0
cpu MHz         : 2806
fpu             : yes
flags           : fpu vme de pse tsc msr pae mce cx8 apic sep mtrr 
pge mca cmov
pat pse36 clfl dtes acpi mmx fxsr sse sse2 ss htt tmi pbe sse3 mon 
dscpl cid
Comment 3 Brian Myers 2004-05-25 21:58:59 EDT
And here's the same info from inside Virtual PC 2004 running Fedora
core  1:

processor       : 0
vendor_id       : GenuineIntel
cpu family      : 15
model           : 3
model name      : Intel(R) Pentium(R) 4 CPU 2.80GHz
stepping        : 3
cpu MHz         : 2637.518
cache size      : 1024 KB
fdiv_bug        : no
hlt_bug         : no
f00f_bug        : no
coma_bug        : no
fpu             : yes
fpu_exception   : yes
cpuid level     : 5
wp              : yes
flags           : fpu vme pse tsc msr pae cx8 sep pge cmov acpi mmx
fxsr sse sse2 pni monitor ds_cpl cid
bogomips        : 5531.23
Comment 4 Brian Myers 2004-05-25 22:13:17 EDT
I tried both idle=poll and idle=boot (separately) at the boot: 
prompt. Both options do take me past the place where I saw kernel 
panic. In both cases the x server started to load and the screen went 
black. In both cases Virtual PC then displayed this dialog box:

An internal virtual machine error (13) has occurred. The virtual 
machine will reset now.

Note that another user reported this "machine error" near the bottom 
of this page:  http://vpc.visualwin.com/Notes/FedoraCore.2.html
Comment 5 Arjan van de Ven 2004-05-26 02:35:31 EDT
the idle thing is clearly a virtual pc bug; it tells teh kernel via
CPU ID that it is capable of mwait, yet when the kernel uses that it
blows up.  (VMWare used to have similar bugs but they fixed that)
Comment 6 Craig Baker 2004-06-01 12:24:39 EDT
Good news: I found that FC2 will install in Virtual PC, go through 
the wizard to create the pc changing nothing but memory allocation... 
Installation will only complete if you use text mode install.

Bad News: 'Segmantation fault' absolutely everywhere. X respawns 
badly, and OS is completely unusable.

So far i cant get it working properly (after 4 installs) in virtual 
pc. - VMWare seems completely unaffected - will let you know after 
this install has finished ;-)


Comment 7 Massimo Caracciolo 2004-06-03 01:31:47 EDT
I have the same behavior of Craig. I can install in text mode, but X 
doesn’t work.

Let me know if some other info is required.
Comment 8 David Sanders 2004-07-01 23:21:01 EDT
Successfull install of FC2 on VPC:
1.  Install in text mode.
2.  On reboot, strange things happen, ignore them.
3.  Replace kernel with a known good Virtual PC .config
4.  Edit xorg.conf to match known good paramaters for VPC.
5.  Reboot.  It works/rocks.
Screen shot provided at: http://www.sandersweb.net/fedora.jpg
Comment 9 David Sanders 2004-07-01 23:24:16 EDT
Created attachment 101581 [details]
Screen shot showing Fedora Core 2 running properly in Virtual PC 2004

Screen shot showing Fedora Core 2 running properly in Virtual PC 2004
Comment 10 David Sanders 2004-07-01 23:27:21 EDT
Created attachment 101582 [details]
config-2.6.7 and xorg.conf for working FC2 under Virtual PC

config-2.6.7 and xorg.conf for working FC2 under Virtual PC
Comment 11 Serge Wenger 2004-07-12 04:20:13 EDT
Hello,

How can I change this files (newbie)? I receive always segmentation error.
Could you please give some tips.

Thanks

Serge
Comment 12 David Sanders 2004-07-13 14:41:06 EDT
Fedora Core 2 Detailed Instructions (57 easy steps) for Virtual PC 2004
1. Download the 4 ISO images.
2. Download http://www.sandersweb.net/vpc.zip
This contains the kernel and some other config files.  It is rather
difficult to compile the kernel on a malfunctioning system so I'm
providing it to you.
3. Place vpc.zip in a shared folder (so we can get it later via samba)
4. Create a virtual machine
5. Boot from first ISO image
6. Type: "linux text" at the boot prompt
7. Select language (english)
8. Select keyboard (us)
9. Select Monitor (LCD Panel 800x600)
10. Select System Type (workstation)
11. Select Disk Partitioning (auto)
12. Select Remove all partitions
13. Select OK to confirm
14. Select bootloader (grub)
15. Select special options (none)
16. Select boot password (none)
17. Select OK to confirm boot loader
18. Select install boot loader into MBR
19. Network config - DHCP - or enter IP address etc.
20. Select hostname (whatever)
21. Select Firewall (enable)
22. Select additional languages (english)
23. Select Time Zone (whatever)
24. Select Root Password (whatever)
25. Select Package Defaults (customize)
26. Package Selection (whatever, except ensure you pick "Windows File
Server" since we will need samba later)
27. Install Media (continue)
28. (format hardisk)
29. (install packages)
30. Reboot
31. SEGMENTATION FAULT (ignore)
You will see a lot of error message, these can be safely ignored.
You may get segmentation faults on some of the below commands, just
try the command again until it works.
32. login as root
33. mount /proc
34. mount /boot
35. mount -o remount,rw /
36. modprobe tulip
37. ifup eth0 boot
38. cd /
39. Now we go get the vpc.zip file.
Type: smbclient //win2ksvr/Share -U david
But replace "win2ksvr" with the name of your computer and "Share" with
the name of your shared folder and "david" with your username on
XP/2000 host.
40. Enter your password for your host computer
41. Type: get vpc.zip
42. Type: quit
43. unzip -o vpc.zip
44. shutdown -r now  (or right-alt-del)
45. (Computer will hang when trying to shutdown)
46. From the VPC menu select Action->Reset
47. (reboots)
48. (Enters graphical setup menu)
49. Agree to the license agreement
50. Enable network time protocal (if you want)
51. Display setup (you can leave this as is for now)
52. Establish an user account
53. <additional CD's> - hit next
54. <finish setup> - hit next
55. Login
56. <All is well with the world>
57. Send me an e-mail to say it worked. 
Comment 13 Serge Wenger 2004-07-14 04:33:54 EDT
Hello David,

First thanks for your help.

I cannot do point 37. I have always a segmentation fault.I put the
vpc.zip file on a CD copy it to / and so on... So it is OK up to point 47.

The problem is that the GRUB startup data are the same as previous. I
must give manually the same params as the /boot/grub/menu.lst and it
start.

I must modify grub.conf, not menu.lst and the right kernel start

Best regards

Serge
Comment 14 David Sanders 2004-07-14 20:21:18 EDT
Fedora Core 3 Test 1 suffers the same problem, to install use
procedure above with added step 43a. 

cp /boot/grub/menu.lst /boot/grub/grub.conf

Bug 119838 should be merged with this one.
Comment 15 David Sanders 2004-07-14 20:23:30 EDT
Created attachment 101927 [details]
Screenshot of Fedora Core 3 Test 1 working under Virtual PC 2004

To install follow procedure in bug report (with added step).
Comment 16 Stephen Renker 2004-07-28 23:18:12 EDT
While it's very nice to have a fixed kernel to install, can we find
out the exact set of changes that are necessary to make it work on
VPC? That would be more helpful to the maintainers to possibly provide
an option in FC3 for the installer to work out of the box.

I'm playing trial and error with compiling kernels and will let
everyone know if I find anything.
Comment 17 Alexander Foygel 2004-08-26 23:31:13 EDT
I can't even get to step #7 - it crashes right after typing 'linux 
text'. Here is what's left on the screen:

apm: overridden by 
ACPI.                                                       
audit: initializing netlink socket 
(disabled)                                  
audit(1093558315.547:0): 
initialized                                           
Total HugeTLB memory allocated, 
0                                              
VFS: Disk quotas 
dquot_6.5.1                                                   
Dquot-cache hash table entries: 1024 (order 0, 4096 
bytes)                     
SELinux:  Registering netfilter 
hooks                                          
invalid operand: 0000 
[#1]                                                     
CPU:    
0                                                                     
 
EIP:    0060:[<c01040c2>]    Not 
tainted                                       
EFLAGS: 00000286   (2.6.5-
1.358)                                               
EIP is at 
mwait_idle+0x23/0x40                                                 
eax: c031f008   ebx: c031f000   ecx: 00000000   edx: 
00000000                  
esi: 00039100   edi: c034e7a0   ebp: 003b2007   esp: 
c031ffec                  
ds: 007b   es: 007b   ss: 
0068                                                 
Process swapper (pid: 0, threadinfo=c031f000 
task=c02cdaa0)                    
Stack: 00020800 c010408a c03205fe c034e7c0 
c010019f                            
Call 
Trace:                                                                
    
 [<c010408a>] 
cpu_idle+0x1d/0x32                                               
 [<c03205fe>] 
start_kernel+0x174/0x176                                         
                                                                      
         
Code: 0f 01 c8 8b 43 08 a8 08 75 0c 89 c8 0f 01 c9 8b 43 08 a8 
08              
 <0>Kernel panic: Attempted to kill the idle 
task!                             
In idle task - not 
syncing                                                     
===================================================

I've tried loading a VM created on a different computer using the 
patch mentioned above. That VM works on the other computer, but if I 
try loading it on mine, it crashes with the following info left on 
the screen:

ock.                                                                  
         

eth0: Digital DS21140 Tulip rev 32 at 0xec00, 00:03:FF:8C:72:5D, IRQ 
11.       

Uniform Multi-Platform E-IDE driver Revision: 
7.00alpha2                       

ide: Assuming 33MHz system bus speed for PIO modes; override with 
idebus=xx    

invalid operand: 0000 
[#1]                                                     

Modules linked 
in:                                                             

CPU:    
0                                                                     
 

EIP:    0060:[<c01020c9>]    Not 
tainted                                       

EFLAGS: 00000246   
(2.6.7)                                                     

EIP is at 
mwait_idle+0x21/0x46                                                 

eax: c03dc008   ebx: c03dc008   ecx: 00000000   edx: 
00000000                  

esi: c03dc000   edi: c0408b60   ebp: 0044d007   esp: 
c03ddfd0                  

ds: 007b   es: 007b   ss: 
0068                                                 

Process swapper (pid: 0, threadinfo=c03dc000 
task=c0387a40)                    

Stack: c03dc000 00099100 c010209f 01020800 c03de6ce c0387a40 00000000 
c0401198 

       00000038 c03de44b c0408b80 
c010019f                                     

Call 
Trace:                                                                
    

 [<c010209f>] 
cpu_idle+0x2c/0x35                                               

 [<c03de6ce>] 
start_kernel+0x147/0x163                                         

 [<c03de44b>] 
unknown_bootoption+0x0/0x110                                     

                                                                      
         

Code: 0f 01 c8 8b 46 08 a8 08 75 0c 89 c8 0f 01 c9 8b 46 08 a8 
08              

 <0>Kernel panic: Attempted to kill the idle 
task!                             

In idle task - not 
syncing                                                     
==============================================

Any suggestsion? The computer is Dell Dimension 4600 with 2.8 GHz 
with HT, 1 GB or RAM.
Comment 18 David Sanders 2004-09-27 14:17:55 EDT
The kernel panic above appears to occur only with the Prescott P4
processors.  This is a seperate issue and should be a seperate entry
in bugzilla.
Comment 19 Krzysztof 2004-10-08 22:21:29 EDT
#13, I'm getting the same problem at part 37, how exactly did you fix 
it?
Comment 20 Krzysztof 2004-10-09 01:11:37 EDT
Got it working. Turns out that whole 57step process is unnecessary. 
All that had to be done to install it was the following (taken from 
dotnetjunkies.com)

-at the login prompt after the X-Server crash, login as root 
-use vi (or similar) to edit the X-Server configuration file 
(/etc/X11/xorg.conf )
go to the "Screen" section, search the line DefaultDepth 16 and 
change the value to DefaultDepth 24.
-save the xorg.conf file and restart all (just type reboot). 
Comment 21 David Sanders 2004-10-16 16:04:58 EDT
Re Comment #19 Krzysztof, at step 37, if you get segmentation fault
errors, keep trying until it works.

Re Comment #20 VPC does not support 24 bit color so your procedure is
unlikely to work.
Comment 22 Krzysztof 2004-10-19 20:23:29 EDT
Well, It did work for me. I don't know why or how... but it does. It 
also worked for the people who replied to the post I got this from ( 
http://dotnetjunkies.com/WebLog/demiliani/archive/2004/06/28/17731.asp
x ).
Comment 23 BRUCE REYNOLDS 2004-10-21 15:43:57 EDT
Under Virutal PC, is it possible to update the kernel?

I followed the 57-step procedure, and got FC2 running (kernel 2.6.7). 
Then I connected to the update site, and downloaded the current 
latest kernel (currently 2.6.8-1.251). The new kernel did not boot or 
run. 

What can I do to keep up-to-date with kernel updates? Will I need to 
rebuild the kernels myself? What do I change before building so that 
the kernel will run on Virtual PC?

Thanks,
Bruce
Comment 24 David Sanders 2004-10-24 18:31:31 EDT
Well, ... that is actually a good question.  If we knew the exact
problem we would fix it and the 57-step procedure would not be needed.
 The only upgrade path currently for FC2 is to build an updated
kernel.  The zip file you used in the 57-step procedure includes the
kernel configuration.  That can be used to build a new kernel (by
copying it to .config in the kernel tree).  A different (updated)
kernel will be provided for FC3 when it is available.  Hope that helps....
Comment 25 David Sanders 2004-10-24 22:07:39 EDT
Re Comment #22 Krzysztof, I looked a the web page you linked to.  The
suggested procedure is in regards to VMWare Workstation not Microsoft
Virtual PC.  I tried it anyway just to be sure, it doesn't help.  This
bug is about Virtual PC not VMWare (there may be a seperate bug, I
don't know).
Comment 26 Deepa M 2004-10-26 19:12:12 EDT
I was able to follow steps up untill Step #30. After rebooting, it 
again goes back to install mode seen in Step #6! And, i do not see 
any errors... any idea?

Thanks.
Comment 27 David Sanders 2004-10-27 15:14:29 EDT
Re Comment #26 Deepa, most likely you still have the install CD
captured when rebooting.  There should perhaps be a step that says
"release install CD using the VPC menu".
Comment 28 Deepa M 2004-10-27 20:47:28 EDT
Thansk David. I tried "CD -> Release CD" option. But did not fix it. 
So, i tried creating a new vitual machine and followed installation 
procedure everytime i had the problem. Now, I am through that step.  
Now, at step 39 - I get the following error

"ERROR: Could not determine network interfaces, you must use a 
interfaces config line"

Also, i followed step 37 until it worked. 

Comment 29 David Sanders 2004-10-28 12:11:22 EDT
Re Comment #28, Deepa, The network isn't getting setup right on your
machine.  Follow these steps when you get to step 39:
a. Download http://www.sandersweb.net/vpc.iso
b. Capture the CD image (CD->Capture ISO image->vpc.iso)
c. mount -t iso9660 /dev/hdc /mnt
d. cp /mnt/vpc.zip /
e. cd /
f. continue with step 43
Good Luck, David
Comment 30 Deepa M 2004-10-28 19:48:41 EDT
Re Comment #29, Thank you David. ISO image was really helpful. All is 
well and I have the Fedora [GUI] up and running. I presume vpc.iso is 
an exact of vpc.zip in ISO format. 

Couple of things: 

1. I tried doing Step 33-39 everytime i rebooted. Is that necessary? 

2. Fedora [GUI] started up on Virtual PC 2004. But, the mouse does 
not seem to be responsive/sensitive enough [rather it is too 
sensitive]. Is there any specifc configuration to fix that? 

Thanks.
Comment 31 David Sanders 2004-11-02 14:31:45 EST
1. I'm not sure what you mean by "everytime I rebooted", but I think
you probably needed the various steps each time.
2. I don't know how to adjust mouse responsiveness, sorry.
Comment 32 David Sanders 2004-11-03 15:25:05 EST
The problem has been determined to be the 4G/4G patch included in the
redhat supplied kernels.  Compiling a kernel without 4g4g mode fixes
the problem.
Comment 33 Dave Jones 2004-11-27 17:13:20 EST

*** This bug has been marked as a duplicate of 136018 ***
Comment 34 ado 2004-12-09 09:54:56 EST
You all here talk to much ... the big bug in fedora core 3 with
virtual pc is this problem

Code: 0f 01 c8 8b 43 08 a8 08 75 0c 89 c8 0f 01 c9 8b 43 08 a8 08
<0>Kernel panic: Attempted to kill the idle task! In idle task - not
syncing

It apears at startup. I cant get even to step 4 or 5 in the
installation steps. Now i'm wondering if this error apears only on
Intel p4 processors with HT or even on amd procesors? Something must
be wrong with the mwait function? Mailto<mustafic@gmail.com>
Comment 35 Mogens Sorensen 2004-12-13 12:06:07 EST
This is a Virtual PC problem and is solved in Virtual PC 2004 SP1, 
available here: 

http://www.microsoft.com/windows/virtualpc/downloads/sp1.mspx

Make sure you read the ReadMe file before upgrading.
Comment 36 ado 2004-12-14 08:21:01 EST
Mogens Sorensen, thnaks, that worked just fine ;-)
The only problem is that some Os-es(most of them linux) that reported
kernel panic, didn't worked but then with the option linux text worked
fine. Thanks, ado
Comment 37 ado 2004-12-14 14:27:28 EST
And that kernel-image of yours, it's kind'a bad. It has no ipv6
support. Only a suggestion to build that in. ;-)

Note You need to log in before you can comment on or make changes to this bug.