Bug 1244930 - Dropdown boxes on RHEVM not rendered properly in Chromium
Summary: Dropdown boxes on RHEVM not rendered properly in Chromium
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine
Version: 3.5.1
Hardware: Unspecified
OS: Linux
unspecified
high
Target Milestone: ovirt-3.6.0-rc
: 3.6.0
Assignee: Alexander Wels
QA Contact: Petr Kubica
URL:
Whiteboard:
Depends On:
Blocks: 1247662
TreeView+ depends on / blocked
 
Reported: 2015-07-20 19:20 UTC by Bryan Yount
Modified: 2019-08-15 04:55 UTC (History)
10 users (show)

Fixed In Version: ovirt-engine-3.6.0-0.0.master.20150412172306.git55ba764
Doc Type: Bug Fix
Doc Text:
Clone Of:
: 1247662 (view as bug list)
Environment:
Last Closed: 2016-03-09 21:09:57 UTC
oVirt Team: UX
mgoldboi: Triaged+


Attachments (Terms of Use)
RHEV-M dropdown box displayed in Chromium 43 on RHEL 7 (49.16 KB, image/png)
2015-07-20 19:20 UTC, Bryan Yount
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2016:0376 normal SHIPPED_LIVE Red Hat Enterprise Virtualization Manager 3.6.0 2016-03-10 01:20:52 UTC
oVirt gerrit 36134 None None None Never
Red Hat Knowledge Base (Solution) 736253 None None None Never
Red Hat Bugzilla 1173660 None None None Never

Internal Links: 1173660

Description Bryan Yount 2015-07-20 19:20:04 UTC
Created attachment 1054020 [details]
RHEV-M dropdown box displayed in Chromium 43 on RHEL 7

Description of problem:
Using the latest Google Chrome (Fedora, RHEL, Windows, and OS X), dropdown boxes are not properly rendered which causes the admin to think that additional selections are not available.

Version-Release number of selected component (if applicable):
  rhevm-webadmin-portal-3.5.3.1-1.4.el6ev.noarch
  Chromium 43.0.2357.132 on RHEL 7.1

How reproducible:
  Very

Steps to Reproduce:
1. Log into RHEV-M admin portal
2. Locate a datacenter with more than 1 logical network
3. Go to a virtual machine and click on its network tab
4. Add a vNIC
5. Click on the dropdown box for "Profile" to pick a logical network.

Actual results:
  Only 1 network is visible, usually "rhevm"

Expected results:
  All available networks should be shown.

Additional info:
  The dialog box is not properly rendered by any Webkit-based browser, Chrome or Safari. See attachment.

Comment 1 Einav Cohen 2015-07-20 20:51:21 UTC
Bryan, can you please test in latest ovirt 3.6? this may be a "duplicate" of bug 1173660. thanks.

Comment 2 Bryan Yount 2015-07-20 21:11:53 UTC
(In reply to Einav Cohen from comment #1)
> Bryan, can you please test in latest ovirt 3.6? this may be a "duplicate" of
> bug 1173660. thanks.

This appears to be resolved in both Chrome and Safari on OS X with RHEV 3.6. Thanks Einav!

Comment 3 Yaniv Lavi 2015-07-21 04:47:28 UTC
Is this a safe change to backport to 3.5.5?

Comment 4 Einav Cohen 2015-07-21 13:28:18 UTC
(In reply to Yaniv Dary from comment #3)
> Is this a safe change to backport to 3.5.5?

@Alexander - thoughts?

Comment 5 Alexander Wels 2015-07-21 13:30:23 UTC
Yes its a fairly small change, should be safe to backport if needed.

Comment 6 Einav Cohen 2015-07-21 13:35:45 UTC
(In reply to Alexander Wels from comment #5)
> Yes its a fairly small change, should be safe to backport if needed.

Thanks, Alexander.

@Yaniv - feel free to target for 3.5.z if you'd like (3.5.5 seems reasonable at this point, I think?), I can clone the BZ once it is fully acked.

Comment 8 Petr Kubica 2015-07-29 10:37:19 UTC
Verified in 3.6.0-0.0.master.20150627185750.git6f063c1.el6
chromium: 43.0.2357.132

Comment 11 errata-xmlrpc 2016-03-09 21:09:57 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHEA-2016-0376.html


Note You need to log in before you can comment on or make changes to this bug.