Bug 125416 - Second NIC not detected on Tyan S2707G2N
Second NIC not detected on Tyan S2707G2N
Status: CLOSED DUPLICATE of bug 124572
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
2
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Arjan van de Ven
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-06-06 12:39 EDT by Eric Karlson
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 14:03:58 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Eric Karlson 2004-06-06 12:39:36 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6) Gecko/20040510

Description of problem:
I took a system that was running a 2.4 kernel and tried to install
Fedora Core 2 over it (straight install, not an upgrade).  The Fedora
Core 2 only detected the Intel 82540EM NIC that is built into the
S2707G2N motherboard.  The Intel 82545EM NIC was not detected.  After
a while, I gave up on Fedora Core 2 and re-installed RedHat 9 over
Fedora Core 2.  After the re-install or RedHat 9 over Fedora, both
NICs were once again detected and functioning perfectly.

System Details:

(Note - I have actually two systems that are essentially the same.  I
have seen this problem on both systems.  The only difference between
then is that one has the 3ware 7500-8 adapter, and the other was a
3ware 9500S-8)

Tyan S2707G2N M/B (with latest BIOS v1.07) [all jumpers in their
default position]
512MB DDR266 ECC, Registered RAM (Corsair)
3ware 7500-8 (last firmeware from v7.7.0 release)
Maxtor 40GB UDMA133 IDE drive
3.5" Floppy
52X IDE CD-ROM (Memorex)

The 3ware card is installed in the first PCI-X slot (the one that does
*not* share a PCI bus with the embedded NIC).

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Install Fedore Core 2 onthe system above


Actual Results:  Fedora Code 2 installs, but second NIC is not detected.

Expected Results:  Expected that the second NIC would be detected

Additional info:
Comment 1 Eric Karlson 2004-06-06 12:43:56 EDT
One thought just occured to me here.  The NIC that is not being
detected is on the 64-bit PCI-X bus.  The one that is detected is on
the 32-bit PCI bus (the motherboard has three separate PCI busses). 
If you look at my other bug (#125412), the 3ware card that is not
being detected was also plugged into a PCI-X slot.  Maybe something
changed with the 2.6 kernel such that the PCI-X buses are not being
detected anymore?
Comment 2 Eric Karlson 2004-06-06 13:12:32 EDT
One thought just occured to me here.  The NIC that is not being
detected is on the 64-bit PCI-X bus.  The one that is detected is on
the 32-bit PCI bus (the motherboard has three separate PCI busses). 
If you look at my other bug (#125412), the 3ware card that is not
being detected was also plugged into a PCI-X slot.  Maybe something
changed with the 2.6 kernel such that the PCI-X buses are not being
detected anymore?
Comment 3 Arjan van de Ven 2004-06-06 13:37:23 EDT
it could be that acpi is ruining the game, could you try acpi=off ?
Comment 4 Eric Karlson 2004-06-08 15:09:01 EDT
Interesting.  Turning off the ACPI support does prevent this 
problem.  It also solves the problem I reported in BZ# 125412.

'Course, it means that I can't get ACPI support running, which is a 
bit of a problem for an SMP system as that is the only way that I can 
get power management.  For the time being, I can work with things 
this way, but I would really like to get *both* ACPI *and* my 
NIC/3Ware hard running at the same time.

Some other data points from various experiments I ran:

Problem also occurs with a stock 2.4.26 kernel installed on top of a 
RedHat 9 installation.  Turning off ACPI "fixes" the problem here as 
well.

Problem also occurs with a stock 2.6.6 kernel installed on top of a 
Fedora Core 2 installation.  Turning off ACPI "fixes" the problem 
here as well.
Comment 5 Len Brown 2004-06-08 20:29:06 EDT

*** This bug has been marked as a duplicate of 124572 ***
Comment 6 Red Hat Bugzilla 2006-02-21 14:03:58 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.