Bug 1245981 - forgotten inodes are not being signed
Summary: forgotten inodes are not being signed
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: GlusterFS
Classification: Community
Component: bitrot
Version: mainline
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: bugs@gluster.org
QA Contact:
bugs@gluster.org
URL:
Whiteboard:
Depends On:
Blocks: 1245165 1247551
TreeView+ depends on / blocked
 
Reported: 2015-07-23 09:05 UTC by Raghavendra Bhat
Modified: 2016-06-16 13:26 UTC (History)
1 user (show)

Fixed In Version: glusterfs-3.8rc2
Doc Type: Bug Fix
Doc Text:
Clone Of:
: 1247551 (view as bug list)
Environment:
Last Closed: 2016-06-16 13:26:24 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)

Description Raghavendra Bhat 2015-07-23 09:05:21 UTC
Description of problem:

If a object gets modified, then bit-rot-stub sends a notification to BitD to sign the object. BitD waits for sometime before signing the object so that if any modification happens within that time interval, it need not sign multiple times. And once the object is signed, its inode context is changed to indicate that, the inode is now in its default state.

But if the inode gets forgotten after sending the sign notification to BitD, but before getting sign request, then when the sign request comes, the inode context says inode is in default state (instead of modified state) and does not sign the object.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 1 Anand Avati 2015-07-24 09:15:45 UTC
REVIEW: http://review.gluster.org/11729 (features/bit-rot-stub: handle REOPEN_WAIT on forgotten inodes) posted (#2) for review on master by Raghavendra Bhat (raghavendra@redhat.com)

Comment 2 Anand Avati 2015-07-27 06:22:13 UTC
REVIEW: http://review.gluster.org/11729 (features/bit-rot-stub: handle REOPEN_WAIT on forgotten inodes) posted (#3) for review on master by Venky Shankar (vshankar@redhat.com)

Comment 3 Anand Avati 2015-07-27 08:33:13 UTC
REVIEW: http://review.gluster.org/11729 (features/bit-rot-stub: handle REOPEN_WAIT on forgotten inodes) posted (#4) for review on master by Raghavendra Bhat (raghavendra@redhat.com)

Comment 4 Nagaprasad Sathyanarayana 2015-10-25 14:47:17 UTC
Fix for this BZ is already present in a GlusterFS release. You can find clone of this BZ, fixed in a GlusterFS release and closed. Hence closing this mainline BZ as well.

Comment 5 Niels de Vos 2016-06-16 13:26:24 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.8.0, please open a new bug report.

glusterfs-3.8.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://blog.gluster.org/2016/06/glusterfs-3-8-released/
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user


Note You need to log in before you can comment on or make changes to this bug.